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Before you begin 
This manual was written for IrriMAX Version 9.1.  

The manual contains the following sections: 
• Using IrriMAX 
• Software Reference Guide 
• Troubleshooting 
• Frequently asked questions 

 
The Using IrriMAX section describes how IrriMAX is used to analyze soil moisture and provides an 
overview of the IrriMAX software. The basic steps for checking current soil moisture and soil moisture 
trends are described in this section. 

The Software Reference Guide section describes the function and controls of each window in IrriMAX. 

Conventions 
The following conventions are used throughout this guide. 

Mouse actions: 
• 'Click' means to click and release (without moving the mouse between these actions) the primary 

button on your mouse. This is usually the left mouse button unless you have configured it 
differently in Control Panel. 

• 'Double-click' means to quickly click the primary mouse button twice. 
• 'Right-click' means to click the secondary mouse button, usually the right button. 
• 'Drop-down list' means to click on the down pointing arrow next to a text box. This drops a list of 

items from which you can select an option. 
• 'Point' means to move the mouse until the cursor moves on top of an item on the screen. 
• 'Click and drag' means to click and hold the left mouse button; then move the mouse to drag an 

item (or border) to the required position; now release the button. 
 

Convention Type of information 

Icons Icons represent: 
• buttons on a toolbar that you click to choose commands 

quickly 
• icons on the desktop that you can double click to open 

software 
• Minimized IrriMAX windows, that appear above the 

Taskbar 
Small Caps Small capitals are used for: 

• keyboard shortcut keys; for example, 'Press SHIFT+F1' 
• filenames; for example, 'DATABASE.SDB' 

Arrow bullet (Ø) Step by step process. These processes are written based on the 
menu commands. The commands may also be completed using 
the equivalent buttons or shortcut keys as appropriate. 

Bold text Bold text is used for: 
• menu items and tool buttons that you click to run a 

program command; for example, 'From the Menu bar, 
click Help' 

• for emphasis; for example, 'Note:...'. 
This font face This font face is used for window, dialog and message box titles; 

for example, 'The Site Configuration window displays'. 

It is also used to cross reference to sections of this manual. 
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Convention Type of information 

Square brackets Square brackets are used for non-specific text, file names or 
paths; for example, '[file name] is not a valid logger image file'. 

Note: Text presented under the heading 'Note:' is important information 
that should be considered before completing an action. 

Warning: Text presented under the heading 'Warning:' is critical 
information that must be considered before completing an action. 

What's included in the IrriMAX package? 
IrriMAX is supplied on a Compact Disc (CD) or as an Internet download (about 18MB) and it includes: 

1. The IrriMAX programs:  
IrriMAX 
Database Manager 
Data Exchange 
Database Entry 
Logger Manager 
Remote Connection Manager (RCM)  
Database Converter 
Logger Download (this version 5 only runs in command line mode)  
Logger Download version 4.1 (the superseded ESW 4.1 version)  
AutoSDB (programming tool) 

2. License agreement (selectable Australia or US and other countries) 

3. Readme.txt file, containing installation instructions, known problems and things discovered after 
this manual was prepared 

4. An Installer, to setup IrriMAX on your computer 

5. Manuals (User guides) for each of the programs, in PDF format (Adobe Portable Document Format) 
and selected resource documents e.g. case studies. 

6. Online help file for each of the programs 

7. Example databases and workspaces with graphs and layouts 

8. Calibration.ini and Calibration-ReadMe.txt files, describing alternatives to the default Sentek 
calibration coefficients 

9. HTML templates for use by the Webify and email feature of workspaces and graphs. 

10. A License certificate which includes a unique serial number that must be entered during the 
Registration process. 

 

If you require more information about other products and services provided by Sentek Pty Ltd 
visit the web site at www.sentek.com.au. 

System Requirements 
To run the IrriMAX software.you require a minimum of a 900 MHz processor, 128 MB RAM and one of 
the following versions of Microsoft Windows: 

• Windows 7 
• Windows Vista with Service Pack 2 or later (all editions except Starter Edition) 
• Windows Server 2003 with Service Pack 2 or later (all editions) 
• Windows Server 2003 R2 or later (all editions) 
• Windows Server 2008 with Service Pack 2 or later 

http://www.sentek.com.au
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• Windows Server 2008 R2 
• Windows XP with Service Pack 3 (except Starter Edition) 

 
A typical installation requires approximately 30 MB of hard disk space. 

A video display supporting at least 1024 x 768 pixels is recommended for ease of interpreting IrriMAX 
graphs. 

Microsoft Excel 97 or Office 97 or later is required if Excel workbook support is required in Data 
Exchange. 

Viewing of the printable version of the manuals requires PDF viewing software such as Adobe Reader. 

Referenced Manuals 
Other Sentek manuals that may be of interest to IrriMAX users include: 

• Calibration of Sentek Pty Ltd Soil Moisture Sensors 
The methodology recommended by Sentek for soil moisture instrument calibration 

• Sentek EnviroSCAN Hardware Manual 
This covers the installation and use of EnviroSCAN RT6 loggers, probes and sensors 

• Sentek EnviroSCAN Plus Hardware Manual 
This covers the installation and use of EnviroSCAN Plus web enabled, wireless communications. 

• Sentek Diviner 2000 User Guide 
This covers the installation and use of Diviner 2000 display unit and probe. It also covers the 
Diviner 2000 software utilities for backup and restoring Diviner 2000 data. 

• TriSCAN Agronomic User Manual 
This manual covers the monitoring, understanding and management of the Sentek 
fertilizer/salinity and soil water monitoring system. 

• AutoSDB2 Programmers' Manual 
This manual is programmer oriented and describes the interface between third-party developed 
software and IrriMAX. 

 
The AutoSDB2 manual is available in the folder where IrriMAX is installed (typically C:\Program 
Files\Sentek\IrriMAX\AutoSDB2\AutoSDB2_Manual.pdf). The other manuals are available on the 
Sentek Resource Kit CD. 

Installing IrriMAX 
The IrriMAX installation process detects previous installations of EnviroSCAN or IrriMAX and will 
install the new version over the top of the previous version.  

There are two ways of getting the IrriMAX installation media: 
• Obtain an IrriMAX Compact Disc (CD) 

This CD contains the IrriMAX installer, How to use IrriMAX, Internet Explorer Installer, 
Acrobat Reader installer, and Sentek Resources documents. 

• Download the IrriMAX installer file from the Sentek web site http://www.sentek.com.au using 
link to Downloads. The file size is about 18MB, so the download may take a long time on a dial-
up connection. The file does not contain the support files that are present on the IrirMAX CD. 

 

Ø  To install IrriMAX from the Internet download file 
1. Download the IrirMAX installer and related files from the downloads section of theSentek web site, 

http://www.sentek.com.au using link Downloads and save them in a convientient folder on your 
computer eg. My Downloads. 
- IrriMAX80_Setup.exe (about 18 Megabytes)  
- Calibration-ReadMe.txt, Calibration.ini and Rcm80.ini (these may have additional information if 
you are upgrading) 

2. Double-click on Readme.txt and check for last minute changes etc. 

http://www.sentek.com.au
http://www.sentek.com.au
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3. Login as a user with Administration privileges. 
Double-click on the IrriMAX80_Setup.exe and the setup program will start. 

4. Follow the instructions below for the Steps common to download and CD install 

 

Ø  To install IrriMAX from the CD 
1. Login as a user with Administration privileges 

Place the IrriMAX CD in your CD/DVD drive and the setup menu will appear. 

2. If the Setup menu does not appear, the Windows autorun facility may be disabled. In this case: 

• On the Windows task bar click the Start menu and select Run.... 
• On the Run dialog type "d:\menu.exe" (where d: is the drive letter of your CD/DVD drive) and 

click OK 
The IrriMAX 9 CD menu appears: 

 

3. Click on the View ReadMe.txt button and check for last minute changes etc. 

4. Click the Install IrriMAX 9.1 button and follow the instructions below for the Steps common to 
download and CD install 

 

Ø  Steps common to download install and CD install 
5. The Welcome window is displayed. 

Read the welcome message and click Next to continue. The Installer will check your system for the 
minimum requirements and look for an existing installation of the software. 

6. The Customer Information window is displayed. 
Enter your name and the name of your company and click Next. 

7. The License Agreement window is displayed. 
Select your country and click Next to continue 
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8. The appropriate Software License Agreement is displayed. 
Select the button to accept the license agreement, then click Next to continue.  

9. The Choose Destination Location window is displayed. 
(If you are upgrading an existing IrriMAX installation, this step is skipped.) 
It is recommended that you accept the proposed installation folder. To change it, click the Change 
button. Click Next to continue. 

10. The Select Features window is displayed. 
(If you are upgrading an existing IrriMAX installation, this step is skipped. You can add or remove 
features by running the Installer again and choosing the Modify option, once the upgrade has 
completed) 
Select the features you want to install, and deselect the features you do not want to install. Click on 
a feature's name to read a description of that feature. Click Next to continue. 

11. The Start Copying Files window is displayed. 
Review your settings and click Back if any are incorrect. Click Next to begin the installation 
process. 

12. The progress meter displays and the IrriMAX files are installed. 

13. The InstallShield Wizard Complete window is displayed. 
You can automatically view the Read Me file or run IrriMAX by selecting the appropriate check 
boxes. 
Click Finish to exit the wizard. 

14. The installation process is now complete. If you wish, you can now logout from the Administrator 
login and log back in as a normal user, and start IrriMAX. 

Uninstalling IrriMAX 
If you wish to completely remove IrriMAX from your computer it can be done using the Windows 
Control Panel. 

Note: 
Removing IrriMAX does not remove existing user data. Workspaces, databases, graphs, 

layouts, log files, license files and configuration files are all retained.  

Ø  To uninstall IrriMAX from Windows Vista or Windows 7 
1. From the Start menu, select Control Panel 

2. Depending on your chosen view, select either Uninstall a Program (in the programs category) or 
Programs and Features. 

3. In the list of software, select "IrriMAX" and click the Uninstall button (Windows Vista) or the 
Uninstall/Change button (Windows 7). 

4. Select the Remove option and click Next to continue. 

5. Respond Yes to the message "Do you want to completely remove the selected application and all of 
its features" 

5. The uninstall process then displays the steps in the removal progress 

6. Some user files may prevent removal of some folders. Clicking the Details button will list these 
folders 

 

Ø  To uninstall IrriMAX from Windows XP 
1. From the Start menu, select Settings, and select Control Panel 

2. In the Control Panel, open Add/Remove Programs 
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3. In the list of software, select "IrriMAX" and click the Add/Remove button 

4. Select the Remove option and click Next to continue. 

5. Respond Yes to the message "Do you want to completely remove the selected application and all of 
its features" 

5. The uninstall process then displays the steps in the removal progress 

6. Some user files may prevent removal of some folders. Clicking the Details button will list these 
folders 

 

Registration and Licensing 
License management in IrriMAX requires that every installation of IrriMAX be registered with Sentek. 
A trial period of 30 days is available for evaluation and the email delays in obtaining a registration site 
key.  

Warning: 
Uninstalling or removing IrriMAX will not renew the 30-day trial period. The registration site 

code and site key are specific to your computer and will not work on another computer. 
Computer clock changes may result in immediate termination of the trial period, making IrriMAX 
unusable until a site key is entered and validated. Until you have registered IrriMAX you should 

not change the computer clock by more that 75 minutes. 

Until IrriMAX is registered, a Registration and Licensing dialog appears every time IrriMAX is started. 
This dialog has the options to Register Now, Register Later or Transfer License. When you select 
Register Now you must fill in the registration details and either: 

• Automatically email the information 
• Print the information for faxing 
• View the information and manually copy it to your email program 

 
You can also choose "Register Now" to update details you have previously sent to Sentek, such as your 
contact address or mailing list preferences. 

Choosing "Register Later" allows IrriMAX to fully operate, but unless it is registered IrriMAX will stop 
working 30 days after the first time it is run. 

Choosing "Transfer License" allows you to move a license from IrriMAX on one computer to another 
computer. After this is done IrriMAX will no longer operate on the first computer. 

How to register IrriMAX 
You can register IrriMAX at any time, even after the trial period has expired.  

Ø  To register IrriMAX 
1. If you are not licensed yet the Registration & Licensing dialog will appear whenever you start 

IrriMAX. Alternatively, it can be invoked by choosing Licensing IrriMAX… from the Help menu 
in Workspace Manager. 
The instructions and information presented by the Registration & Licensing dialog will vary 
depending on your current license state. The image below shows how it appears if you have not yet 
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installed a full license. 

 

2. Click the Register Now button. 
The Registration Details dialog appears. 

 

3. Enter the appropriate text and select either E-mail or Print/Fax or Copy/Paste. This information 
together with the IrriMAX version and registration Site Code will be composed into either an 
automatic email message, a printed document, or plain text that be copied into your email program. 

About Serial Numbers 
The dialog will verify that you have entered a correct serial number. This unique serial number is 

specified on the licence certificate which was supplied with the IrriMAX package and is 
comprised of sixteen capital letters, optionally split into groups using spaces or dashes. 

 
If you are upgrading from an earlier version of IrriMAX, please enter your previous Serial 

Number in the Old Serial Number field. 
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Some add-on components of IrriMAX may be separately licensed. Enter the serial numbers for 
these in the Add-on Serial(s) field, separated by commas. 

4. Click the OK button. 

a)  If E-mail was selected a message will be sent to registrations@sentek.com.au. The email may be 
viewed in the Sent Items folder of your email program. 

Note: 
Some email programs warn that an automatic email may contain a virus. You can the preview 

the email before sending or select Send anyway. 

b) If Print/Fax was selected a single page will be printed on your default printer. You can then fax the 
page to the Fax number on the page. 

5. After sending the request you can continue to use IrriMAX by clicking the Register Later button, 
until you receive a response from the Sentek Registrations department. 

6. When you receive the Site Key from the Sentek Registrations department (email or FAX), start 
IrriMAX and on the Registration and Licensing dialog type (or copy/paste from the email) the 
supplied site key into the Site Key text box (spaces are not significant). 
Click the Validate button.  
You will get the message: "Your Site Key has been validated. Thank you for choosing a Sentek 
product." Registration is now complete, and the Registration & Licensing dialog will no longer 
appear at startup. 

 
If you receive an error message check the reasons in section Troubleshooting Registration and Licensing 
Page 202. 

How to transfer a license from one copy of IrriMAX to another 
It is possible to transfer a license from a fully licensed copy of IrriMAX into an unlicensed copy on 
another machine. Both copies of IrriMAX must be the same version. The process does not require that 
you obtain a new Site Key from Sentek. 

You will require an external storage device (for example a floppy disk or USB memory key) or a shared 
network folder to store the license files during the transfer process.  

This is a three step process: 
1. Preparation of a transfer folder on the new computer 

2. Putting the old computer's license into the transfer folder 

3. Extracting the license from the transfer folder onto the new computer. 

 

Ø  To perform a license transfer 
1. On the computer with the unlicensed copy of IrriMAX, choose Licensing IrriMAX... from the 

Help menu of the workspace manager window to invoke the Registration & Licensing dialog. This 
dialog also appears each time you start an unlicensed copy of IrriMAX. 

2. Click the Transfer License In... button and follow the directions to prepare a folder for license 
transfer. The folder can be on a network, floppy disk or other removable storage device (such as a 
USB memory key). It must be writable by both copies of IrriMAX. 

Warning: 
There can only be one outstanding transfer for any given unlicensed copy of IrriMAX. This 
means that once a folder is prepared for license transfer, you must complete the remaining 

steps successfully. If you lose the contents of the folder, you will need to obtain a Site Key from 

mailto:registrations@sentek.com.au
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Sentek. 
Hidden system files are generated in this folder, so you must copy the whole folder. 

3. On the computer with the licensed copy of IrriMAX, choose Licensing IrriMAX… from the Help 
menu of the workspace manager window. 

4. Click the Transfer License Out... button and follow the directions to write the license to the folder 
you prepared in step 3. Your old copy of IrriMAX is now unlicensed and will cease to function. 

5. On the computer with the unlicensed copy of IrriMAX, click the Transfer License In... button and 
follow the directions to import the license. 

 

What's new in IrriMAX 9.1? 
This section is intended for users familiar with IrriMAX 9.0. It describes new features and changes that 
have been introduced to the software with the release of IrriMAX 9.1. 

Packages 
A package is a compressed archive of all files used by a workspace or graph, intended to facilitate easy 
exchange of IrriMAX files. IrriMAX can extract the contents of the package to a chosen location, and 
then open them automatically. 

Packages can be created either manually from the workspace or graph File menus, or automatically as 
attachments when using the Mail Workspace or Mail Graph commands. They can also be created when 
webifying a workspace or graph. 

Packages can be opened by browsing in IrriMAX, or directly from Windows by double-click or drag-and-
drop. They can be opened directly from email attachments or after downloading from a web page. 

See page 33. 

Server Mode 
IrriMAX and Data Exchange command lines can be sent to an instance of IrriMAX running in server 
mode. This special mode allows commands to be queued and executed sequentially on a hidden desktop. 
A small program called IrriMAXServer.exe is used to communicate with the server instance. 

See page 27. 

(The Server Mode feature requires a Premium license.) 

Reports 
All graph reports now have the option to output to a text file rather than direct to Notepad. 

All graph reports except the Budget Line Periods report can output their values to an IrriMAX database 
for graphing. 

All graph reports now have the option to choose a time range based on growth stages. 

The last-used parameters for all reports are now stored in the graph document so that they don't need to be 
re-entered each time the report is run. 

If a single ruler is present on the graph, the start of the range to report will default to the time at the ruler. 
(As before, if two rulers are present, the time range to report will default to the range between the two 
rulers.) 

See page 179. 

(The Reports feature requires a Premium license.) 
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Alerts 
The Workspace Properties dialog now contains an Alerts tab for configuring the options relating to the 
mailing of alert messages. See page 55. 

• Alerts can be combined into one email (as before), or sent separately. You can elect to be notified 
about only those alerts that are new since the last alert email was sent. 

• You can elect to be notified when an alert is over. 
• Alert email messages now contain more information in the subject line, and redundant 

information in the body has been removed. 
 

The workspace Tools menu has a new command Mail Alerts... for sending alert emails from within 
IrriMAX, rather than the command-line. See page 68. 

The value of the last reading can be included in a graph-based alert by including %V in the user-defined 
message. See page 159. 

Each alert in an email is now prefaced by a bullet-point ("*" for red alerts and "-" for yellow and green.)  
This prevents Microsoft Outlook removing "extra" line breaks when the email is viewed. 

The /alertmail command-line switch now uses the new alert mailing properties stored in the workspace 
document. If used without an argument, it uses the email address stored in the document. See page 25. 

(The Alerts feature requires a Premium license.) 

Webify 
When webifying a workspace with the Upload when complete option, it is no longer necessary to specify 
an Output Folder. IrriMAX will instead use a temporary folder and delete it after the upload is complete. 
See page 65. 

It is no longer necessary to specify a full path to the Output Folder when webifying a graph (see page 
178) or workspace (see page 57). Relative paths can be used to specify a folder in a location relative to 
the graph or workspace document. 

FTP upload of webified files now uses two simultaneous connections to improve speed. 

The new macro WORKSPACE_PACKAGE_LINK can be used in a workspace webification template 
to generate and include a package containing the workspace document and all related files. See page 192. 

The new macros GRAPH_PACKAGE_LINK and GRAPH_ZIP_LINK can be used in a workspace or 
graph webification template to generate and include a package or zip containing the graph document and 
related database files. See page 193. 

"Webify Graphs..." has been renamed to "Webify Workspace..." 

(The Webify feature requires a Premium license) 

Data Exchange 
The Data Exchange SDB destination module has a new switch "/logger:" which is used to override the 
Logger ID provided by the source module. For command-line use only. 

The Data Exchange SDB destination module has a new switch "/combine" which is used to combine 
multiple source databases into one destination. For command-line use only. 

See the Data Exchange documentation for more information. 

Miscellaneous 
Upload Workspace has been added to the workspace manager Tools menu, to permit uploading of 
workspace files to a FTP server (see page 66). This feature can be accessed from the command-line using 
the "/upload" switch (see page 25). 
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It is now possible to display "tags" which show the values of the last readings on single-axis graphs, and 
the distance to the adjacent budget lines as a difference or a percentage on single-line graphs. Access this 
feature on a pane-specific basis from the Tags submenu of the graph's View menu. See page 172. 

IrriMAX databases (.SDB and .WDB files) are now registered with Windows to be opened by IrriMAX, 
where they are added to the databases list. See page 32. 

Workspace, graph and layout documents display an asterisk (*) in their title bar when they contain 
unsaved changes. 

Mapped Readings map files are now included in workspace and graph zip files and packages. It is now 
possible to enter a relative path to the map file in the Download Wizard, to specify a map file in a location 
relative to the workspace document. 

The Logger Dialog now allows a Logger ID of 32 characters for non-RT6 loggers (previously 22) and 
Site names of 32 characters (previously 29). See page 92. 

The Advanced... button on the Webify and Mail dialogs has been renamed to More Properties... 

What's new in IrriMAX 9.0? 
This section is intended for users familiar with IrriMAX 8.0. It describes new features and changes that 
have been introduced to the software with the release of IrriMAX 9.0. 

Standard and Premium Licenses 
There are two license levels for IrriMAX 9 - Standard and Premium. A number of features are only 
available to users who have obtained a Premium license: 

• Webify and Mail of workspaces and graphs (introduced in IrriMAX 7.1) 
• Database and Graph Alerts (new feature - see below) 
• Graph Reports (new feature - see below) 

 

Database and Graph Alerts 
An alert is a notification presented to the user that is triggered when a nominated condition is met. The 
user can define alert triggers based on these conditions: 

• A graph line being above or below a nominated budget line on a graph. 
• The last reading of a database being a nominated amount of time older than the current time. 
• The last reading of a database containing an invalid moisture or salinity value. 

 
Alerts are displayed in a window at the bottom of the Workspace Manager. See page 41. 

Graph-based alerts are defined in the Graph Properties dialog (see page 159.) Database-based alerts are 
defined in the the Database Properties dialog (see page 62.) 

IrriMAX can be invoked with the "/alertmail:" command-line switch to send the currently triggered alert 
messages to a nominated email address, then exit. If this switch is combined with the "/download" switch, 
the batch download will be performed first, then the alert triggers evaluated. See page 25. 

Graph Reports 
A selection of text-based reports can be generated from the Graph window, based on the data in the 
currently selected pane. See page 179. 

• The Graphed Values Report outputs the values as displayed in the current pane. See page 179. 
• The Cumulative Values Report outputs a running total of the values as displayed in the current 

pane. See page 180. 
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• The Budget Line Periods Report lists the amount of time the graph line spends between each pair 
of visible budget lines. See page 180. 

• The Daily Crop Water Use Report attempts to give a more accurate indication of crop water use 
than simply graphing "daily negative change". See page 181. 

 
Reports can also be run from the command-line. See page 25. 

Sentek Plus/Multi (Satellite) Module 
The new Sentek Plus/Multi (Satellite) Data Exchange source module allows download of readings that 
have been sent via satellite to a POP mailbox. Currently only the Iridium message format is supported. 

See the Data Exchange documentation for more information. 

Workspace Download Management 

"New Database" Wizard 
The New Database command now presents a New Database Wizard to assist with creation of a new 
database, either manually or by download from a selection of Data Exchange sources. If one or several 
databases are created from a download, the databases are automatically added to the workspace and the 
download command is stored in the workspace for subsequent downloads. See page 86. 

Download Wizard 
The Download Wizard in the Workspace Manager assists with the creation of the download commands for 
existing databases in the workspace. All Data Exchange source modules are supported. Their controls are 
embedded within the Wizard, so Data Exchange need not be invoked separately. See page 88. 

Easy editing of Mapped Readings mapping files 
The Download Wizard can create and update the Mapping Files used by the Data Exchange Mapped 
Readings module. These files no longer need to be edited by hand. See page 88. 

Batch and Background Downloads 
Each database with a download command has the option of being included in a batch (unattended or 
automatic) download. 

The Start Download and Start Batch Download commands in the Workspace Manager start 
downloading into one or more databases as a background process, using the download commands stored 
in the workspace. See page 61. 

Download progress is shown in the Download Window at the bottom of the Workspace Manager. Closing 
the window cancels the download. See page 46. 

IrriMAX can be invoked with the "/download" command-line switch. This downloads into all databases 
that have download commands marked for inclusion in a batch download. IrriMAX then exits. See page 
25. 

Download direct from files on the Internet 
The Data Exchange CSV, Excel and Mapped Readings source modules can now download direct from 
the Internet using a HTTP or FTP URL. 

Direct reading from the Internet using HTTP or FTP URL (without first downloading the whole file) is 
supported for the Data Exchange SDB and WDB source modules. 
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Webify Enhancements 
The new workspace comment property is substituted into the workspace template where the text 
WORKSPACE_COMMENT_TEXT appears. See page 192. 

When webifying a graph or workspace, IrriMAX will now create the output folder if it does not exist. 

When uploading a webified workspace using FTP, IrriMAX will now create the folders in the remote path 
if they don't exist. 

The default webify templates now include the "robots" meta tag so that the pages will not be indexed by 
search engines. 

Other Workspace Manager changes 
A new General tab in the workspace Properties dialog allows the entry of comments specific to the 
current workspace. See page 54. 

The workspace document can now store the time-zone for databases that are not using local time. This is 
used for sorting the Last Reading column, and for those alerts based on the age of the last reading. See 
page 62. 

The Measurement tab of the IrriMAX Settings dialog now allows you to select the default unit of measure 
for graphing of temperature and volume values. See page 77. 

The workspace document now remembers the sort column and direction for the graph list, and enforces 
the sort order continually. To stop sorting, drag a graph row to a different position. See page 44. 

New Edit menu contains download and Database Properties commands. The Add Database and 
Remove Database commands have moved here from the File menu. See page 61. 

The Trim/Extract dialog now allows an empty range to be chosen, enabling a database to be completely 
emptied by a trim. See page 108. 

Right-clicking on an empty area in workspace manager's database list now presents a context menu that 
allows creating or adding a database, and starting a batch download. 

The Remove Database and Recalculate Database commands in workspace manager can now operate on 
multiple selected databases. 

The Registration Details dialog now allows you to enter a message to be read by Sentek Registrations. See 
page 6. 

Other Graph window changes 
Copy Pane, Paste Pane and a Paste Properties submenu have been added to the graph Edit menu and 
context menu. Any graph pane can now be copied to another graph, and various properties of a copied 
pane can be applied to an existing pane. See page 170. 

The unit of measure used for the display of readings in each pane can be selected from the Graph 
Properties dialog (see page 149) and the Graph Popup menu (see page 138.) The default choice is to use 
the default IrriMAX setting (see page 77) but you can also choose to display the unit used in the database, 
or another unit for which a conversion is known. You can also create your own custom unit conversion 
for each pane (see page 149). 

Growth Stages are now permitted on all panes. If a pane does not support budget lines, the growth stage 
names and dividers are displayed without them. 

Enlarge Pane has been added to the graph View menu, to enlarge the current pane by 25% and shrink all 
the other panes equally. See page 172. 

Comments has been added to the graph View menu, to toggle between showing and hiding all the graph 
comments on every pane. See page 172. 

New horizontal zoom presets of 3 Months, 6 Months and 1 Year have been added to the graph window's 
Zoom X menu. See page 173. 
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The Day Start property for bar graphs previously only applied if the bar duration was exactly one day. It 
now applies if the bar duration is an exact multiple or divisor of one day. See page 149. 

Graph printouts have been modified so that the details shown are no longer linked only to the currently 
selected pane: 

• Only the graph file name (without file extension) and the user-entered comment are shown at the 
top of the page. 

• The graph path (not the path of the first pane's database) is shown at the bottom of the page. 
• Database name, last reading time and sample interval are not printed by default. To print these, 

they must have been selected to appear in the legend for the pane. 
• Regardless of pane settings, "Logger ID" is shown in all printed legends. 

 
The default name for a new graph is now the same as the database from which it was created. 

When choosing a vertical zoom percentage from the Zoom Y menu, you can now hold down the Shift 
key to zoom all panes at once. See page 173. 

The Time Shift property can now be used on any graph pane. 

Data Exchange changes 
The following changes to various Data Exchange source modules are described in the Data Exchange 
documentation. 

Sentek Plus/Multi Module changes 
• The Sentek Plus/Multi source module has a new Path control and "/PATH:" command-line 

parameter. This is used to specify a path relative to the path in the Server record. It is no longer 
necessary to create Server records that differ only by path. 

• The Edit Sentek Plus/Multi Servers dialog in the Sentek Plus module now has an Export Servers 
button, which exports all the server records to a ".reg" file. Double-click this file to import the 
servers into the registry of another machine, or another user account on the same machine. 

• The Sentek Plus/Multi/Solo source modules now supply sensor normalization history records. 
 

Mapped Readings Module changes 
• The Mapped Readings module supports a new "Separator" directive for specifying field-separator 

characters other than the default comma and tab. Consecutive separators can optionally be treated 
as a single separator. 

• The Mapped Readings module will recognize numbers that use a comma as the decimal mark, 
providing that the number is enclosed in double quotes or the Separator directive has been used to 
specify a field-separator character that isn't a comma. 

• The Mapped Readings module supports a new multiplier directive for scaling the imported 
values. For example, add "*25.4" to the map file to convert inches to millimetres. 

• The Mapped Readings module now supports a "HourOfDayCol" directive for when the time is 
expressed as an hour from 1 to 24. 

• The Mapped Readings module will now download the entire source file from the internet if 
provided with a HTTP or FTP URL. 

 

SDB and WDB Module changes 
• The Data Exchange SDB and WDB modules will now read the file from the Internet when 

provided with a FTP URL (HTTP URLs were already supported). This functionality is also 
available using the AutoSDB2 interface. 

• The Data Exchange SDB Destination module now supports appending and modifying records in 
the ESSensorHistory table. When a sensor history record (consisting of sensor address, date, air 
and water counts) is sent to the SDB destination, it replaces all records in the sensor history table 
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for that sensor from the new record's date onward. The module will accept but ignore redundant 
records. 

• The Data Exchange SDB Destination module will now create default sensor history records for a 
new database if they are not supplied by the source. 

• The Data Exchange SDB and WDB destination modules now support the /ERASE command-line 
switch, which will empty the destination database prior to the download. 

 

CSV and Excel Module changes 
• The Data Exchange CSV and Excel source modules will now download the entire source file 

from the internet if provided with a HTTP or FTP URL. 

Miscellaneous changes 
Drag-and-drop adding of files from Windows Explorer has been implemented in the Workspace Manager, 
Logger Layout and Graph windows, and in the Select Sensors Dialog. 

It is now possible to edit the historical record of air and water normalization counts of a sensor. In the 
Logger Configuration Dialog, right-click a sensor row and choose Edit Normalization History... 

The Recalculate Database Dialog now allows the reverse calculation of of raw counts from cooked 
values. This is useful for retrieving the original raw counts for Sentek Plus/Multi databases. Note that you 
must first enter the correct normalization history and calibration for each sensor using the Logger 
Configuration Dialog. See page 113. 

The new "/log:" command-line switch allows specifying a file to contain a combined log of IrriMAX and 
Data Exchange events. If unspecified, IrriMAX events are not logged, and Data Exchange events are 
recorded in the Data Exchange log as normal. See page 25. 

The Database Entry utility now has a right-button popup menu for changing the number of decimal places 
shown in each column of data. See the Database Entry documentation. 

What's new in IrriMAX 8.0? 
This section is intended for users familiar with IrriMAX 7.1 It describes new features and changes that 
have been introduced to the software with the release of IrriMAX 8.0. 

Most changes in this release fall under the following categories: 

• Better support for custom sensors (e.g. SoluSAMPLER-type readings). 
• More graph presentation options and improved graphing flexibility. 
• User-interface and usability enhancements. 

 
The changes are grouped by software component. 

Workspace Manager changes 

New database management tab in the workspace window 
The workspace window now contains two lists, Graphs and Databases. The Graph List shows the 
traditional view of the graphs in the workspace. The Database List contains all databases referenced by 
graphs and layouts in the workspace, plus any other databases that are manually added to the list. The 
database list is saved as part of the workspace document. 

If a database is highlighted in the list, all the database operations in Workspace Manager will use the 
highlighted database rather than asking the user to browse for one. All database operations are also 
available from the context menu that appears when a database in the list is selected with the right mouse 
button. 

The list can be sorted in either ascending or descending order by any of the columns. This sort order is 
maintained as databases are added or modified. 
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See page 46. 

Live graph thumbnails in the workspace graph list 
The Graph Info column can now display a thumbnail view of each graph. The size of the thumbnail is 
specified using the General tab of the IrriMAX Settings dialog. See page 84. 

This feature can be turned off if it adversely affects performance. 

Default Mail and Webify templates can be specified 
Default Mail and Webify templates can be specified in the new Templates tab on the IrriMAX Settings 
dialog. This allows use of customized templates without having to select them in each graph or 
workspace. See page 83. 

The template for the Upload Notification Email (UPLOADEMAIL.HTML) can also be changed. 

Multiple graphs can be sent in a single mail 
The workspace's Mail Graphs feature can now send all graphs in a single email, by use of the new 
WORKSPACEEMAIL.HTML template. See page 54. 

This template can be made the default by specifying it on the new Templates tab on the IrriMAX Settings 
dialog. See page 83. 

Mail and Webify feature extended with more options 
• When mailing or webifying from a workspace, graphs can be automatically zoomed to their 

preset date range. If they are zoomed to their vertical extents, budget lines can be included in the 
extents. Graphs with more than one vertical axis can be "stacked" so they don't overlap. 
See page 54 for workspace mail properties. See page 58 for workspace webify properties. 

• When mailing a workspace, a message can be entered to include in the body of each graph email. 
See page 54. 

• When webifying a workspace manually, a message can be entered to include in the Upload 
Notification Mail. See page 65. 

 

Drag-and-drop graph row ordering in workspace window 
Workspace Manager allows drag-and-drop reordering of graph rows. See page 41. 

Various workspace window improvements 
• The Last column has been renamed Type/Last. Click the column header to sort summed graphs 

in  order of irrigation priority, followed by the other graphs sorted by type (Stacked, Common Y 
or Separate Y, denoted by icons). See page 41. 

• The Graph Type column has been renamed Sensor Types. Click the column header to sort the 
graphs alphabetically based on the type of sensors they display. See page 41. 

• Layout and text windows are now invisible when minimized (like graphs.) 
• Invisible layout and text windows are now accessible from buttons on a new toolbar called the 

Workspace Bar, located underneath the existing toolbar. The Workspace Bar can be hidden or 
shown using the Workspace Manager View menu. See page 41. 

• The graph list can be scrolled vertically using the mouse wheel. 
• The mail feature now uses the most secure authorization method from those offered by the server. 

The "Secure Password Authentication" checkbox has been removed. See page 82. 
• The logger, site and probe information displayed in each graph row is now derived from all panes 

in the graph window, not just the first. 
• The logger, site and probe information, and the last reading time, as shown in a mailed or 

webified graph header, are now derived from all graph window panes, not just the first. 
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• Use the spacebar to minimize the currently viewed graph or layout and return to the Workspace 
Manager. Use the Esc key to send the the currently viewed graph or layout behind all other 
windows. 

• The Save Changes? dialogs that appear when IrriMAX is closed now have Yes to All and No to 
All options. 

• The shortcut keys for Cascade, Tile Horizontally and Tile Vertically have changed to F3, F4 
and F5 respectively. See page 69. 

• The Bring Layouts to Front function can now be accessed by the F6 shortcut key. See page 69. 
• Toolbar buttons have been added for Mail Graphs… and Webify Workspace… See page 64. 
• The Add Color and Remove Color buttons have been removed from the IrriMAX Settings dialog 

Color tab. See page 78. 
• The Irrigation and Rainfall tab has been removed from the IrriMAX Settings dialog, and the Graphs 

tab has been added (see page 80). Some settings are now accessed only by the new Database 
Entry utility. 

 

Layout and Logger Configuration Dialog changes 

Irrigation and Rainfall sensor support in SDB files 
The Logger Configuration dialog now directly supports addition of Irrigation and Rainfall sensors to a 
standard soil moisture database (SDB file). See page 95. 

To add an irrigation or rainfall sensor, ensure that the Logger Type combo box shows Unspecified 
(Irrigation and rainfall cannot be added to an RT6-type database).  Highlight a probe in the logger tree 
and click the Add Sensor>> button, then choose Irrigation or Rainfall to add a sensor. Alternatively, 
choose the options from the menu that appears when you right-click a probe. 

Logger type "Other" changed to "Unspecified" 
The Logger Type combo box offers two choices, RT6 or Unspecified. RT6 validation mode enforces 
strict rules for an RT6-compatible database. Unspecified mode does not enforce any particular rules. 
Unspecified used to be called Other. 

It is now possible to switch back from Unspecified to RT6, providing the database is compatible. 

Note that the validation setting is not preserved. If a database is RT6-compatible, then RT6 will be 
selected each time it is opened in the Logger Configuration dialog. 

Sites can be hidden on logger layout 
The site icons for individual loggers on the layout document can be hidden, to better represent single-
probe units. 

To hide sites, right click the logger icon and choose Hide Sites from the popup menu. Alternatively, left-
click the logger icon and choose Hide Sites from the Selection submenu of the Edit menu. See page 127. 

Sensor selection dialog supports custom sensors 
The Sensor Selection dialog and the graph window's Select Sensors for New Pane dialog have been 
combined, to allow creation of new graphs which don't have moisture or matric potential in the primary 
pane. This dialog is used to create a graph from either the Workspace Manager or the Logger Layout 
window. 

The new dialog shows the moisture probe layout on one tab, and all other sensor types in list format on 
the other tabs. Any type of sensor can be chosen to create a graph. See page 115. 
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Graph window changes 

New Bar Graph mode 
Graphs can be drawn in bar form in any non-I&R pane. The duration of the bars can be specified. When 
more than one reading falls within the time covered by a bar, the bars can be configured to show the start 
reading, the end reading, the minimum, the maximum, the average, the total sum of the values, or the total 
sum of only the positive or negative values. The graph mode (line, bar or change bar) can be configured 
using the graph Properties dialog. See page 149. 

When Irrigation or Rainfall sensors are graphed from an SDB file, daily total bar mode is set by default. 

Some graph mode combinations are selectable from a popup menu which appears when you click the 
pane's legend section with the left mouse button. 

New Change Bars mode 
Change Bars show the difference in value compared to the underlying value of the preceding bar. For 
example, daily crop water use can be shown by graphing soil moisture as a change bar, configured to 
show the total sum of the negative values. See page 149. 

Graphing restrictions have been removed 
• Graphs can now have any sensor type in the main pane. 
• Summed graphs can be created in any pane. The interpolation feature is now pane-sensitive. Note 

that the total sum is divided by the total number of probes containing selected sensors. 
• Budget lines and growth stages can be added to any pane which contains either a single sensor or a 

summed graph. 
 

Improved line legends for each graph pane 
The graph legends now appear immediately above the graph they refer to, or can be configured to appear 
in a corner of the graph. They can optionally include Logger Id, database name, last download time and 
current sampling interval. 

The legend properties for individual panes can be configured using the graph Properties dialog. See page 
149. 

Hovering above a legend with the mouse changes the cursor to a finger symbol. A left-click opens a 
popup menu that allows selection of a number of graph modes, and a More… option that opens the graph 
Properties dialog. 

The Irrigation and Rainfall pane has changed to use this mechanism for switching modes. 

Time offset for a pane allows comparison with historical data 
The time range of readings shown in a secondary pane can be offset from the main pane by a nominated 
amount, using the graph Properties dialog. This allows easy comparison with historical data. See page 
149. 

Differencing and totaling in vertical rulers 
When two or more vertical rulers are added to a graph, each ruler now also shows the difference in values 
when compared to the ruler on its immediate left. If the graph shows "total" bars, then the ruler also 
shows the total sum of the values between the two rulers. See page 166. 

Separate graph stacking 
Stack on the graph's Zoom menu reorders and adjusts stacked or separate-Y graphs so that the lines don't 
overlap. See page 173. 
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Arrow-less comments 
The arrow and/or border of a graph comment can be hidden, by deselecting Show Comment or Show 
Border on the comment's popup menu. See page 168. 

Expanded integration of graph window with other components 
• Logger Configuration… has been added to the graph's Tools menu. This opens the Logger 

Configuration dialog for the database associated with the currently selected pane. See page 176. 
• Enter Readings… has been added to the graph's Tools menu. This opens the Database Entry 

utility for the database associated with the currently selected pane. See page 176. 
 

Various Graph User Interface improvements 
• Graphs can be scrolled horizontally and vertically by clicking the graph and dragging the mouse 

with the left button held down. See page 144. 
• Graphs can be zoomed in and out vertically by use of the mouse scroll wheel. For a horizontal 

zoom, hold down the Shift key or the scroll wheel button while using the scroll wheel. 
• Use the Shift key when zooming to horizontal or vertical extents to apply the operation to all 

panes. (In the case of a horizontal zoom to extents, this will zoom all panes to their combined 
horizontal range.) Alternatively, choose All Extents from either the Zoom X or Zoom Y sub-
menus of the Zoom menu. 

• Preset vertical zoom amounts have been added to the Zoom Y sub-menu of the Zoom menu. 
These amounts range from 5% to 100%, where the percentage is of the total valid range for that 
sensor. In the case of soil moisture, the valid range happens to be 0 to 100 millimeters. Choosing 
10% on a soil moisture graph pane will therefore zoom the pane to a vertical range of 10 
millimeters. See page 173. 

• The behavior of Zoom to Vertical Extents can be changed in the IrriMAX Settings dialog to 
include budget lines in the extents. See page 80. 

• The behavior of Reset Graph can be changed in the IrriMAX Settings dialog to optionally zoom to 
the preset date range and/or to vertical extents. See page 80. 

• Equalize Pane Heights on the graph's View menu sizes the panes so that the graph part of all 
panes is the same height. See page 172. 

• Reset Graph and Properties… have been added to the graph's popup menu. 
• Zoom to Rectangle can be activated by the "Z" key. 
• Undo Zoom can be activated by the Ctrl+Z keyboard shortcut. 
• Irrigation and Rainfall panes now change height proportionally with the graph window instead of 

being a fixed height. 
• The logger details in the header and the vertical value span in the status bar now update to reflect 

the currently selected pane. Previously they only referred to the primary pane. 
• The Budget Line Names tab on the graph's Properties dialog has been removed and incorporated 

into the Budget Lines tab. See page 154. 
 

IrriMAX Utilities changes 

New Database Entry utility 
The Database Entry utility facilitates manual data entry into soil moisture or custom databases (.SDB 
files) for SoluSAMPLER or any other data. It also incorporates the previous utility for entering events 
into Irrigation and Rainfall databases (.WDB files). 

From within IrriMAX, the utility can be started from the Workspace Manager, the Graph window or the 
Logger Layout window. Note that Database Entry runs independently of IrriMAX, and will remain open 
when IrriMAX closes. It is also possible to create multiple instances of it. 

To start from the Workspace Manager, choose Database Entry… from the Tools menu. The utility starts 
with no database loaded. 
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To start from the Logger Layout, right-click the logger or site icon for which you want to enter readings, 
and choose either Enter Readings… or Enter Irrigation & Rainfall… The utility starts with the 
database already loaded, and in the case of Irrigation and Rainfall launched from a site icon, the site 
checkbox set. 

To start from the Graph window, ensure that the graph pane for which you want to enter data is selected 
(the pane legend at the side of the graph is bold and underlined). Choose Enter Readings… from the 
Tools menu. 

See the Database Entry documentation for more information. 

Data Exchange SDB and WDB module enhancements 
• The Data Exchange "IrriMAX Database" and "Irrigation & Rainfall Database" source modules 

can now read from an SDB or WDB file over the Internet using the HTTP protocol. Simply enter 
a URL where you would normally enter a filename in the Source section. 

• The Data Exchange "IrriMAX Database" destination module now supports the "/modify" switch, 
which allows modification, insertion and deletion of records within an SDB file. 

 
See the Data Exchange documentation for more information. 

Data Exchange Mapped Readings Module now integrated and enhanced 
The Mapped Readings add-in module is now included with IrriMAX. It extends Data Exchange with the 
ability to download readings from text-format files that do not conform to the standard Sentek CSV 
structure. This is done with the aid of a "mapping file" which specifies how to translate the data for 
import into an existing Sentek database. See the Data Exchange documentation for instructions on 
creating a mapping file using a text editor such as NotePad. 

• Tab characters are now recognised as field separators. 
• When using the TableCol directive to merge different sets of data with non-matching 

timestamps, linear interpolation is now used to manufacture values in those fields that don't have 
values in a merged record (allowing IrriMAX to draw unbroken lines). 

• New Locale directive to specify the locale/language that should be used to interpret dates. Use 
this to resolve mm/dd/yy versus dd/mm/yy ambiguity, and to interpret foreign language month 
names. 

• TimeShift directive for adjusting times to a different timezone. 
• LoggerIdCol directive for filtering out source lines based on the Logger Id. 
• ResampleMinutes directive for merging readings into records with timestamps that are a 

multiple of a given number of minutes. 
• A value can be hardcoded for each destination column. For example, an explicit value of 'empty' 

for a raw value will prevent it being automatically set to 65535, allowing IrriMAX to reverse-
calculate it from the cooked value. 

• LoggerId is now an optional directive. If not supplied, the module will attempt to retrieve it from 
the destination. 

 
See the Data Exchange documentation for more information. 

Remote Connection Manager supports Windows modems 
Remote Connection Manager now supports use of any modem recognized by Windows, without requiring 
a device to be set up on the Devices tab. The modems can be selected from the Local Communication 
Device drop down list on the Loggers tab, where they appear at the top, surrounded by brackets. 

See the Remote Connection Manager documentation for more information. 

Remote Connection Manager has improved usability 
• Phone numbers can be entered in Remote Connection Manager without requiring a Node record. 
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• The Remote Connection Manager window size has increased and lists are now sorted. The Edit 
menu has been renamed File, and Edit Site renamed Edit Configuration. 

• Remote Connection Manager now returns an exit code of 0 for success, 1 for unrecognised core 
program exit code and negative values for various errors (see Help). Previously the RCM exit 
code was undefined. 

 
See the Remote Connection Manager documentation for more information. 

Database Manager minor enhancements 
• The Database Entry utility can be started from the Database Manager Tools menu 
• The Data Exchange utility can be started from Import and Export on the Database Manager 

Tools menu. 
• The Verifying List dialog that appears when Database Manager is started now has a Cancel button. 

 
See the Database Manager documentation for more information. 
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Using IrriMAX 
This section provides an overview of IrriMAX and describes how IrriMAX is used. 

The importance of a Sentek Trained agronomist or distributor on installation 
For accurate, meaningful data readings, it is important to have a Sentek trained agronomist, or distributor, 
analyze the site, install the soil probes and configure the software.  

What is IrriMAX? 
IrriMAX is a Windows-based program which provides an environment for the management of databases 
and graphs containing soil moisture, matric potential, rainfall and irrigation, salinity and other sensors. 
This environment is known as the workspace and displays in the Workspace Manager window. See page 
29 for an introduction to the workspace concept. 

Hardware Integration 
IrriMAX software integrates with the Sentek range of hardware (including RT6 Loggers, EnviroSCAN 
Plus, Diviner 2000, EnviroSCAN, EnviroSMART, EasyAG and TriSCAN devices) to create a network of 
irrigation management sites. 

RT6 Logger 
The RT6 logger can support up to eight sites, each site consisting of a strategic array of probes. Each 
probe contains up to sixteen sensors (maximum of 32 sensors per logger) set to measure moisture content 
over a range of preset depths. 

TriSCAN Sensors 
TriSCAN sensors monitor both soil moisture content and salinity. Salinity is influenced by a range of 
factors including irrigation and fertilizer management.  These changes in salinity at various soil depths 
over time are plotted in the IrriMAX software in a separate graph pane above the soil moisture data. 

Irrigation and Rainfall 
The most critical aspect for achieving quality and yield in irrigated agriculture is the ability to match the 
crop's water requirements with irrigation or rainfall events. IrriMAX provides growers with a continuous 
account of the plant's water use dynamics. This accurate measure of water use provides water 
management control for an entire root zone. IrriMAX software displays this data, providing clear water 
management information. 

IrriMAX provides the ability to display irrigation & rainfall crop water application rates in a bar-graph 
form, in a pane above the soil moisture graph. Each site can have its own irrigation & rainfall data. 

Custom Sensors 
Various user-defined custom sensors can be added to an IrriMAX database and graphed as a complement 
or an alternative to moisture sensors. 

Software Components 
The main IrriMAX application is supported by a suite of utility programs. Each program can be run from 
the Windows Start menu, and desktop shortcuts can optionally be created during installation. 
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IrriMAX is the main application used to manage and view soil moisture information from the 
logger, salinity from TriSCAN sensors, rainfall and irrigation events and readings from other 
custom sensors. The IrriMAX Workspace Manager maintains the graphs, layouts and database 
configurations. 

The Logger Configuration Dialog component is used to create IrriMAX databases. It can also send 
configurations to the RT6 logger. 

 

Data Exchange transfers data to and from various IrriMAX sources and destinations. It is used to 
populate IrriMAX databases with readings downloaded from RT6 loggers, the Diviner 2000, 
EnviroSCAN Plus servers, EnviroSCAN Solo probes and the SoloPORTER.  

It also supports conversion of IrriMAX data to and from Comma-Separated Value text files and 
Microsoft Excel worksheets. Using the Mapped Readings module, readings can be imported into 
IrriMAX databases from almost any text-based file format. 

Refer to Data Exchange documentation for details. 

 

Database Entry is used to manually enter readings into IrriMAX databases and Irrigation and 
Rainfall databases. It allows creation of databases using the Logger Configuration Dialog. 

Refer to the Database Entry documentation for details. 

 

Database Manager is used to view all databases on your computer. It provides various database 
manipulation functions,.for example merging two databases to create a single database. It also 
allows creation of databases using the Logger Configuration Dialog. 

Refer to the Database Manager documentation for details. 

 

RT6 Logger Manager communicates with the RT6 logger to provide basic logger diagnostics and 
management functions. This information includes: viewing logger identification, ROM firmware 
version, sensor configuration, data block headers, voltages and dynamic sensor readings. It also 
allows the setting of baud rate, sampling interval and logger date and time. 

Refer to the RT6 Logger Manager documentation for details. 

 

Remote Connection Manager (RCM)  manages the remote connection between a computer and a 
remote logger over a modem or radio connection. 

Refer to the Remote Connection Manager documentation for details. 

 

The ES2 Database Converter utility converts EnviroSCAN 2 database formats to the IrriMAX 
database format. 

Refer to the ES2 Database Converter documentation for details. 

Starting IrriMAX 

Ø  To start IrriMAX 
1. From the Windows Taskbar, click the Start button and point to Programs. 

2. Point to Sentek, point to IrriMAX and click IrriMAX 
The Workspace Manager window displays. 
See page 83 for details of startup options. 

 

Note: 
The license manager Registration and Licensing dialog will appear until IrriMAX is registered. See 

page 6 for the process to register IrriMAX. 
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Note: If you chose to have desktop icons installed on your Windows 
desktop during the installation, you can also start IrriMAX by double-
clicking this icon. 

Ø  To Open or Print IrriMAX documents from Windows Explorer: 
IrriMAX has Windows file extension associations which allow the opening and printing of workspaces 
(.sws), graphs (.gt, .gss and .gsk) and layouts (.sll) from Windows Explorer.  

1. Open Windows Explorer and browse to the folder containing the desired IrriMAX documents. 

2. Double click to launch IrriMAX and open the desired document. 
OR 
Right-mouse click on the desired filename and on the popup menu select the Open or Print menu 
item. IrriMAX will automatically start. 
Note: If file extensions are not displayed, the icon next to the file name depicts the type of file. 
 

 

3. If Print is selected the operation will be performed then IrriMAX will automatically close. 
Note: Print workspace only prints graphs which have the Print checkbox selected. 

 

Ø  To start IrriMAX and load a document 
1. From the Windows Taskbar, click the Start button and select Run... 

2. On the Run dialog, type "C:\Program Files\Sentek\IrriMAX\IrriMAX.EXE" "document", where 
"document" is the path to the workspace, graph or layout document that you want IrriMAX to load 
automatically on startup (the quotes are necessary if blanks appear in the path name). Note that the 
path to "IrriMAX.EXE" above is an example only. The program may have been installed at a 
different location on your machine. 
Note: You can also replace the IrriMAX.exe command with the full path to the required document. 
See To Open or Print IrriMAX documents from Windows Explorer above. 

3. Click OK 

 

Exiting IrriMAX 
Exiting IrriMAX shuts down the IrriMAX application. 
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Ø  To exit IrriMAX 
From the Workspace File menu click Exit: 

• If the open files have not been saved, message boxes display prompting you to save or abandon 
each document. 

 
Once all files have been saved or abandoned the application will shutdown. 

Starting IrriMAX from the Command Line 
Advanced users can launch IrriMAX from the command line, a custom shortcut or the Windows Task 
Scheduler. This allows you to supply the filename of a workspace, graph or layout document to be 
automatically loaded when the program starts. You can use various command-line switches to make 
IrriMAX perform certain operations. 

An IrriMAX command line consists of three parts, separated by spaces: 

• The path to the IrriMAX executable, enclosed in double-quotes if the path contains spaces. This is 
typically "C:\Program Files\Sentek\IrriMAX\IrriMAX.exe". In the examples below it is assumed 
that the current directory is the directory in which IrriMAX is installed, so we can invoke 
IrriMAX by simply typing "IrriMAX.exe". 

• The path to an IrriMAX document to open. You can supply a graph or layout document, but the 
switches detailed below are only valid for workspace documents. The path to the document must 
be enclosed in double-quotes if it contains spaces. 

• Various combinations of switches as detailed below. Some switches require you to supply an 
argument. If a switch or its argument contains spaces, the switch and its argument must be 
enclosed in double-quotes. 

 
The following example downloads into the databases and webifies the workspace, sending error messages 
to an email address: 

IRRIMAX.EXE "C:\DATA\MY WORKSPACE.SWS" /DOWNLOAD /WEBIFY /FAILMAIL:ME@MYCOMPANY.COM 

Command-Line Switches 

/download 
IrriMAX will download into all files in the workspace that have download properties stored and the 
"include in batch downloads" flag set (see page 88). When all other command-line switches have been 
processed, IrriMAX will exit. 

IRRIMAX.EXE "C:\DATA\MY WORKSPACE.SWS" /DOWNLOAD 

/webify 
IrriMAX will webify the workspace according to the stored properties in the workspace document (see 
page 57). If the /download switch is also given, the download will be performed first. When all other 
command-line switches have been processed, IrriMAX will exit. 

IRRIMAX.EXE "C:\DATA\MY WORKSPACE.SWS" /WEBIFY 

/mail 
IrriMAX will mail the graphs in the workspace according to the stored properties in the workspace 
document (see page 56). If the /download switch is also given, the download will be performed first. 
When all other command-line switches have been processed, IrriMAX will exit. 

IRRIMAX.EXE "C:\DATA\MY WORKSPACE.SWS" /MAIL 
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/gvreport:outputfilename,graphname,paneno,startdate 
IrriMAX will output the Graphed Values Report (see page 179) to the specified file. If the /download 
switch is also given, the download will be performed first. When all other command-line switches have 
been processed, IrriMAX will exit. 

The following command writes the report to a file called C:\REPORT.TXT. The name of the graph within 
the workspace is GRAPH.GT (a path is not supported so there must only be one Graph.gt in the 
workspace). The report is run on the first pane of the graph, which is pane 0 (the panes are numbered 
from zero, ordered from bottom to top). 

IRRIMAX.EXE "C:\DATA\MY WORKSPACE.SWS" /GVREPORT:C:\REPORT.TXT,GRAPH.GT,0 

A start date can be supplied as an optional fourth parameter. Many date formats are recognized, 
depending on your computer's locale settings. You can alternatively supply the name of an existing 
growth stage (see page 142) from which the date will be extracted. 

… "/GVREPORT:C:\REPORT.TXT,GRAPH.GT,0,2011-03-11 9:00AM" 

… "/GVREPORT:C:\REPORT.TXT,GRAPH.GT,0,FLOWERING" 

If any parameter contains a comma, then that parameter needs to be enclosed by a pair of double-quotes 
on either side, and the whole report switch must be enclosed in double-quotes. For example: 

… "/GVREPORT:""C:\REPORTS, OUTPUT\REPORT.TXT"",GRAPH.GT,0" 

The report can also be output to an IrriMAX database (.SDB file).  

/cvreport:outputfilename,graphname,paneno,startdate 
IrriMAX will output the Cumulative Values Report (see page 180) to the specified text file or IrriMAX 
database. Usage is identical to /gvreport above. 

/blreport:outputfilename,graphname,paneno,startdate 
IrriMAX will output the Budget Line Periods Report (see page 181) to the specified text file. Usage is 
identical to /gvreport above. However, there is no option to output to an IrriMAX database with this 
report. 

/wureport:outputfilename,graphname,paneno,startdate 
IrriMAX will output the Daily Crop Water Use Report (see page 181) to the specified text file or 
IrriMAX database. Usage is identical to /gvreport above. 

/zip:zipfilename 
IrriMAX will add the workspace and all linked documents and databases to a zip file with the given 
name. If the /download switch is also given, the download will be performed first. When all other 
command-line switches have been processed, IrriMAX will exit. 

IRRIMAX.EXE "C:\DATA\MY WORKSPACE.SWS" "/ZIP:C:\BACKUPS\MY WORKSPACE.ZIP" 

/alertmail:emailaddresses 
IrriMAX will email all currently triggered alerts to the supplied email addresses. To send to more than 
one address, separate them with commas. If the /download switch is also given, the download will be 
performed first. When all other command-line switches have been processed, IrriMAX will exit. 

IRRIMAX.EXE "C:\DATA\MY WORKSPACE.SWS" /DOWNLOAD /ALERTMAIL:ME@MYCOMPANY.COM 

The alert emails will be sent according to the stored properties in the workspace document (see page 55). 
To use the email addresses stored in the workspace document, omit them from the command line. 

IRRIMAX.EXE "C:\DATA\MY WORKSPACE.SWS" /ALERTMAIL 
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/failmail:emailaddresses 
If an error occurs when loading the workspace or during a command-line operation, then IrriMAX will 
email an error message to the supplied email addresses. To send to more than one address, separate them 
with commas. 

IRRIMAX.EXE "C:\DATA\MY WORKSPACE.SWS" /WEBIFY 
/FAILMAIL:ME@MYCOMPANY.COM,ADMIN@MYCOMPANY.COM 

/log:logfilename 
If a log file name is supplied with this switch, then IrriMAX will write the command-line to the log file 
whenever it starts. Various events are written to the log file. All text that would normally go to the Data 
Exchange log file will instead be sent to this file. 

IRRIMAX.EXE "/LOG:C:\LOGS\IRRIMAX.LOG" 

/tempws 
If you launch IrriMAX with the command line switch /tempws (not case sensitive), you will not be 
prompted to save any changes you have made to the workspace when you exit the program. 

IRRIMAX.EXE "C:\DATA\MY GRAPH.GT" /TEMPWS 

Running IrriMAX in Server Mode 
IrriMAX and Data Exchange command-lines can be executed by IrriMAX in server mode. Server mode 
has the following advantages: 

• Command-lines sent to IrriMAX in server mode are queued and executed sequentially. This 
ensures best use of the system's resources by avoiding the case of multiple copies of IrriMAX 
launching and running commands simultaneously. 

• When IrriMAX runs a command in server mode it is done on its own separate desktop and does 
not interfere with the desktop of any other users of the computer. 

• When IrriMAX is launched in server mode it remains running and waits for additional 
commands. This avoids delays introduced by repeatedly launching the program. Alternatively it 
can be instructed to close after running a command. 

• All commands sent to IrriMAX in server mode are recorded in a log file called 
IRRIMAXSERVER.LOG, which can be found in the Sentek public folder. The log records whether 
the commands failed or were successful. 

 
Communication with an instance of IrriMAX running in server mode is done by use of a small program 
called IRRIMAXSERVER.EXE. 

Use of server mode requires a Premium license. 

Using IrriMAXServer.exe 
IrriMAXServer.exe is a command-line program used for submitting commands to an instance of IrriMAX 
running in server mode. Simply substitute IrriMAXServer.exe for IrriMAX.exe in your batches, shortcuts 
or scheduled tasks. 

IrriMAXServer.exe will start an instance of IrriMAX in server mode (if it is not already running), then 
pass its command-line arguments through to the server where they are queued for execution. The usual 
scenario is that IrriMAXServer.exe will then terminate immediately without waiting for the command to 
be executed, and the instance of IrriMAX running in server mode remains in memory, waiting for more 
commands. 

IrriMAXServer.exe recognizes the following additional command switches. 
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IrriMAXServer /dex 
The /dex command indicates that the remaining command switches are to be forwarded by IrriMAX to 
Data Exchange. This allows general Data Exchange operations to be executed by the same queue as 
IrriMAX operations, in cases where the order of execution is important. 

If an IrriMAX log file is specified, Data Exchange will use it as well. For example: 

IRRIMAXSERVER /LOG:C:\LOGFILE.LOG /DEX /S:SDB C:\INPUT.SDB /D:SDB C:\OUTPUT.SDB 

IrriMAXServer /help 
The /help command displays a list of the command-line switches that are recognized by 
IrriMAXServer.exe. 

IrriMAXServer /status 
The /status command displays the status of the server. If the server is not running it displays "Server not 
running". Otherwise it displays the version number, running time, working time (the time spent actually 
running commands), the number of commands executed and the status of the command queues. 

IrriMAXServer /quit 
The /quit command switch shuts down the server when there are no more commands in the queue. You 
can use this switch by itself, or in conjuction with an IrriMAX command-line. 

IrriMAXServer /abort 
The /abort command switch shuts down the server as soon as the current command is finished, discarding 
any queued commands. 

IrriMAXServer /wait 
The /wait command switch will cause IrriMAXServer.exe to remain running until the command is 
executed, rather than terminate immediately after submitting the command to the queue. You can use this 
switch by itself, or in conjuction with an IrriMAX command-line. 

IrriMAXServer /priority 
The server provides a priority queue in addition to the standard queue. Any commands sent to the priority 
queue by use of the /priority switch will be executed before any commands in the standard queue. (The 
/status and /abort commands are automatically sent to the priority queue.) 

IrriMAXServer /suspend 
The /suspend command suspends execution of commands in the standard queue. This takes effect after 
the currently executing command is finished. To resume execution of commands, use the /resume 
command. 

IrriMAXServer /resume 
The /resume command resumes execution of commands in the standard queue. It has no effect if the 
queue was not suspended by the /suspend command. 

 

Online Help 
Online help for IrriMAX can be obtained in various ways: 
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Ø  To obtain online help 
1. Press F1 on the keyboard to view help on the currently active window. 

2.  Press SHIFT+F1 on the keyboard to view pop-up help on the control that has focus in a dialog box. 

3.  Click  to display help on a dialog box containing this button. 

4. From the Help window, double click items in the help list. 
Click the Contents tab to scroll through a table of contents for online help. 
Click the Index tab to search for topics by using an index of keywords and phrases. 
Click the Search tab to use full-text search and look for specific words. 
Click the Favorites tab and click Add to keep a reference of your favorite topics 

5. Use ScreenTips to display information about each item on the window. 

To see a ScreenTip for a window item, click  or  and then click an item on the window to 
display information about that item. 

6. To see the name of a toolbar button, position the mouse pointer over the button until the name 
appears as a ToolTip. 

7. To see menu item descriptions, position the mouse pointer over the menu item until the description 
appears in the status bar at the bottom of the window. 

8. A glossary of IrriMAX terminology is also available. 
Click the Glossary on the Help toolbar. 

Printing Help Topics 
Individual help topics may be printed as required. A full copy of the user guide is also supplied as a file in 
Adobe Acrobat portable document format (PDF), which can be printed. 

Ø  To print a help topic 

In help, click . Select either the selected topic, or the selected heading and all subtopics. 

Ø  To print the PDF version of the user guide 
A full copy of this user guide is provided with the software, in PDF format. You can print a full copy of 
the PDF user guide using Adobe Reader, which is used to view the PDF user guide. Please refer to the 
Adobe Reader online help for details on how to print selected pages or a full copy of the user guide in 
A4 format. These files are available from the Start menu. 

Note: Adobe Reader can be installed from the IrriMAX CD. 

Ø  To view a Manual in PDF format 
1. From the Windows Taskbar, click the Start button and point to Programs. 

2. Point to Sentek, point to IrriMAX, point to Manuals and click file you wish to view 
Adobe Reader displays the selected file. 

The IrriMAX Workspace 
Everyday usage of IrriMAX requires interaction with many separate files. Database files are created and 
updated with readings from loggers; graph documents are created to display the readings from these 
databases; and layout documents allow access to databases from a graphical representation of the loggers 
in the field. 

The IrriMAX Workspace Manager window provides access to a collection of related databases, graph 
documents and layout documents. Links to these independent files are stored in the workspace document. 
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• Opening a workspace document also opens all the files to which it links. 
• You can create multiple workspaces, but only one can be open in IrriMAX at a time. 
• Files included in one workspace can also be included by another. 

 
You could, for example, use more than one workspace to organize and view data from a single logger if 
you wanted to have different 'views' of the same data. Alternatively, you can use one workspace to 
combine layouts or graphs from multiple loggers. A consultant would typically save a different 
workspace for each client. 

Below is an example of a typical IrriMAX session which shows the main window types. 

 

The Workspace Manager Window 
The Workspace Manager is the heart of IrriMAX from which you can: 

• Create and save workspace documents, databases, graphs and layouts. 
• Organize, access and manipulate databases. 
• Arrange and access the graph and layout windows. 
• View a summary list of all the open graphs with thumbnail images. 
• View soil moisture gauges that represent irrigation urgency. 
• Manipulate databases using a variety of tools. 
• Send graphs by email, or convert them for viewing on the web. 
• Backup all files referenced by the workspace. 
• Perform batch printing of graphs. 
• Change settings that govern the way the software operates. 
• Manage registration and licensing of the software. 

 



 IrriMAX User Guide 
 Using IrriMAX 

Sentek Pty Ltd 31 

Layout Window 
From the Layout window you can create a picture of your site configurations and create graphs. The 
Layout window provides a stylized picture of each logger configuration. From the Layout window, any 
combination of probes, sites and sensors may be selected to display the corresponding data in a graph 
window.  

Graph Window 
From the Graph window you can view graphs. The Graph window displays readings from one or more 
databases in a time-based graph for detailed examination. Each graph window can contain multiple 
vertical panes for comparison of different information over a common time period. 

Logger Configuration Dialog 
The configuration of logger, sites, probes and sensors in a database is managed by the Logger 
Configuration dialog box. The Logger Configuration dialog box also provides access to the Calibration 
Registry where calibrations for specific soil profiles are stored. It also allows selection of custom sensor 
propertiess from a central registry. 

The dialog also communicates directly with an RT6 logger to set its configuration. 

Data Acquisition 
Before using IrriMAX graphs to interpret data, that data must first be acquired and added to an IrriMAX 
database. 

RT6 Logger 
Data can be downloaded from an RT6 logger in three ways: 

• By going into the field and directly connecting a laptop into the logger (front panel of the 
housing). 

• By disconnecting the logger from the logger housing and taking it to your computer (requires 
office download cable) 

• By remotely connecting to the logger from the office, then downloading data. 
 

Refer to the Remote Connection Manager and Data Exchange documentation for details of 
downloading data either remotely or via a direct connection. 

Diviner 2000 
Data can be downloaded from a direct connection to a Diviner 2000 unit. See the Data Exchange 
documentation for details. 

EnviroSCAN Solo 
Data can be downloaded from an EnviroSCAN Solo probe in two ways: 

• By going into the field and directly connecting a laptop into the probe (front panel of the 
housing). 

• By going into the field and copying the data into a SoloPORTER device, then bringing this back 
to your computer and reading the data from it. 

 
Refer to the Data Exchange documentation and SoloPORTER User Guide for details. 

EnviroSCAN Plus 
EnviroSCAN Plus probes upload their data to a server on the Internet. Refer to the Data Exchange 
documentation for details on downloading the data from the server into an IrriMAX database. 
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Manual Data Entry 
Readings can be manually entered into an IrriMAX database using a spreadsheet-like interface. Refer to 
the Database Entry documentation for details. 

Text Files 
The Data Exchange CSV and Mapped Readings modules can assist to import data from various text-
based formats. See the Data Exchange documentation for details. 

IrriMAX File Formats 
Various different types of file are used with the IrriMAX software. 

IrriMAX Databases 
The data for the IrriMAX system is stored in two types of related databases: 

• The IrriMAX Database (.sdb) contains logger configuration information and sensor readings, 
logged over time. There can be only one logger per database. 

• The Irrigation & Rainfall Database (.wdb) contains the irrigation & rainfall data for each of the 
sites in a paired IrriMAX database. The I&R databases must have the same filename as the soil 
moisture databases that they are paired with (except for the file suffix of WDB instead of SDB). 
These databases contain irrigation & rainfall application rates, times and periods. 

 
File Name 
Extension... 

Icon ...contains this kind of information 

.SDB 

 

IrriMAX Database 

.LCS  Logger configuration portion of a SDB file that has 
been temporarily detached (do not delete these files) 

.WDB 

 

IrriMAX Irrigation & Rainfall Database 

.WCS  Logger configuration portion of a WDB file that has 
been temporarily detached (do not delete these files) 

.WDX  Index files associated with an IrriMAX irrigation & 
rainfall database (.WDB file) These files are 
automatically generated when required. 

IrriMAX Documents 
IrriMAX uses a number of different document file types for management and presentation of the data 
stored in the databases. 

You can double-click on the icon for any document to launch IrriMAX and open that document.  

File Name 
Extension... 

Icon ...contains this kind of information 

.SWS 

 

IrriMAX Workspace - a document containing links 
to a collection of databases, layout and graph 
documents. 
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File Name 
Extension... 

Icon ...contains this kind of information 

.SLL 

 

IrriMAX Logger Layout - a document containing 
pictorial links to IrriMAX databases. 

.GT 

 

IrriMAX Summed Graph - a graph with a single 
summed line in the main pane. 

.GSK 

 

IrriMAX Stacked Graph - a graph with multiple 
lines in the main pane 

.GSS 

 

IrriMAX Separate Y Graph - a graph with multiple 
lines in the main pane, with a vertical axis for each 
line 

.GSC 

 

IrriMAX Common Y Graph - a graph with multiple 
lines in the main pane, sharing a common axis 

.IMXPAK 

 

IrriMAX File Package - a compressed format 
containing any or all of the above document types 

IrriMAX File Packages 
An IrriMAX File Package is a compressed archive of all files referenced from either a workspace 
document or a graph document. 

Packages are intended to facilitate easy exchange of IrriMAX files between users. They have the file 
extension ".imxpak". 

The files within a package are stored without folder information. It is not possible to create a 
package containing two files that have the same name (for example two graphs called graph.gt 
that are stored in different folders.) The intent is that when the package is extracted, all files are 

put in the same folder to simplify management. 
 

You can use the Zip Workspace (see page 64) or Zip Graph (see page 176) commands if you 
need to create an archive which preserves folder information. 

Creating Packages 
Packages can be created by choosing Save Package… from the File menu of either the Workspace 
Manager window (see page 48) or the Graph window (see page 162). 

They can also be automatically created and attached to an email when using the Mail Workspace (see 
page 66) or Mail Graph (see page 176) commands. 
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A workspace package can be created from the command-line using the /zip switch. See page 25. 

They can also be created when webifying a workspace or graph. See page 193. 

Opening Packages 
Packages can be uncompressed and opened in IrriMAX by opening the .imxpak file from Windows, or by 
dragging and dropping it onto the IrriMAX workspace window. You can also open them directly from 
email attachments or after downloading from a web page. 

From within IrriMAX, they can be opened from the Open submenu of the workspace window's File 
menu, and the Open button on the toolbar. See page 48. 

When a package is opened, the following dialog appears. 

 

Create or overwrite a folder named 
Enter the name of a folder that will contain the files that are extracted from the package. The default name 
supplied is the name of the package file. 

Within the folder 
Enter the full path of a folder inside which the package folder will be created. You can use the Browse… 
button to select this parent folder. IrriMAX remembers your choice for next time. 

Delete the original package file after extraction 
If you check this box, the original .imxpak file will be deleted after the files are successfully extracted 
from it. 

You may want to select this option if the package was being used simply as a file transfer mechanism. 
Conversely, you may wish to retain the original package for backup purposes. 

Ø  To open a package 
1. Open the package and specify a location for the uncompressed files, as described above. 

2. Click the OK button. 

3. The package files will be extracted to the desired location. If there are already files in the folder 
with the same names, you will be notified and given the option to either replace them, or cancel the 
operation. 

4. If the files are successfully extracted and you ticked the Delete the original package file after 
extraction checkbox, the original package is deleted from your computer. 

4. If your currently loaded workspace has unsaved changes, you will be prompted to save or discard 
them. You also have the option to cancel the operation at this point. 
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5. If the package contained a workspace document, it will be opened. Otherwise IrriMAX will attempt 
to open all files in the package in a new workspace document. 

 

Managing IrriMAX files 
Your databases and documents should be managed in a way that makes them easy to locate every time 
you need them. It is important to devise a file storage system, which matches the crops, logger 
configurations, and workflow practices that you prefer. The following guidelines have been provided to 
help you structure your file storage. 

Storing similar databases in the same place 
The first time IrriMAX has to perform a database save it proposes the "Save As" with default "My 
Documents" folder. Saving a database when a workspace is loaded proposes the same folder as the 
workspace document. From then on IrriMAX proposes the last save folder.  

Versions of Windows have different locations for "My Documents": 

Platform Typical Default Location 

Windows XP  C:\Documents and Settings\< user name>\My Documents 

Windows Vista & Windows 7 C:\Users\<current user name>\Documents 

IrriMAX files do not have to be in these default locations. It is suggested that separate sub-folder be 
created for the storage of IrriMAX files. 

Multiple IrriMAX database files can be stored in the same folder. In this way, you can have more than 
one database per logger. These databases may be used at different times of the year, seasonally adjusted 
or under varied cropping conditions. It is recommended that where more than one database exists for one 
site, those files are stored in a similar place. You may have two loggers taking information from four 
areas. A folder (directory) structure that nominates the site of the logger for the four main loggers could 
be used. Within that folder structure, additional folders are added to store individual crop information. For 
example: 

1 Logger1 South Gate  

 1 Beetroot 2002 

 1 Beetroot 2003 

 1 Lettuce 2003 

1 Logger2 West Orchard  

 1 Nectarines 2003 

 1 Peaches white 2003 

 1 Peaches yellow 2003 

Separating ES2 databases from current files 
EnviroSCAN 2 database folders and files  should be stored in separate folders to IrriMAX databases. It is 
recommended that after installing IrriMAX, EnviroSCAN 2 databases should be backed up to disk and 
then converted to IrriMAX using the ES2 Database Converter  

Using file names that correspond to sites 
Using long file names that correspond to the actual site description is advisable. Files may be named for 
location, crop and seasons as required. It is important to use names that you will recognize and that are 
easy to remember. 

Managing logger sites 
It is important to use clear naming conventions for loggers and to replicate these naming conventions 
within computer file structures. In this way, information is easy to find and manage.  
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The Site names that you use will also be used as site names for the Irrigation & Rainfall database (.wdb) 
which is associated with each logger database (IrriMAX database .sdb).  

The following guidelines should be used when setting up logger sites: 
• Select a different Site for each Irrigation area 

(e.g. each Pivot, paddock, section or crop area), 
so the irrigation statistics can be recorded individually. 

• Assign distinctive logger IDs 
Use location or crop names to distinguish one logger from another. If crop rotation is likely, do 
not use crop names alone but use combined crop and season names. 
For example, Malbec Spring 1999 

• Label loggers/logger housing clearly with their IDs 
A space is provided on the inside lid of the logger housing for an information sticker. 

• Backup the database after each successful download. 

Understanding soil moisture and salinity management 
IrriMAX processes continuous soil moisture and salinity data from a network of Sentek probes 
representing different sites on the farm and different depth levels within a particular soil profile. Data 
from all sites and sensors can be sampled from once a minute to once a day (typically at 10 or 30 minute 
intervals). 

Using continuous soil water data, IrriMAX can display a range of dynamic changes in soil moisture and 
salinity that occur in the soil profile. 

Trends of water extraction rates in the soil profile mirror the speed and depth level at which crop water 
use is occurring. You are able to observe how quickly the plant is 'drinking' and can see the extent of the 
living root zone. With the help of the software, you can visualize the actual depth of an irrigation or 
rainfall event. These are essential decision making criteria for good irrigation scheduling. 

The following soil moisture parameters can be quantified numerically and displayed graphically using the 
IrriMAX software: 

• Daily crop water use 
• Daily evaporative and drainage losses from the soil profile 
• Soil water extraction patterns within different layers of a soil profile 
• Depth and distribution of the root zone 
• Growth progress and growth decline rate of the root zone 
• Depth and distribution of a wetting front after an irrigation  
• Rate of redistribution of a wetting front after an irrigation or rainfall event 
• Behavior of soil water dynamics in the soil profile indicating changes in soil texture and/or 

structure 
• Fertilizer impact and salinity trends 
• Saturation point, rate of drainage and onset of field capacity in any given layer of the soil profile 
• Rate of soil water depletion in a stressed or unstressed phase of the crop 
• Onset of crop water stress 
• Crop water use under waterlogged conditions 
• Crop water use changes as affected by: 

different crops, varieties, ages, phenological phases, canopy sizes, fruit loads, irrigation system 
performances, soil types, topographical exposure, disease incidents, cultural management 
practices, soil salinity changes, soil structural problems, weather conditions and many other 
factors 

• Year to year irrigation management histories and a record of implemented irrigation strategies 
• Effective wetting depth of irrigation & rainfall 
• Occurrence and impact of water tables on the soil profile and the crop root zone 
• Changes of the shape of the 'wetting onion' in drip irrigation 
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• Site specific soil water budgets for optimal crop productivity and irrigation efficiency (With these 
budgets you can predict the next irrigation date and the necessary amount of irrigation to refill the 
profile) 

• On-farm overview of soil water budgets from all sites to prioritize irrigation management 
decisions in terms of urgency. 

 
Expert advice is recommended to understand the full extent of all the parameters mentioned above, and 
how to recognize and work with these key decision making criteria effectively to generate rational 
irrigation management decisions. 

By recording irrigation & rainfall water application rates and times, a clearer overview of crop water 
management can be seen. By viewing the I&R graph above the soil moisture graph, the reason for any 
increase in moisture can easily be identified and quantified. 

The following is a brief introduction on the use of IrriMAX data using the following examples: 
• Example 1 - The Summed Graph 
• Example 2 - Stacked Graph 
• Example 3 - Daily totals Irrigation and Rainfall pane 
• Example 4 - Event Amounts Irrigation & Rainfall pane 
• Example 5 - Fertilizer/Salinity Pane 
• Example 6 - Matric Potential Graph 
• Example 7 - Custom Sensors 

Example 1 - The Summed Graph 
The summed graph provides you with a picture of soil water changes occurring in the profile.  

 

This summed graph shows the moisture values for a probe with sensors located at 10cm, 30cm and 40cm 
expressed as soil water content in mm. The irrigation event shows the water content rising quickly. The 
graph shows a steeper slope during the daytime indicating a higher water use by the crop than at 
nighttime. When soil moisture depletion reached the Refill Point on the 17th June, irrigation was again 
applied, which replenished the soil water content to the set Full point. Rain later on the 17th raised the 
moisture content above the Full point. 
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Example 2 - Stacked Graph 

 

This stacked graph shows the readings for a probe with sensors at levels of 10cm, 20cm, 30cm, and 40cm. 
The graph shows crop water use is most pronounced at the 10cm soil depth, reflecting the highest 
concentration of roots active in water uptake located in this soil layer. Irrigation infiltration can also be 
seen by the rise in soil moisture occurring at the 40cm soil depth (Note the time delay for the irrigation to 
reach this depth). 

Example 3 - Daily totals Irrigation and Rainfall pane 

 

This graph shows the amount of water applied to the site in each 24 hour period in the form of rain and 
irrigation. There is a small gap between days to highlight the start time of each day. The start time of this 
24 hour period is defined in the Graph , but as a default is from 9am to 9am the next day. The rainfall and 
irrigation data is displayed as a column graph with the column width of a 24 hour period on the x-axis. 
The y-axis shows the total application for the day. When the daily format is selected, the y-axis reflects 
the amount of water applied in total for the 24 hour period. 

The value of the daily total graph is that it shows the total amount of water that is applied over the course 
of a day. This can then be compared directly to any increases in soil moisture. Losses due to canopy 
interception, runoff and evaporation can be readily seen, and the depth of infiltration related to the 
amount of water applied. This graph is particularly useful in applications such as drip or sprinkler 
irrigation where the irrigation is applied at a uniform rate and the key value of interest is the amount of 
water applied in millimeters or inches. 
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Example 4 - Event Amounts Irrigation & Rainfall pane 

 

This "Amount" mode shows each irrigation event or rainfall application against time. It is designed for 
advanced interpretation of the impact of varying application rates on infiltration, depth of irrigation and 
even lateral spread of water where more than one probe is used. An alternative, the "Rate" mode, is 
particularly useful for pivot or linear movement irrigation systems where the rate of application is readily 
adjusted, and also for analyzing the impact of rainfall events. 

The segment box numbers  below the irrigation and rainfall bars show the total amount 
of water that has been applied over a given period between the vertical dotted lines. The duration of this 
period is dependent upon the time scale of the x-axis. In the example above, the graph zoom is such that 
each vertical dotted line represents a 12 hour period and the numbers represent the total amount of 
irrigation and rainfall for each 24 hour period 9am to 9am the next day. 

The y-axis shows the total water application for each event. The x-axis is the time scale. The width or 
thickness of the column reflects the duration of the water application. Therefore the amount of water 
applied in millimeters or inches is shown by the height of the column. This amount is also listed as a 
number underneath the bar when you zoom into a daily time-view. 

The influence of application rate on infiltration can be compared to an increase in soil moisture content. 
Higher application rates in some soil types can lead to surface run-off and poor infiltration. Light rain 
falling as drizzle will have different infiltration rates to heavy, storm events, but there will also be varying 
effects of canopy interception under some crop types. Plotting rainfall as a rate graph will help analyze 
the impact of rainfall on soil water content, which can help determine whether irrigation is necessary after 
rain. 

Example 5 - Fertilizer/Salinity Pane 
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This graph shows the fertilizer/Salinity pane above the moisture pane. The graph shows that the short 
irrigation event on 8 November caused an increase in the salinity, while the earlier irrigation events were 
long enough to flush the salts from the root zone. 

Example 6 - Matric Potential Graph 

 

This graph shows matric potential in the primary pane. It is showing regular daily irrigation events and 
weekly larger saturating applications. There is also a general drying trend over the month (summer). 

You cannot graph moisture and matric potential in the same pane because the axis units are different. 

Example 7 - Custom Sensors 

 

This voltage pane, from an EnviroSCAN Plus system, shows the battery voltage at each sample interval 
(sensor V1) and the voltage at each upload to the Internet (sensor V2, daily at 11:00 pm). 

Another use for this pane is to display a stacked graph of the same sensors that are present in a summed 
graph in the primary graph pane. 
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Software Reference Guide 
This guide describes the use of each component of the software. 

The Workspace Manager Window is the main window of the application and is used to organize and 
access the various IrriMAX files and documents. 

• See page 29 for an introduction to the workspace concept. 
• See page 41 for how to use the Workspace Window. 

 
The IrriMAX Settings Dialog is used to configure the way IrriMAX operates, and to specify how it should 
display things like dates and measurement units. See page 74. 

The Logger Configuration Dialog is used to create IrriMAX databases and to configure RT6 loggers. It 
provides access to the Calibration Registry Dialog for managing the sensor calibrations associated with 
different soil types, and the Sensor Properties Dialog which is used to maintain a registry of user-defined 
sensors. 

• See page 91 for how to use the Logger Configuration Dialog. 
• See page 101for how to use the Sensor Properties Dialog. 
• See page 103 for how to use the Calibration Registry Dialog. 

 
Various tools are available for updating and manipulating databases. These include manual data entry, 
downloading and data trimming or extracting. Most tools are available from either the workspace 
manager window or the graph windows. See page 106. 

The Sensor Selection Dialog is used to select sensors from a database and create a new graph. See page 
115. 

The Layout Window is used to organize your databases in a graphical form. It can be used to create 
graphs. See page 118. 

The Graph Window displays your data in a graphical form and provides tools to assist in interpretation 
and decision making. See page 135. 

The Text Data Viewer is launched from the Graph Window and allows you to see the actual values from 
the database that the graph is displaying. See page 184. 

Finally, the data import and export functions of IrriMAX make use of the integrated Data Exchange 
utility. See the Data Exchange documentation for more information. 

Workspace Manager Window 
The Workspace Manager or Workspace Window is the main window of the IrriMAX program. It provides 
access to all of the graphs, layouts and databases associated with the currently open workspace document. 
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The Workspace Manager window consists of a menu bar, toolbar, the workspace bar, the main display 
area and a status bar. There are also two windows that may appear at the bottom of the Workspace 
Manager window - the Alerts window and the Download window. 

Menu bar 
The menu bar contains all commands under five menus - File, Edit, View, Tools, Window and Help. 
Each of these menus contains sub menus and commands. The steps described in this manual refer to the 
menu paths even if there is another way of invoking the command. Where available, the menu commands 
display the shortcut keys that perform the equivalent command. 

Toolbar 
The toolbar is used to quickly access major editing and viewing commands that are applicable to the 
workspace window. The toolbar displays by default but can be hidden or displayed as required. 

Workspace bar 
The workspace bar contains buttons for accessing the layout and text data viewer windows in the 
workspace. It also contains tabs for switching whether the main display area of the workspace shows a 
graph list or a database list. The toolbar displays by default but can be hidden or displayed as required. 

Main Display Area 
The main area of the window displays either a list of graphs or a list of databases. The lists can be 
switched by the tabs on the Workspace Bar or from the View menu. 
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Alert window 
The Alert window displays whenever a user-defined alert trigger is activated. It will not appear if there 
are no current alerts. Alerts are displayed in order of priority. Red alerts are the highest priority, then 
yellow and then green. 

To suppress the display of alerts, the window can be closed using its Close button, or Show Alerts can be 
deselected from the View menu. This is a per-workspace setting. 

The window can be resized by dragging the top of its caption bar. It can also be shrunk by double-
clicking its caption bar, and restored to its previous size by double-clicking again. 

Download window 
The Download window displays whenever a background download is in progress. To close the window 
(and abort the download) use the window's Close button, or Download Window can be deselected from 
the View menu. 

The window can be resized by dragging the top of its caption bar. It can also be shrunk by double-
clicking its caption bar, and restored to its previous size by double-clicking again. 

Status bar 
The status bar at the bottom of a window displays information about the window. As you use the mouse 
to point to icons on a menu or toolbar, the name of the command being selected appears in the status bar. 

The Workspace Manager window commands 
All Workspace Manager commands are available from one of the following: 

• menus on the menu bar 
• buttons on the toolbar 
• shortcut keys on the keyboard 
• options from the title bar shortcut menu (right-click on title bar to see the menu) 

 
Note: Not all commands are available using all methods. 

Managing windows with Workspace Manager 
Workspace Manager allows its windows to be independently maximized, minimized and restored. When 
they are minimized they disappear. Special operations that can be performed in IrriMAX Windows 
include: 

• Cascade and Tile vertically or horizontally 
• Control windows of the same type as a group (graphs, layouts) 
• Bring layouts to the front 
• Send behind the other windows 
• Rearrange icons on the desktop (while minimized) 
• Control graphs from the Workspace window 
• When the Workspace is minimized, all windows become hidden 

 
For further detail see page 70.  

Workspace Manager Graph List 
The Graph List is shown by default when the workspace is first loaded. It contains a row for every graph 
window that is open in the workspace. 
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The Graph List contains five columns. These are: 
• Last - displays the last summed value from the summed graphs. The value is displayed using a 

soil moisture gauge so that you can view the current moisture summed value compared to the Full 
and Refill points set in the graph. 
For non-summed graphs, the type of the graph (stacked, separate-Y, common-Y) is shown in icon 
form. 
Note that the information in this column refers to the primary graph pane only. 

• Graph Info -displays the title of each graph file saved within the workspace. The graph file name 
is shown bold and underlined and the following lines list the sites and probes selected in to the 
graph and the information entered in to the graphs comments field. 
Clicking anywhere on the Graph Info cell for the graph opens and displays that graph. 

• Sensor Types - lists the different types of sensor shown in all panes of the graph. 
• Print - Graphs with the check box selected will be printed when the File menu Batch Print 

command is selected or a graph file is opened with the Print option. This column is also used for 
selecting graphs to mail or webify. 

• Controls -displays the Minimize, Maximize and Close buttons for the graph windows. These 
controls allow you to manipulate each graph window directly from the workspace manager. 

 

Ø  To show the graph list 

• Either select Graphs from the workspace manager View menu. 
• Or click on the Graphs tab in the workspace bar. 

 

Managing graphs from the Graph List 
In the Graph List  you can see the type of graph that has been created and the graph's file name and other 
information. 



 IrriMAX User Guide 
 Software Reference Guide 

Sentek Pty Ltd 45 

You can click on the graph title to display the graph. 

 

 

You can also use the controls to manage each open graph window. See page 70 for details on other ways 
to manage windows. 

 

The soil moisture gauge 
The soil moisture gauge is displayed for summed graphs. The gauge displays the last value from the 
summed graph in relation to the Full and Refill points set in the graph. 

Important Note: The last reading is the last one from the database and is not necessarily the last one in 
the logger. 

The usefulness of the fuel gauge will depend on the accurate positioning of the agronomic lines on the 
summed graph. A trained agronomist should set these positions. 

 

If the soil moisture gauge pointer is: 
• in the blue, the last summed value is currently above the value assigned to indicate the Full Point. 
• in the green, the last summed value is less than the value set for the Full Point and greater than the 

value set for the Onset of Stress. Therefore, the soil water content for the soil profile being 
graphed is within the agronomic lines set. 

• in the red, the last summed value has fallen below the value assigned to Onset of Stress.  
 

Missing databases 
If you open a workspace containing a graph, and the original database file has been removed or renamed, 
or contains no valid data, a large red question mark displays in place of the soil moisture gauge. You can 
search for the missing database to update the graph and workspace. See page 147 for details of finding 
missing databases from the Graph window. 
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Sorting and arranging graph rows 

Ø  To sort the graph rows 
Click on a column title to sort the graph rows by the information in that column. Click on the same 
column title a second time to reverse the direction of the sort. The sort order is permanently maintained, 
so graph rows will automatically change position when information is changed. 

• Click on Last to sort the graphs in order of irrigation urgency (based on proximity of the last value 
to the refill point.). Non-summed graphs follow, sorted by type. 

• Click on Graph Info to sort the graphs in alphabetical order of name. 
• Click on Sensor Types to sort the graphs in alphabetical order of sensor type. 
• Click on Print to sort the graphs based on whether they are selected for printing or not. 
• Click on Controls to sort the graphs based on whether they are minimized or not. 

 
To stop automatically sorting, reposition a graph row manually using the steps below. 

Ø  To manually move a graph row to a new position 
• Click a row using the left mouse button and start moving the mouse without releasing the button. 
• The mouse cursor changes to indicate the row is being dragged. 
• Release the left mouse button over the row which occupies the desired position of the row you are 

moving. 

Workspace Manager Database List 
The Database List is hidden by default when the workspace is first loaded. It contains a row for every 
database linked from the layouts and graphs in the workspace, and every database that has been manually 
added to the workspace. 

Various functions on the File, Edit and Tools menus require selection of a database as a first step. If the 
Database List is visible and a database is highlighted, these functions will use the highlighted database 
rather than prompting you to browse for one. 
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The Database List contains six columns. These are: 
• Name - displays the file name of the database and an icon indicating whether the database is a 

standard IrriMAX database (SDB file) or an Irrigation and Rainfall Database (WDB file). The 
icons are greyed if the database is not currently in use in a graph or layout open in the workspace. 

• Path -displays the file-system folder in which the database is stored. 
• Logger Id - displays the Id of the logger whose readings are stored in the database. 
• Last Reading - Displays the time stamp of the last reading in the database. 

 
• The fifth column displays icons indicating whether the database has a download command, and 

whether the download is to be run as part of the batch (automatic or unattended) download. 
Double-clicking within this column will invoke the Download Wizard (see page 88.) 

 

 Signifies that the database has a download command defined. 

 The database has a download command, and is flagged to be included in the batch or 
unattended download. 

 The database was created as a result of downloading to another database. It has no 
download command of its own, but downloading to the other database will also 
download to this one. This is a result of a single download source supporting multiple 
destinations. 

 
• The sixth column displays icons indicating if there are alerts defined for the database, and if these 

alerts are disabled or raised. Double-clicking within this column will invoke the Database 
Properties dialog (see page 62.) 

 

 Signifies that the database has alert triggers defined, but none are raised. 

 The database has alert triggers defined, but they are currently disabled. 

 The database has a red alert currently raised. 

 The database has a yellow alert currently raised. 

 The database has a green alert currently raised. 
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Ø  To show the database list 

• Either select Databases from the workspace manager View menu. 
• Or click on the Databases tab in the workspace bar. 

 

Ø  To show the popup menu 
Database-related commands on the workspace toolbar and menu are also accessible directly from the 
database list on a popup menu. 

Click on a database in the list with the right mouse button. The popup menu appears. 

Ø  To sort the database list 
Click on a column title to sort the database rows by the information in that column. Click on the same 
column title a second time to reverse the direction of the sort. 

The rows will remain sorted by that column as databases are added, removed or modified. The sort 
column and direction is saved in the workspace document. 

Ø  To add a database to the list 

Ensure the database list is visible, then choose Add Database… from the Edit menu, or click the  
button in the toolbar. 

This function is disabled if the database list is not shown. 

Ø  To remove one or more databases from the list 
Ensure the database list is visible and at least one database is highlighted, then choose Remove Database 

from the Edit menu or click the  button in the toolbar. Alternatively choose Remove from the 
database list popup menu. 

It is not possible to remove a database if it is being referenced by a graph or layout in the workspace. You 
can only remove non-referenced databases. These are distinguished by gray icons. 

This function is disabled if the database list is not shown. 

Workspace File Menu 
The File menu displays file commands for the Layout, Graph and Workspace windows. 

New databases and logger configurations may also be created from the Workspace Manager File menu. 
The menu commands, equivalent shortcuts and tool buttons are: 

Menu item Shortcut key Button To... 

New Ø ALT, F, N  Expand the New submenu. 

 Workspace CTRL+SHIFT+W 
or 
ALT, F, N, W 

 
Create a new workspace. 

 Database CTRL+SHIFT+D 
or 
ALT, F, N, D 

 
Create a database using the New Database Wizard. See 
page 86. 

 Layout CTRL+SHIFT+L 
or 
ALT, F, N, L 

 
Create a new layout. See page 118. 
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Menu item Shortcut key Button To... 

 Graph CTRL+SHIFT+G  
or 
ALT, F, N, G 

 
Open the Sensor Selection dialog to create a graph. See 
page 115. 

(Also available as New Graph… on the Database List 
popup menu.) 

Open Ø CTRL+O  
or 
ALT, F, O 

 
Expand the Open submenu, or browse for all IrriMAX file 
types if CTRL+O is used. 

 Workspace... CTRL+W  
or 
ALT, F, O, W 

 Open a workspace. 

 Database... CTRL+D  
or 
ALT, F, O, D 

 Open a database in the Logger Configuration Dialog. See 
page 91. 

(Also available as Open… on the Database List popup 
menu.) 

 Layout... CTRL+L  
or 
ALT, F, O, L 

 Open a layout. 

 Graph... CTRL+G  
or 
ALT, F, O, G 

 Open a graph. 

 Package... ALT, F, O, P  Open an IrriMAX file package. 

Save Workspace CTRL+S  
or 
ALT, F, S 

 
Save changes to the current workspace. Stores the position 
and ordering of the workspace, graph and layout windows. 

Save Workspace As... ALT, F, A  Save the workspace with a new name. 

Save All CTRL+SHIFT+S  
or 
ALT, F, L 

 
Save all open workspaces, graph and layouts. 

Save Package… ALT, F, K  Save all workspace files in an IrriMAX file package. See 
page 33. 

Recent Workspaces ALT, F, W  Open a recently used workspace. 

Recent Graphs ALT, F, G  Open a recently used graph. 

Recent Layouts ALT, F, L  Open a recently used layout. 

Batch Print... CTRL+P  
or 
ALT, F, P 

 
Print all selected graphs. See page 53. 

Page Setup... ALT, F, U  Change the current print page setup. See page 54. 

Properties… ALT+ENTER  
or 
ALT, F, R 

 
Change the properties of the current workspace. See page 
54. 

Exit ALT+F4 
 

Close the IrriMAX software. 

(button is on the title bar) 

Creating new files in Workspace Manager 
The Workspace Manager window can be used to create new workspaces, layouts, graphs and databases. 
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Ø  To create a new workspace 
From the File menu, select New and click Workspace,or click the corresponding toolbar button. A new 
unsaved workspace displays. 
Note: If a workspace is already open with unsaved changes to the workspace, graphs or layouts, a 
message box displays, prompting you to save each changed file. 

Ø  To create a new database 
From the File menu, select New and click Database, or click the corresponding toolbar button 
The New Database Wizard appears. See page 86. 

Ø  To create a new layout 
From the File menu, select New and click Layout, or click the corresponding toolbar button 
An unsaved blank layout displays in the layout window. See page 120 for details on using the layout 
window. 

Ø  To create a new graph 
Do one of the following to create a new graph. 

• Click on a database in the Database List to highlight it. Press the right mouse button and choose 
New Graph… from the popup menu. 

• Click on a database in the Database List and choose Graph.. from the New submenu of the File 
menu or click the corresponding toolbar button. 

• If the Database List is not visible or there is no highlighted database, choose Graph… from the 
New submenu of the File menu, or click the corresponding toolbar button. 

 
1. From the File menu, select New and click Graph. 

The Open dialog box displays (to open the database in which the graph will get the data). 

 
 

2. In the Look in: box, click on the drop-down arrow and browse for the folder where the 
database file is located. A list of available files displays. 
 

3. Click on the database to be used to create the graph. 
 

4. Click Open. 
 

After performing one of the above steps, the Sensor Selection dialog will appear to allow you to select the 
sensors to appear in your new graph, and choose the type of graph to create. See page 115. 

You can also create graphs from the layout window. See page 118. 
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Opening files in Workspace Manager 

Note: Clicking  displays all IrriMAX file types in the Open dialog box. 

All IrriMAX file types can be opened and managed from the Workspace Manager. When an IrriMAX 
file is opened from Workspace Manager, it opens in the appropriate window. For example, if you open a 
stacked graph file (*.GSK), a graph summary displays in the Workspace Manager window and the graph 
file displays in the Graph window. 

When you open an existing workspace, all associated windows open, one by one, in the background. 
Since a workspace maintains a list of all layouts and graphs associated with the workspace, each of these 
files opens, in its own window, in the original size and position as when the workspace was last saved. 

You can open files by: 
• browsing to the directory containing the file and selecting the file 
• selecting a file from the recent files list in the File menu. 

 
A recently used file is a file that has been opened before. Workspace Manager maintains a list of recently 
used files from which you can select a file to open. The recently used file list is continually updated each 
time you open a file. A maximum of four files (for each file type) is displayed in the list. 

Ø  To open a file 
1. From the File menu, select Open and click one of the following: 

• Workspace... to open a workspace in the Workspace Manager window 
• Database... to open a database in the Logger Configuration dialog box 
• Graph... to open a graph in a Graph window 
• Layout... to open a layout in a Layout window 
• Package... to open a package file containing any or all of the above 
 
The Open dialog box displays.  

 
2. In the Look in: box, click on the drop-down arrow and browse for the directory where the file is 

located. 
A list of available files displays. 

3. Click on the file to be opened. 

4. Click Open. 
The file opens and displays in the appropriate window. 
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Ø  To open a recently used file 
1. From the File menu, click one of the following: 

• Recent Workspaces to display a list of recent workspaces 
• Recent Graphs to display a list of recent graphs 
• Recent Layouts to display a list of recent layouts. 
A list of the recently used files displays. 

 
2. Click on the required file from the list. 

The selected file opens in the appropriate window. 

Saving workspaces 
When you create a new workspace, the workspace file does not exist until you save and name the file. To 
quickly save changes to all open files (workspaces, layouts or graphs) you can use the Save All 
command. 

If you want to save the workspace with a different file name, the Save As command is used.  

Note: If you close the Workspace Manager window, or try to open a new or existing workspace, you are 
prompted to save all unsaved files used in the currently open workspace. The unsaved files could include 
workspaces, layouts or graphs. 

Ø  To save a workspace 
 1. From the File menu, click Save Workspace. 

If the workspace is an existing workspace, the file information is saved. 
You are prompted to save any unsaved layouts or graphs. 

2. If any files have not been saved before, the Save As dialog box displays for each unsaved file. 

 
3. Select a file location for each new file. 

Note that the default name for a new workspace is 'Workspace'. 

4. Enter a file name for each new file. 

5. Click Save. 
The new file is saved. 



 IrriMAX User Guide 
 Software Reference Guide 

Sentek Pty Ltd 53 

Ø  To save a workspace as a new file 
 1. From the File menu, click Save Workspace As.... 

The Save As dialog box displays.  

2. Select a file location for the new database. 

3. Enter a file name for the new workspace. Note that the current file name displays in the File name 
dialog box. 
Note: If you do not enter a new file name, the original file will be replaced with this file.  

4. Click Save. 
The new workspace is saved. 

 

Ø  To save all open windows 
 1. From the File menu, click Save All. 

The file information is saved for all open layouts, graphs and the workspace.  

2. If any files have not been saved before, the Save As dialog box displays for each unsaved file. 

3. Select a file location for each new file. 

4. Enter a file name for each new file. 

5. Click Save. 
The new file is saved. 

Printing from Workspace Manager 
Batch printing is used to print one or more graphs at a time. Before you run the Batch Print command, 
you must have already selected the graphs to be printed. Graphs to be printed are selected in the Print 
column of the Workspace Manager window.  

 

Ø  To batch print graphs 
1. From Workspace Manager, select the graphs to include in the batch printing. 

2. From the File menu, click Batch Print.... 
The Batch Print dialog box displays. 
 

 
 

3. Select a printer. 
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4. Click OK. 
The progress meter displays as graphs are sent to the printer. 

Using Page Setup 
The Workspace Manager Page Setup command is used to control the default orientation (portrait or 
landscape) of new documents. After a document is created, you can use the Page Setup from the File 
menu of that document, to change the paper orientation and margins. The paper size, budget region 
dithering and source are common to all Page Setup dialogs, so changing those parameters on one 
document is reflected in Page Setup of all documents. 

Note: Changes to the printer settings apply only to IrriMAX and do not alter the printer settings for any 
other application. 

Ø  To set the page setup options 
1. From the File menu, click Page Setup.... 

The Page Setup dialog box displays. 

 
Do one or more of the following: 

2. Under Paper, select from the drop-down lists: 

• The required paper size 
• The paper source 

3. Under Orientation, select either Portrait or Landscape. 

Workspace Properties 
The Workspace Properties dialog presents a number of tab pages containing properties that are stored 
within the workspace document. 

General 
The General property page  is used to set various properties of the workspace (currently only the 
workspace comment). 
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Comment 
Enter anything you like in this control. Text will wrap automatically. 

Alerts 
The Alerts property page is used to set the properties of the workspace that control how alerts are mailed. 
These properties are used when manually mailing alerts using the Mail Alerts dialog (see page 68) and 
when mailing alerts using the command-line (see page 25). 

 

Recipients 
Enter the email addresses of the recipients of the alert notifications, separated by commas. Enter the email 
addresses here if you will repeatedly email the same people. Otherwise you can enter the recipients at the 
time you create the email. 

Combine multiple alerts into one email 
Check this box to combine all the alert notifications into one email. If this option is not selected, then a 
separate email will be sent for each alert notification. 
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You may wish to send separate emails if you are using an Email to SMS service and you want to ensure 
that each alert notification fits within the 160-character size limitation of SMS. On the other hand, you 
may wish to save costs by combining as many alerts as possible into each SMS and rely on the Email to 
SMS service to split them over multiple SMS messages and the recipient's mobile phone to recombine 
them. 

Notify about new alerts only 
Check this box to limit alert notifications to those alerts that have been raised since the last email was 
sent. 

This can be useful for saving costs if you are using an Email to SMS service, or to minimize annoyance 
for the recipients. However, it increases the chance that alerts might be overlooked by the recipients. 

If you select this option it is recommended that you also choose to notify when an alert is over (see 
below). This is because the recipient no longer receives a complete list of all current alerts with each 
mailing. 

Notify when an alert is over 
Check this box to be notified if an alert, for which a notification email was sent, is now over. This 
notification will be sent only once. 

Mail Workspace 
The Mail Workspace property page is used to set the properties of the workspace that control how HTML 
graph snapshots are mailed. 

 

Recipients 
Enter the email addresses of the recipients of the emailed graph snapshots, separated by commas. Enter 
the email addresses here if you will repeatedly email the same people. Otherwise you can enter the 
recipients at the time you create the email. 

Subject 
Enter text for the subject line of the emails. Leave blank to use the graph names. 

The subject text can contain certain macros that will be replaced with information specific to the graph 
you are mailing. These macros are: 

• GRAPH_NAME_TEXT is replaced by the name of the graph. 



 IrriMAX User Guide 
 Software Reference Guide 

Sentek Pty Ltd 57 

• GRAPH_COMMENT_TEXT is replaced by the user-entered comment for the graph. 
• GRAPH_LOGGER_TEXT is replaced by the Logger ID from the database shown in the main 

pane of the graph. 
• GRAPH_DOWNLOAD_TEXT is replaced by the date and time of the last download into the 

database shown in the main pane of the graph. 
 

Template 
A template file to use when converting the graphs to emails. Leave blank to use the default template (see 
page 83.) 

Use the Browse… button to search for a different template file. 

Graphic Dimensions 
The width and height in pixels of the graphical part of the emailed graph snapshot. Enter 0 to use the 
same width or height as on screen. 

Override these dimensions with those in graph document 
If this box is checked and a graph document specifies a non-zero dimension in its properties, then the 
graphic dimension will be taken from the properties of the graph document.  

An example of when this can be useful is if a particular graph contains a large number of panes. It might 
be desirable to specify a large height value for that graph only. 

Only include graphs marked for batch printing 
Check this box to mail only those graphs with a tick in the Batch Print column in the workspace manager 
window. 

Scroll graphs to end 
Check this box to scroll the graphs to reveal the most recent readings, prior to taking the snapshot for 
emailing. Note that the graphs will continue to show the new time range after the process is complete. 

Zoom graphs to preset date range 
Check this box to zoom the graphs to their preset date range, prior to taking the snapshot for emailing. 
Note that the graphs will continue to show the new range after the process is complete. 

Stack separate graphs 
Check this box to arrange separate graphs in sensor order, stacked as close as possible on top of each 
other without overlap, and zoomed to vertical extents, prior to taking the snapshot for emailing. Note that 
the graphs will remain stacked after the process is complete. 

Zoom graphs to vertical extents 
Check this box to zoom the graphs to show their full vertical range, prior to taking the snapshot for 
emailing. Note that the graphs will continue to show the new range after the process is complete. 

Include budget lines in extents 
Check this box to ensure that all visible budget lines remain visible if zooming to vertical extents. 

Webify Workspace 
The Webify Workspace property page is used to set the properties of the workspace that control how the 
workspace is converted to web-compatible form. 
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Workspace Template 
A template file to use when converting the workspace to web-compatible form. Leave blank to use the 
default template (see page 83.) 

Use the Browse… button to search for a different template file. 

Output Folder 
Use the Browse… button to select a folder to receive the files output by the webification process. 
Alternatively you can type the name of the folder in the edit box. 

If the folder you specify does not exist, it will be created during the webification process. 

You may enter a path relative to the location of the workspace document, rather than supply a full path. 

You can leave this field blank if you also select Upload when complete. IrriMAX will output the 
webified files to a temporary folder and delete them after the upload. 

Output File Name 
The name for the webified workspace file. Leave blank to use the workspace name. Index.html is another 
common choice. 

Only include graphs marked for batch printing 
Check this box to include only those graphs with a tick in the Batch Print column in the workspace 
manager window. 

Upload when complete 
Check this box to upload the generated files to the Internet using FTP. 

Webify Graphs 
The Webify Graphs property page is used to set the properties of the workspace that control how the 
graphs are converted to web-compatible form. 
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Graph Template 
A template file to use when webifying the graphs. Leave blank to use the default template (see page 83.) 

Use the Browse… button to search for a different template file. 

Graphic Dimensions 
The width and height in pixels of the graphical part of the emailed graph snapshots. Enter 0 to use the 
same width or height as on screen. 

Override these dimensions with those in graph document 
If this box is checked and a graph document specifies a non-zero dimension in its properties, then the 
graphic dimension will be taken from the properties of the graph document.  

An example of when this can be useful is if a particular graph contains a large number of panes. It might 
be desirable to specify a large height value for that graph only. 

Scroll graphs to end 
Check this box to scroll the graphs to reveal the most recent readings, prior to webifying them. Note that 
the graphs will continue to show the new time range after the process is complete. 

Zoom graphs to preset date range 
Check this box to zoom the graphs to their preset date range, prior to webifying them. Note that the 
graphs will continue to show the new range after the process is complete. 

Stack separate graphs 
Check this box to arrange separate graphs in sensor order, stacked as close as possible on top of each 
other without overlap, and zoomed to vertical extents, prior to webifying them. Note that the graphs will 
remain stacked after the process is complete. 

Zoom graphs to vertical extents 
Check this box to zoom the graphs to show their full vertical range, prior to webifying them. Note that the 
graphs will continue to show the new range after the process is complete. 
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Include budget lines in extents 
Check this box to ensure that all visible budget lines remain visible if zooming to vertical extents. 

FTP Upload 
The FTP Upload  property page is used to set the properties of the workspace that control how the 
webification output files are uploaded to the Internet. 

 

Address 
The name or IP address of your FTP server. 

Path 
Path of a folder on the FTP server, relative to the default login folder, to receive the uploaded files. 

Port 
Port number to use when connecting to your FTP server. Usually 21. 

Passive Mode 
Check this box to connect using passive mode, uncheck for active mode. See glossary entry for FTP for 
more information. 

User Name 
User name for authentication by your FTP server. 

Password 
Password for authentication by your FTP server. 

Recipients 
Email addresses of recipients for a notification email after successful upload, separated by commas. 
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Path URL 
The URL for public access to the upload folder on the FTP server. Used to place a hyperlink in the upload 
notification email. 

Workspace Edit Menu 
The Edit menu displays edit commands for the workspace window. The menu commands, equivalent 
shortcuts and tool buttons are: 

Menu item Shortcut key Button To... 

Add Database… INSERT 
or 
ALT, E, A 

 
Select a database to add to the workspace. 

Remove Database DELETE 
or 
ALT, E, R 

 
Remove the currently selected databases from the 
workspace. This is only possible if the databases are not 
being referenced by a graph or layout (i.e. the icon for the 
database in the Database List is gray). 

(Also available as Remove on the Database List popup 
menu.) 

Download Wizard… ALT, E, Z  Launch the Download Wizard to set up a download source 
for a single selected database. See page 88. 

Start Download F7 
or 
ALT, E, D 

 Run the download commands for one or more selected 
databases. 

Start Batch Download SHIFT+F7 
or 
ALT, E, B 

 Run the download commands for all databases that have 
the "include in batch download" flag set. 

Database Properties… ALT, E, P  Show the Database Properties dialog (see page 62.) 
 

Ø  To download into a selection of databases 
1. Reveal the Workspace Manager's databases list by clicking on the Databases tab. 

2. Click on a database in the list to highlight it. You can select more than one database by holding the 
CTRL key while clicking to select additional databases one at a time, or the SHIFT key to select a 
range of databases. Each database must have a download command set up by the Download Wizard 
(see page 88.) Databases with download commands are marked with  or . 

3. From the Edit menu, click Start Download. Alternatively you can right-click the selected databases 
and choose Start Download from the popup menu. 

4. Each selected database will be downloaded in turn as a background process. Download progress is 
shown in the Download Window at the bottom of the Workspace Manager. Closing the window 
cancels the download. See page 46. 

 

Ø  To start a batch download 
1. At least one database in the workspace must have a download command set up, and have the 

"include in batch download" flag set by the Download Wizard (see page 88.) Such databases will be 
marked with . 

2. From the Edit menu, click Start Batch Download. 

3. Each batch database will be downloaded in turn as a background process. Download progress is 
shown in the Download Window at the bottom of the Workspace Manager. Closing the window 
cancels the download. See page 46. 
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Database Properties Dialog 
The Database Properties dialog allows you to store extra information about databases, and to define alert 
triggers based on the last reading in the databases. It can be used to define these properties for a single 
database, or for a selection of multiple databases all at the same time. 

Note: These properties are stored in the workspace document, not the database itself. 

 

Ø  To set database properties 
1. Click on a database in the workspace manager's database list to highlight it. You can select more 

than one database by holding the CTRL key while clicking to select additional databases one at a 
time, or the SHIFT key to select a range of databases. 

2. From the Edit menu, click Database Properties… Alternatively you can right-click a selected 
database and choose Database Properties… from the popup menu. 

3. Use the dialog to edit the properties. If a control is blank, this means that you are editing the 
properties of more than one database, and that particular property is not currently identical for all of 
them. If you leave the control blank and hit the OK button, that property will not be changed. 
Otherwise you can change the property and all the selected databases will have that property set to 
the new value. 

 

Database Time Zone 
The workspace document can store the time-zone for databases that are not using local time. This is used 
for sorting the Last Reading column in the database list, and for triggering and sorting those alerts based 
on the age of the last reading. 

The drop-down list contains a selection of time zones described by their offset from Universal Co-
ordinated Time (UTC) in hours and minutes. You can also choose Local Time and Local Time (no 
DST). The latter ignores daylight savings time. 

Alert Triggers 
Use the Enable alerts checkbox to enable or disable the generation of alerts based on the other settings in 
the Alert Triggers section. 

You can choose from No Alert, Red Alert, Yellow Alert and Green Alert from the drop-down lists for 
the two different types of alert triggers. 

The first alert trigger condition is based on whether the last reading in the database contains an invalid 
moisture or salinity value. 
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The second alert trigger condition is based on the age of the last reading in the database, compared to the 
current time, accounting for the database's time zone and the local time zone. You can choose a time 
period from the drop-down or type in a different value. 

Workspace View Menu 
The View menu lists elements of the window that may be displayed or removed from view, for example, 
toolbars. The toolbar and status bar display by default. The menu commands, equivalent shortcuts and 
tool buttons are: 

Menu item Shortcut key To... 

Graphs ALT, V, G Display the graph list in the Workspace Manager window. 

Databases ALT, V, D Display the database list in the Workspace Manager window. 

Show Alerts ALT, V, A Enable the display of the alert list at the bottom of the Workspace 
Manager window. 

Download Window ALT, V, O Display or hide the download window at the bottom of the Workspace 
Manager window. 

Toolbar ALT, V, T Display or hide the toolbar. When ticked, the toolbar displays. 

Workspace Bar ALT, V, W Display or hide the workspace bar. 

Status Bar ALT, V, S Display or hide the status bar. 

Viewing the graph and database lists 
The Workspace Manager window can display either a list of graphs in the workspace or a list of 
databases. These lists are most easily selected using the tabs on the workspace bar, but can also be 
switched from the View menu. 

Ø  To display the graph list or database list 
From the View menu, click: 

• Graphs to display the graph list and hide the database list. 
• Databases to display the database list and hide the graph list. 

Viewing the alert list 
The alert list is normally visible when there are currently triggered alerts, and hidden otherwise. It is 
possible to suppress the display of the alert window, even if there are alerts triggered. 

Ø  To enable or disable display of the alert list 
From the View menu, click: 

• Show Alerts to enable display of the alerts (item displays a check mark) or suppress display of 
alerts (item has no check mark.) 

Viewing the download window, toolbar, workspace bar and status bar 
The download window appears at the bottom of the Workspace Manager window whenever a download 
operation is started. Closing it will also stop the download. 

The toolbar is used to quickly access major editing and viewing commands that are applicable to the 
window. The toolbar displays by default but can be hidden or displayed as required. 

The workspace bar is used to switch the workspace between viewing graphs and databases. It also 
contains buttons for all open layout windows and text data windows. The workspace bar displays by 
default but can be hidden or displayed as required. If it is hidden, its functions can still be accessed from 
the View menu and the Window menu. 

The status bar at the bottom of a window displays information about the window. As you use the mouse 
to point to icons on a menu or toolbar, the name of the command being selected appears in the status bar. 



 IrriMAX User Guide 
 Software Reference Guide 

Sentek Pty Ltd 64 

Ø  To display or hide the download window, toolbar, workspace bar and status bar 
From the View menu, click: 

• Download Window to display or hide the download window. 
• Toolbar to display or hide the toolbar. 
• Workspace Bar to display or hide the workspace bar. 
• Status Bar to display or hide the status bar. 

Workspace Tools Menu 
The Tools menu provides a variety of options for manipulating databases and workspaces. 

All database tools apply to the currently selected database on the Workspace Manager's Database List. 
These tools are also available from the popup menu that appears when you right-click a database on that 
tab. 

If the Database List is not visible, or there is no current selection, then you will be required to browse for 
the database you want.  

The Tools menu commands, equivalent shortcuts and tool buttons are: 

Menu item Shortcut key Button To... 

Enter Readings… CTRL+E 
or 
ALT, T, E 

 
Open the Database Entry utility to enter readings into a 
database. See the Database Entry documentation for more 
information. 

Export… ALT, T, X  Open Data Exchange to export data from a database. See 
page 108. 

Trim/Extract… ALT, T, T  Trim readings from either end of a database, or extract 
readings from one database to another. See page 108. 

Spike Remover… ALT, T, S  Remove spikes from a database. See page 110. 

Recalculate Database… ALT, T, R  Recalculate the readings in a database. See page 113. 

Data Exchange... ALT, T, D  Launch the Data Exchange utility. See the Data Exchange 
documentation for more information. 

Zip Workspace... ALT, T, Z 
 

Copy all the files in the workspace to a ZIP archive. See 
page 64. 

Webify Workspace… ALT, T, W 
 

Generate a snapshot of the workspace in Web-compatible 
format and optionally upload it to a FTP server. See page 
65. 

Upload Workspace… ALT, T, U  Upload workspace files to a FTP server. 

Mail Graphs… ALT, T, M 
 

Send snapshots of all or some of the graphs as Web-
compatible emails. See page 66.  

Mail Alerts… ALT, T, A  Send alert notifications via email. See page 68. 

IrriMAX Settings... ALT, T, E 
 

Change the global settings for the application. See page 74. 

 

Zip Workspace 
A single workspace document and its associated graph, layout and database files can be copied to a Zip 
archive. This is convenient for making back-ups, or for giving the files to another person. 

Ø  To copy a workspace and associated files to a Zip archive 
1. From the Tools menu of the workspace manager window, select Zip Workspace… 

2. A file selection dialog appears. Choose the name and location for the Zip file and click Save. 
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If the Zip file already exists, IrriMAX will prompt for confirmation before overwriting it. It will not add 
files to an existing archive. 

The archive will contain the workspace document, all the graph and layout documents in the workspace, 
and each database (.SDB file) that is currently being viewed in a graph window. If an irrigation and 
rainfall database (.WDB file) exists with the same name as the database in the main pane of a graph 
window, it will be backed up regardless of whether it is being viewed or not. 

The Zip file will contain full path information for each file. However, Zip files cannot store volume 
information, so the volume name will be represented as the top-level folder in the path. For example, the 
file C:\Files\Workspace.sws will be stored within the Zip file as C\Files\Workspace.sws. 

Webify Workspace 
A snapshot of the current workspace can be converted into web-compatible files (HTML). 

This is useful for converting the workspace into a universal format for use in presentations or for 
publishing on the Internet. 

The webification process produces a web-compatible document (usually a HTML file) for each graph, 
with an embedded graphic file showing those elements of the graph that cannot be otherwise represented. 
The graphic file is in PNG (portable network graphics) format and is viewable in most modern browsers. 

A document is also produced for the workspace, with links to each of the graphs. This document contains 
embedded thumbnail images of the graphs, and soil-moisture gauges for each summed graph. 

After a workspace has been webified, IrriMAX can upload the generated files to the Internet using FTP. 

Ø  To webify a workspace 
1. From the Tools menu of the workspace manager window, select Webify Workspace… 

2. The Webify Workspace dialog appears 

 

 

Output Folder 
Use the Browse… button to select a folder to receive the files output by the webification process. 
Alternatively you can type the name of the folder in the edit box. 

If the folder you specify does not exist, it will be created during the webification process. 

You may enter a path relative to the location of the workspace document, rather than supply a full path. 

You can leave this field blank if you also select Upload when complete. IrriMAX will output the 
webified files to a temporary folder and delete them after the upload. 
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Only include graphs marked for batch printing 
Check this box to include only those graphs with a tick in the Batch Print column in the workspace 
manager window. The value you enter here will update the stored property in the workspace document. 

Upload when complete 
Check this box to upload the generated files to the Internet using FTP. The value you enter here will 
update the stored property in the workspace document. 

Message for Upload Notification Mail 
This field will be active if you choose to upload when complete, and you have specified one or more 
recipients in the workspace's FTP Upload properties.  You can enter a message specific to this upload. 
The message will not be saved in the workspace document. 

More Properties… 
Click this button to invoke the Webify properties pages for the workspace (see page 57). From there you 
can specify additional properties to fine-tune the way the webified workspace will appear. 

OK 
Click OK to webify the workspace. When the process is complete, you will be asked if you wish to view 
the output. IrriMAX will open the files using your default web browser. 

Finally, if you selected Upload when complete, Data Exchange will open in a special mode to allow 
upload of the files using FTP. 

Upload Workspace 
Some or all of the files comprising the workspace can be uploaded to a FTP server, either individually or 
combined in an IrriMAX File Package. 

Ø  To upload the workspace 
1. From the Tools menu of the workspace manager window, select Upload Workspace… 

2. The Upload Workspace dialog appears 

 

 

3. Choose which file types to upload. 

4. Choose whether to combine the files into a package. 

5. Click Next. Data Exchange will open in a special mode to allow upload of the files using FTP. 
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Mail Workspace 
 Snapshots of the graphs as currently shown on screen can be sent as HTML emails, viewable within the 
recipient's email client. Alternatively the actual workspace document and all related files can be sent as an 
IrriMAX package file or as a Zip archive. 

 

Note: Sending HTML snapshots requires that the recipient's email client is configured to allow 
HTML emails with embedded pictures. If the recipient's security policy forbids this, it should be 

possible for them to create an exception for emails originating from you. 

Ø  To mail the workspace 
1. From the Tools menu of the workspace manager window, select Mail Workspace… 

2. The Mail Workspace dialog appears 

 

 

Recipients 
Enter the email addresses of the recipients of the emailed graph snapshots, separated by commas. This 
field is mandatory. The value you enter here will update the stored property in the workspace document. 

Subject 
Enter text for the subject line of the emails. Leave blank to use the graph names. The value you enter here 
will update the stored property in the workspace document. 



 IrriMAX User Guide 
 Software Reference Guide 

Sentek Pty Ltd 68 

The subject text can contain certain macros that will be replaced with information specific to the graph 
you are mailing. These macros are: 

• GRAPH_NAME_TEXT is replaced by the name of the graph. 
• GRAPH_COMMENT_TEXT is replaced by the user-entered comment for the graph. 
• GRAPH_LOGGER_TEXT is replaced by the Logger ID from the database shown in the main 

pane of the graph. 
• GRAPH_DOWNLOAD_TEXT is replaced by the date and time of the last download into the 

database shown in the main pane of the graph. 

Message 
Enter optional text to include in the body of every graph email. 

Send 
Choose the type of email to send. Select HTML Email to mail static snapshots of the graphs that the 
recipient can view in their Email client software. 

Select IrriMAX Package to send the workspace document and all related files in an IrriMAX package 
(.imxpak) file. The recipient will be able to open the package directly from the email if they have 
IrriMAX 9.1 or later installed. 

Select Zipped Workspace to send the workspace document and all related files in a standard Zip archive. 

Only include graphs marked for batch printing 
Check this box to mail only those graphs with a tick in the Batch Print column in the workspace manager 
window. The value you enter here will update the stored property in the workspace document. 

This setting only applies when sending HTML emails. It has no effect when sending packages or Zip 
archives. 

More Properties… 
Click this button to invoke the Mail Workspace properties page for the workspace (see page 56). From 
there you can specify additional properties to fine-tune the way the HTML emails will appear. 

OK 
Finally, click OK to email the graphs. At this point, the Mail Settings page might appear if you have not 
already configured IrriMAX for sending mail (see page 82). 

Mail Alerts 
You can send notifications of your alerts to nominated recipients using email. 

Ø  To mail alert notifications 
1. From the Tools menu of the workspace manager window, select Mail Alerts… 

2. The Mail Alerts dialog appears 
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Recipients 
Enter the email addresses of the recipients of the emailed alert notifications, separated by commas. This 
field is mandatory. The value you enter here will update the stored property in the workspace document. 

Resend previously mailed alerts 
Check this box to ensure that the recipients are notified about all current alerts, regardless of whether a 
notification has been mailed before. 

Whether this box is initially checked depends on the value of the "Notify about new alerts only" 
workspace property (see page 55). However, changing the state of this box does not affect that stored 
property in the workspace document. 

More Properties… 
Click this button to invoke the Mail Alerts properties page for the workspace (see page 55). From there 
you can specify additional properties to fine-tune the way the email are sent. 

OK 
Finally, click OK to email the alert notifications. At this point, the Mail Settings page might appear if you 
have not already configured IrriMAX for sending mail (see page 82). 

Workspace Window Menu 
The Window menu provides options for sizing, displaying and accessing other open windows. 

Note: The shortcut keys for windows arrangement F3, F4 and F5 can be used in most IrriMAX windows 

The menu commands, equivalent shortcuts and tool buttons are: 

Menu item Shortcut key Toolbar 
Button 

To... 

Arrange Ø ALT, W, A  Open the Arrange submenu 

 Cascade F3 
or 
ALT, W, A, C 

 
Overlap all open windows. 

 Tile Horizontally F4  
or 
ALT, W, A, H 

 

Tile all open windows from the top to the bottom of 
the screen. 

 Tile Vertically F5  
or 
ALT, W, A, V 

 
Tile the windows from the left to the right of the 
screen. 

 Include Workspace Manager ALT, W, A, W  Include the Workspace Manager window in the 
window arranging commands. 

 Include Graphs ALT, W, A, G  Include the graph window in the window arranging 
commands. 

 Include Layouts ALT, W, A, L  Include the layout window in the window arranging 
commands. 

Minimize All CTRL+M  
or 
ALT, W, M 

 
Minimize all open windows, except the Workspace 
Manager window. 

Restore All Minimized CTRL+R  
or 
ALT, W, R 

 
Return all windows to the position they were in prior 
to minimizing. 

Bring Layouts to Front F6  
or 
ALT, W, L 

 
Bring the Layout windows in front of the Workspace 
window. 
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Menu item Shortcut key Toolbar 
Button 

To... 

Window Ø 

 Windows... 

ALT, W, W 
 

Display the Windows dialog box. 

 

Viewing windows 
Once a file is opened (see page 51), it displays in the appropriate window. All windows can be managed 
from the Workspace Manager window using the Window menu. 

All windows can be viewed on the screen at one time, either tiled on the screen, cascaded or floating. 
Floating windows are free to float anywhere on the screen, including floating in front or behind other 
windows. 

Note: To quickly hide the Workspace Manager window, right-click in the title bar (the bar at the top of 
the window containing the text IrriMAX) and click Send Back. The Workspace Manager window is sent 
behind all other floating windows.  

The Window menu displays up to 15 file names. 

 

Ø  To view open windows 
From the Window menu, select the graph or layout file to view. 
The graph or layout file displays. 
Note: If there are more than 15 windows open, from the Window menu, click Windows.... 
The Windows dialog box displays all open windows. 

Using the Windows dialog box 
The Windows dialog box lists all open windows. 

 

From the Windows dialog box you can: 

• display one or more open windows (if the windows are floating the last file selected displays on 
top) 
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• save one or more open windows 
• close one or more open windows. 

 
Note: You can select multiple files to view, save or close by pressing and holding the CTRL key and 
left-clicking each file name. To select all files, select the first file in the list, press and hold the SHIFT key 
and select the last file in the list.  

Ø  To view open windows from the Windows dialog box 
From the Windows dialog box select the file(s) to view and click Activate. 
The file(s) displays in the appropriate window. 

Ø  To save open windows from the Windows dialog box 
From the Windows dialog box select the file(s) to save and click Save. The last file selected from the list 
is activated and displayed. 

Ø  To close open windows from the Windows dialog box 
From the Windows dialog box select the file(s) to close and click Close. 
Note: If you close all windows, the workspace will be empty.  

Arranging windows 
Windows can be arranged from the Workspace Manager window using the Windows menu. Arranging 
windows is useful if, for example, you want to view multiple windows at the same time. 

If you do not need to see a particular window but still need to keep it open, you can minimize that 
window into an icon. Icons appear at the bottom of the Windows desktop. An exception is the IrriMAX 
graph window, which disappears when minimized instead of minimizing to an icon, because graphs are 
more easily managed from the workspace manager graph list. 

You can apply the window arrangement commands to all windows or selected types of windows. 

Note: The Workspace window has controls for minimize, maximize, restore and close each of its graphs. 
See page 43 for details of using the Workspace Manager window. 

Types of windows that can be arranged 
A specific type or all open IrriMAX windows can be arranged from the workspace. You can select which 
types(s) of windows to be included in the arrangement from the Arrange option of the Window menu in 
Workspace Manager. A type is selected to be included in the arrangements when the option is checked. 
The types are: 

• Layouts windows 
• Graph windows 
• Workspace window 

 
For example, if you only want to arrange and view the layout windows with the Workspace Manager 
window on one screen you would make sure that the Include Layouts option is turned on (selected) and 
that Include Graphs option is turned off (not selected). 

Cascade arrangement 
Cascading windows arranges multiple windows in an overlapping sequence so that the title bar of each 
window is visible. The windows overlap from least recently used to most recently used. The Workspace 
Manager window remains in the foreground.  
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Horizontal arrangement 
Tiling windows horizontally arranges all open windows in horizontal pattern from the top to the bottom 
of the screen. You can arrange all windows or selected types of windows by selecting which types to 
include. 

Vertical arrangement 
Tiling windows vertically arranges all open windows in a vertical pattern from the left to the right of the 
screen.  

Ø  To Arrange included window types 
From the Window menu, select Arrange and click one or more of the following: 

 
• Cascade - All 'included' window types cascade with the 

Workspace Manager window on top 

 • Tile Horizontally - All 'included' window types tile 
horizontally 

 • Tile Vertically - All 'included' window types tile vertically. 

Minimizing all windows 
The Minimizing all windows command minimizes all open Graph and Layout windows in one simple 
step. This saves you having to minimize all windows using the standard Windows minimize button ( ) 
in every open window. 

The Workspace Manager window remains open, as this is the parent from which you manage the other 
windows. If you want to minimize the Workspace Manager window, click  in the title bar. All open 
Graph and Layout windows will disappear until the Workspace Manager window is restored 

Minimizing windows hides the windows from view without closing the windows. When a graph window 
is minimized it disappears. When a layout or text viewer window is minimized an icon (button) displays 
at the bottom of the desktop. 
Note: This is different to a conventionally minimized window that displays the button in the Taskbar. 

Note: When all windows are minimized the window arrangement commands are dimmed. The Minimize 
All command is also dimmed. 

The Restore all Windows command restores all minimized windows to normal windows. It does not 
matter whether one, multiple or all windows are minimized, the Restore all Windows command restores 
all minimized windows. Restoring minimized windows displays all open windows as they were prior to 
minimizing, for example, if they were tiled they will return to their tiled positions. 

Ø  To minimize all windows 

 From the Window menu, click Minimize All.  

All open Graph and Layout windows are minimized and appear as 
icons at the bottom of the Windows desktop. 

Ø  To restore all minimized windows 
 

 From the Window menu, click Restore All Minimized.  

All minimized Graph and Layout windows are restored to the previous 
arrangement. 

 

Bringing layouts to the front 
If Workspace Manager contains one or more layouts, you can bring the layouts to float on top of all other 
windows. This makes it easy for you to find and display a layout. 
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Ø  To bring layouts to the front 

 
From the Window menu, click Bring Layouts to Front 

All Layout windows are brought to the front of all other open windows. 

Workspace Help Menu 
The Help menu provides access to the online user guide contents and search utilities. The menu 
commands, equivalent shortcuts and tool buttons are: 

Menu item Shortcut key Button To... 
Help Topics F1 

or 
ALT, H, H 

 
Display the online help file. 

Licensing IrriMAX… ALT, H, L  Display the Licensing & Registration dialog 

About IrriMAX... ALT, H, A 
 

Display current version information. 

Ø  To access online help 
From the Help menu, click Help Topics. 
The Help window displays. 

Click the Contents tab to scroll through a table of contents for online help. 
Click the Index tab to search for topics by using an index of keywords and phrases. 
Click the Find tab to use full-text search and look for specific words. 

Ø  To access version information about IrriMAX 
1. From the Help menu, click About IrriMAX... 

The IrriMAX about dialog box displays. 

2. Click OK to close the dialog box. 
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IrriMAX Settings Dialog 
The Workspace Manager IrriMAX Settings dialog box provides controls to customize how IrriMAX looks 
and how it displays information. For example, you can change the colors used for lines in a new graph or 
the measurement units displayed on all graphs. These settings are global and apply to all appropriate 
windows within IrriMAX. These settings can be changed at any time. 

Ø  To change IrriMAX settings 

From the Tools menu, select IrriMAX Settings…, or click the IrriMAX Settings button  on the 
toolbar. The IrriMAX Settings dialog box displays with the Date & Time tab initially visible. 

All tabs of the IrriMAX Settings window have a common set of buttons for editing.  

  

Click this button... ...to perform this function 

 
Apply all changes and close the IrriMAX Settings dialog box. 

 
Cancel the IrriMAX Settings dialog box without applying any changes. The global settings 
remain unchanged. 

 
Apply all changes without closing the IrriMAX Settings dialog box. This is in case you want to 
select another tab of the dialog box to make further changes to other settings. 

 
Display the online help. 

 
Reset all settings on the displayed tab to the default values. These are the values that applied 
when you first installed the software. 

Date and Time Settings 
Date and time format can be customized to suit the way you want to show dates and times within 
IrriMAX. Date and time settings can be customized to suit American or European conventions and 12 or 
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24-hour clocks. To return all date and time settings to the original configuration click the Reset All 
button. 

 

Ø  To set the date and time formats 
1. From the IrriMAX Settings dialog box, click the Date and Time tab (if not already displayed). 

2. In the Category list, select the category of date and time you wish to change.  

3. In the Format drop down list, do one of the following: 

• Click the down arrow and select the format for that date and time category 
• Accept the default 

4. In the Date Separator box, accept the default or enter a separator, for example, forward slash (/), full 
stop (.) or colon (:). 

5. In the Time Separator box, accept the default or enter a separator, for example, forward slash (/), 
full stop (.) or colon (:). 

6. Select either 12 or 24-hour clock. 
A sample of the new date format displays in the Sample box. 

7. In the Week start day box, click the down arrow and select the day on which you want week 
intervals shown on graphs to start.  
This setting is used in the graphs to determine the position of the vertical dashed lines when they are 
spaced one week apart. It also affects the calculation of weekly rainfall and irrigation totals. 

8. Do one of the following: 

• Click OK to apply the changes and close the dialog box 
• Click Apply to apply the changes without closing the dialog box (you can now change other 

settings) 
• Click Cancel to discard the changes and close the dialog box. 
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Font Settings 
Character Font settings may be changed for the Workspace Manager window, Logger Layout window, 
and Graph window. The available fonts are those installed in your Windows font directory. To return all 
font settings to their original configuration click the Reset All button. 

 

Ø  To change the Font settings 
1. From the IrriMAX Settings dialog box, click the Fonts tab. 

2. In the Category list, select the category to be changed. 

3. Click Change. 
The Font dialog box displays. 
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4. In the Font dialog box, scroll and select a font or enter the first letter/s of the font to narrow the 
selection to that area of the list. A sample of how the font will display is shown in the Sample box. 

5. In the Font style list, select a style from those listed, for example, Italic. A sample of the font 
displays in the Sample box. 

6. In the Size list, select an appropriate size to match your font. A sample of how the font will display 
is shown in the Sample box. 

7. In the Script drop down list, click on the drop-down arrow and select from the list. Not all fonts have 
multiple script settings. Only fonts that have special character sets, such as Central European, 
Symbol or Mac will list multiple script settings. 

8. Click OK. 
The IrriMAX Settings dialog box displays. 

9. Do one of the following: 

• Click OK to apply the changes and close the dialog box 
• Click Apply to apply the changes without closing the dialog box (you can now change other 

settings) 
• Click Cancel to discard the changes and close the dialog box. 

Measurement Settings 
The Measurement tab allows you to specify the default units of measurement for the display of moisture, 
temperature and volume. The default units are used unless overridden by the graph window. 

You can also control whether sensor depths are displayed in centimeters or inches, and set the default 
spacing of sensors for new databases created by the Logger Configuration dialog. 

To return all measurement settings to their original configuration click the Reset All button. 

 

Ø  To set units of measurement 
1. From the IrriMAX Settings dialog box, click the Measurement tab. 

2. Select a sensor depth, measurement unit of Centimeters or Inches. 



 IrriMAX User Guide 
 Software Reference Guide 

Sentek Pty Ltd 78 

3. Select a sensor spacing measurement of 10cm (centimeters) or 4 inches (Imperial). 

4. Select a moisture measurement to display on the graphs. 
Select either Millimeters per spacing, Inches per spacing or User Defined. 
If you select User Defined, a list of existing user-defined units is available from the drop-down list. 
You can edit or remove existing user defined units by clicking Edit or Remove respectively. 
If you want to define a new moisture unit (other than those listed), click Add. The User Defined 
Measure Unit dialog box displays. 

 
 
Enter a customized measurement equation, for example, cm = 0.1 x (mm). When customizing the 
name of your units, restrict the name to about five characters, as the measurement name must be 
able to be easily read on a graph. User defined measurements may be edited or removed as required. 
Click OK to accept the new user defined measurement units. The Measurement tab of the IrriMAX 
Settings dialog box displays again. 

5. Choose a unit for the display of temperature by selecting one of the Celcius, Fahrenheit or Kelvin 
buttons. This choice will override the unit stored in the database if IrriMAX is able to detect that the 
database uses one of these three temperature units (by inspecting the sensor record's short and long 
description fields.) 

6. Choose a unit for the display of volume by making a selection from the Volume drop-down list. 
This choice will override the unit stored in the database if IrriMAX is able to detect that the 
database contains one of the listed units. 

7. Do one of the following: 

• Click OK to apply the changes and close the dialog box 
• Click Apply to apply the changes without closing the dialog box (you can now change other 

settings) 
• Click Cancel to discard the changes and close the dialog box. 

Color Settings 
The color of layout highlights (showing a selected item in the layout window) and the color of graph lines 
and bars (as displayed in the graph window) may be changed as required. Changes to colors are made as 
required, for example, to make lines easier to read on a graph. 

Note: 
Changes to the Default Line Colors only apply to new documents created. To change the line 

colors of an existing graph, see page 149. 

Clicking the Reset All button resets all colors to their default values. 
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Ø  To change color settings 
1. From the IrriMAX Settings dialog box, click the Colors tab. 

2. To change a color, click on the drop-down arrow next to the category. 
The Color dialog box displays. 

 
3. Do one of the following: 

• Select a color from the Basic colors palette 
• Click Define Custom Colors>> and click on the variegated palette. Click Add to Custom 

Colors to select the non-basic color and return to the Basic colors palette. 
4. Click OK. 

The Color dialog box closes. 

5. Do one of the following: 

• click OK to apply the changes and close the IrriMAX Settings dialog box 
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• click Apply to apply the changes without closing the dialog box (you can now change other 
settings) 

• click Cancel to discard the changes and close the dialog box. 
 

Budget Line Settings 
The default names, drawing styles and colors of the budget lines may be changed for IrriMAX graphs. 

Note: Changes to the Budget Lines settings only apply to new graphs created. To change the budget line 
properties of an existing graph, see page 154. 

 

Ø  To change default budget line settings 
1. From the IrriMAX Settings dialog box, click the Budget Lines tab. 

2. To change the default name for a budget line, click on the corresponding edit control in the Default 
Name column and type in a new name. 

3. To change the default style or color for a budget line, click on the corresponding control in either 
the Style or the Color column. 

4. To restore the default names, styles and colors to the system defaults, click on the Default button.  

5. Do one of the following: 

• click OK to apply the changes and close the IrriMAX Settings dialog box 
• click Apply to apply the changes without closing the dialog box (you can now change other 

settings) 
• click Cancel to discard the changes and close the dialog box. 

Graph Settings 
The Graphsl tab of the IrriMAX Settings dialog box contains three sections: 

• Irrigation and Rainfall 
• Line width 
• Interface Preferences 
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Irrigation and Rainfall Settings 
These settings govern how irrigation and rainfall bars are calculated. They have an immediate effect on 
all I&R graphs. 

Setting Description 

Week Start In the Week Start box, click the down arrow and select the 
day on which you want week intervals to start.  
This setting is used in the graphs to determine the position of 
the vertical dashed lines when they are spaced one week 
apart. It also affects the calculation of weekly rainfall and 
irrigation totals. 

Day Start This is the time of day that the I&R Totals modes use as the 
start time for Hourly, Daily, Weekly and Monthly totals. 
The format of this field is controlled by Windows Regional 
setting for Time (12 hour with AM/PM, or 24 hour clock). 

Line Width Settings 
The width of graph lines can be independently set for when they are displayed on screen and when they 
are printed. Normally the widths are set to one, but this value may be increased to improve legibility of 
the lines. It must be noted that any screen line width greater than one will noticeably slow down the 
drawing of graphs. Changing the widths affects all the display of all graphs. 

Interface Preferences 
These settings allow you to customize some aspects of how the graph user interface operates. 

Setting Description 
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Default Preset Date 
Range 

Each graph window has a preset date range, which 
represents the typical time scale over which the soil moisture 
needs to be monitored. The preset date range for graphs can 
be changed individually using the graph settings dialog. The 
value here is the default value assigned to newly created 
graphs.  

Note: Changes to the Preset Date Range only apply to new 
graphs created. 

Zoom to Vertical 
Extents includes 
Budget Lines 

The graph window's Zoom to Vertical Extents function 
adjusts the vertical range so that all of the graph lines are 
visible. To ensure that all budget lines are also visible, check 
this box. 

Reset Graph also 
Zooms to Vertical 
Extents 

The graph window's Reset Graph function scrolls the graph 
so that the end point is visible. To automatically zoom to the 
vertical extents after scrolling, check this box. 

Reset Graph also 
Zooms to Preset Date 
Range 

The graph window's Reset Graph function scrolls the graph 
so that the end point is visible. To automatically zoom to the 
preset date range after scrolling, check this box. 

Mail Settings 
The Mail tab of the IrriMAX Settings dialog box contains two sections: 

• Outgoing Mail Server 
• Sender Identification 

 

 

Outgoing Mail Server 
IrriMAX acts as an SMTP mail client for the purpose of sending mail. The settings in this section should 
be the same as you would enter into a mail client like Outlook Express. Your ISP or network 
administrator will provide you with these settings. 

Sender Identification 
Enter the email address and name to identify the sender of the emails sent by IrriMAX on your behalf. 
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Testing your mail settings 
To verify the settings you have entered, click the Test… button. 

IrriMAX will attempt to send an email to the address that you entered in the Sender Identification 
section, using the mail server specified in the Outgoing Mail Server section. 

Template Settings 
The Templates tab of the IrriMAX Settings dialog box is used to supply the file paths of the default 
templates to use when mailing or webifying graphs and workspaces. 

If the template properties of the graph and workspace documents are left blank, then the templates used 
will be the ones specified here. 

If you wish to modify a template supplied with IrriMAX, you should first create a copy in a different 
location, then modify the copy. This protects your modifications from being lost when IrriMAX is 
reinstalled or upgraded. You can use the Templates tab to make your modified template the default  

 

Mail Graph from Graph Window 
This template is used when Mail Graph is chosen from a Graph window. The default is 
GRAPHEMAIL.HTML in the Templates folder within the IrriMAX program folder. 

Mail Graphs from Workspace 
This template is used when Mail Graphs is chosen from the Workspace Manager window. The default is 
GRAPHEMAIL.HTML in the Templates folder within the IrriMAX program folder. 

Use of the default template will generate a separate email for each graph. To combine all the graphs into 
one email, browse for and select WORKSPACEEMAIL.HTML from the Templates folder. 

Webify Graph(s) 
This template is used when a graph is webified, by choosing either Webify Graph from a Graph window 
or Webify Workspace from the Workspace Manager window. The default is GRAPH.HTML in the 
Templates folder within the IrriMAX program folder. 
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There are special sections within the default template that generate different code depending on whether 
the graph is standalone or part of a workspace. 

Webify Workspace 
This template is used when Webify Workspace is chosen from the Workspace Manager window. The 
default is WORKSPACE.HTML in the Templates folder within the IrriMAX program folder. 

Upload Notification Mail 
This template is used to generate an email message when a webified workspace has been successfully 
uploaded. The default is UPLOADEMAIL.HTML in the Templates folder within the IrriMAX program 
folder. 

General Settings 
The General tab of the IrriMAX Settings dialog box contains three sections: 

• Startup settings 
• Logger layout settings 
• Workspace Manager settings 

 

 

Startup Settings 
IrriMAX can be configured to open the last used workspace each time it is started. This is a convenient 
feature if you regularly use the same workspace. To enable this feature, check the Load last workspace 
checkbox. 

Holding down the SHIFT key while IrriMAX starts will prevent the opening of the last workspace. 

The splash screen is the Sentek graphic picture that displays when the software is started. To prevent the 
splash screen from appearing, ensure that the Show splash screen checkbox is unchecked.  
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Logger Layout Default Image Size 
The size of the default logger and site icons, on the Layout window, may be changed as required by 
selecting Small, Medium or Large from the Default Image Size dropdown list. 

If you select a new default size, the new size only applies to newly added image objects in the layout 
window. This is when new database is added to a layout, or when new site is added to an existing 
database in the layout document. 

Workspace Manager Graph Thumb Size 
A miniature 'thumbnail' image of each graph can be displayed in the Workspace Manager graph list. 
Select one of the following from the Graph thumb size drop-down list: 

• None - Select this to turn off the display of thumbnail images. Use this setting to maximize space 
for other information, or improve performance of IrriMAX if your computer is slow. 

• Tiny - The thumbnails fit exactly into the standard row height of the graph list. Their presence 
does not decrease the number of rows that can be displayed at a time. 

• Small, Medium, Large, Extra Large - These sizes allow a more detailed thumbnail to be shown, 
at the expense of space for other information. Small and Medium provide a good view of the 
graph without using too much space. Large and Extra Large may be legible enough to substitute 
for viewing the full graph window under some circumstances. 

• Enormous - This selection generates a large image without any downscaling. If the workspace 
window is maximized on a 1280x1024 pixel-wide screen, there will be enough space for two 
graph images. 
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New Database Wizard 
The New Database Wizard assists with the creation of a new IrriMAX database (SDB file), then 
automatically adds the created database to the workspace's database list. 

IrriMAX databases can be created manually, or they can be created by downloading from various sources. 
If they are created by downloading, the download command is stored in the workspace to assist with 
subsequent downloading of new readings to the database. 

Ø  To invoke the New Database Wizard 
• From the workspace manager File menu, choose New> Database... 
• Or right-click on an empty part of the workspace manager's database list, and choose New 

Database… from the popup menu. 
 

The first page of the wizard allows you to choose how the database will be created. Choose an option, 
then click Next (or Finish if you choose to create the database manually.)  

 

Ø  To create the database manually 
1. Select the Create manually button 

2. Click Finish to create a database using the Logger Configuration Dialog (see page 91.) 

 

Ø  To create the database by download 
1. Select the button for your desired download source. 

2. Click Next to proceed to the Wizard page for that source. 

3. Enter the information required for the source you have chosen. 

4. Click Next to proceed to the final page of the wizard (see below). 
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The final page of the New Database Wizard is used to choose a name and location for the created 
database(s), and set some options for subsequent downloads. 

 

Database Folder 
Type the path of a folder in which the new database(s) will be created, or click the Browse… button to 
pick a folder using the Browse for Folder dialog. 

Database File Name / Root Name for Multiple Databases 
This control is named according to whether your download source supports multiple destinations. 

• If the source creates a single database, enter a name for the new database, without the .SDB file 
extension. 

• If the source potentially creates multiple databases (e.g. Diviner 2000), enter the root name for 
these databases. The final name for each database is composed of the root name, plus a suffix 
supplied by the source. 

 

Include in batch download 
Databases with download commands defined can be marked to be included in batch or unattended 
download operations. It is then possible to download into all these databases in one go, by manually 
invoking the batch download, or by running IrriMAX with the /DOWNLOAD command-line switch. 

This option has no effect when initially creating the database. It can be modified later using the Download 
Wizard (see page 88.) 

Allow insertion of records and modification of existing records 
IrriMAX databases are usually updated by appending new readings. Existing readings are unaffected by a 
download. Select this option to allow modification of existing records and insertion of new records 
between existing records. 

This option has no effect when initially creating the database. It can be modified later using the Download 
Wizard (see page 88.) 
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Ø  To complete the New Database Wizard 
Click Finish after completing the final page. If all goes well, the Download Window will appear at the 
bottom of the workspace manager window (see page 41) and display feedback from the download 
operation. 

If a database is successfully created, it will be added to the workspace's database list (see page 46.) 

If there is an error creating the database, you will be returned to the final page of the New Database 
Wizard. From here you can click the Back button to modify the options for your chosen source and try 
again. 

The workspace manager's database list displays  if download settings are defined, or  if there are 
download settings and the database is flagged to be included in a batch download. 

If more than one database is created, the download settings are stored against one master database and the 
other databases display  to indicate that their download is linked to the download of another database. 
Sorting the database list by the column containing these icons will group all linked databases with their 
master database. 

Download Wizard 
.The Download Wizard is used to configure how readings are downloaded to a database. The settings are 
stored within the workspace to enable repetition of downloads, either manually or as part of a batch or 
unattended download. 

Ø  To invoke the Download Wizard 
• Click on a database in the workspace manager's database list, then select Download Wizard… 

from the Edit menu. 
• Or right-click on a database in the workspace manager's database list, then choose Download 

Wizard… from the popup menu. 
• Or click on the relevant pane in the graph window, then choose Download… from the Tools 

menu. Note that if you invoke the Download Wizard from the graph window, then the download 
properties are stored in the graph document, not the workspace document. You will need to step 
through the wizard each time you download, and the download can't be included in the 
workspace's batch download process. 

 
The first page of the wizard allows you to choose how the database will be updated. Choose an option, 
then click Next (or Finish if you choose the No download source option.) 
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The final page of the Download Wizard is the same for all download sources. It allows the setting of 
some final options before saving the download settings to the workspace and optionally starting the 
download. 

 

Start the download now 
Choose this option to automatically start the download when the Finish button is clicked. 
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Include in batch download 
Databases with download commands defined can be marked to be included in batch or unattended 
download operations. It is then possible to download into all these databases in one go, by manually 
invoking the batch download, or by running IrriMAX with the /DOWNLOAD command-line switch. 

Allow insertion of records and modification of existing records 
IrriMAX databases are usually updated by appending new readings. Existing readings are unaffected by a 
download. Select this option to allow modification of existing records and insertion of new records 
between existing records. 

Erase all readings before download! 
This option will empty the database before each download operation. This is useful if the role of the 
database is to be an exact copy of the data in the download source. 

Warning: Use of this option with an inappropriate source can cause loss of data. 

Ø  To complete the Download Wizard 
Click Finish after completing the final page. If you chose Start the download now, the Download 
Window will appear at the bottom of the workspace manager window (see page 41) and display feedback 
from the download operation. Otherwise the download settings will simply be stored in the workspace 
document for later use. 

The workspace manager's database list displays  if download settings are defined, or  if there are 
download settings and the database is flagged to be included in a batch download. Double-clicking on 
these icons will invoke the Download Wizard again. 
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Logger Configuration Dialog 
The Logger Configuration dialog is used to configure the database associated with a logging device. In the 
case of the RT6 logger, it is used to configure the logger itself. 

The dialog supports two types of logger:  
• Sentek RT6 loggers, which support up to 4 sites and probes on each of two runs (A and B). Each 

run supports up to 16 moisture sensors. 
• Non-RT6 (type Unspecified) loggers. These loggers can have TriSCAN (moisture and salinity) 

sensors, matric potential, irrigation, rainfall and custom sensors. The database can have up to 16 
sites, 99 probes and 999 sensors. 

 

 

The dialog displays the current logger configuration in tree form as a hierarchy of sites, probes and 
sensors under a single logger. There are various columns describing the sensors. 

Ø  To open the Logger Configuration dialog box 
The dialog can be accessed from many different areas of the IrriMAX software and utilities. 

• From Workspace Manager, choose New Database from the File menu to create a new database. 
• From Workspace Manager, choose Open Database… from the File menu. Now browse for an 

existing database file to open. Alternatively select the database in the Database List and choose 
Open… from the right-button popup menu. 

• From the Layout window, right-click on a logger icon and choose Logger Configuration… from 
the popup menu to open an existing database. 

• From the Graph window, select the pane whose database you wish to open, then choose Logger 
Configuration… from the Tools menu. 

• From the Database Entry utility, choose New Database… from the File menu to create a new 
database, or choose Logger Configuration… from the File menu to view the currently open 
database. 
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• From Database Manager, choose New Database… from the Tools menu to create a new 
database, or select a single database from the list in the main window then choose Edit 
Configuration… from the Tools menu. Refer to the Database Manager User Guide for details. 

 

Using the Logger Configuration dialog 
The logger configuration tree represents the way in which a logger and its probes and sensors are setup. 
The Add and Delete buttons are dynamic and change according to the type of component that is selected 
in the logger tree view. This configuration can be sent to an RT6 logger using the Send to Logger button. 

To collapse the logger tree view, click . 
To expand the logger tree view, click . 

To add components to the logger tree view you can: 
• use the Add buttons 
• right-click on the hardware element to display the shortcut menu listing the options specific to the 

selected element. 
 

For example, to add a sensor to a probe you can do one of the following: 

• Click . 
• Right-click on the probe and select Add Sensor from the shortcut menu. 

 

 
 

   

Click this button... ...to perform this function The button changes to... 

 
Add a site to the logger. 

 

 
Add a probe to a site. 

 

 
Add a sensor to a probe.  

 
The button label changes and 
displays a sub-menu when 
Unspecified logger type is selected. 

 
Delete all sites from the logger.  

 
Delete a site from the logger. The line directly above 
the one that has been deleted is highlighted. 

The Delete button corresponding to 
the highlighted component. 

 
Delete a probe from the site. The line directly above 
the one that has been deleted is highlighted. 

The Delete button corresponding to 
the highlighted component. 

Shortcut menu 
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Click this button... ...to perform this function The button changes to... 

 
Delete a sensor from the probe. The line directly above 
the one that has been deleted is highlighted. 

The Delete button corresponding to 
the highlighted component. 

 
Take normalizing sensor readings from the selected 
sensor. See page 100. 

Not visible when Unspecified 
logger type is selected. 

 
Access the Calibration Registry. See page 103.  

 
Send the logger configuration to the RT6 logger. See 
page 98. 

Not visible when Unspecified 
logger type is selected. 

 
Create a new Irrigation & Rainfall database to match 
the current logger's site names. 

 

 
Access online help.  

 
Save changes made to an existing logger 
configuration. 

 

 
Save or clone a new logger configuration.  

 
Close the logger configuration dialog box.  

RT6 logger Setup rules 
The configuration is limited to any one of the following conditions: 
On one logger you can have: 

• a maximum of 32 sensors divided into 2 cable runs of 16 sensors 
• a maximum of 8 probes 
• a maximum of 8 sites 

 
On one cable run you can have: 

• a maximum of 16 sensors 
 

On one probe you can have a maximum of 16 sensors. 

You should not create a new irrigation & rainfall database until you have finalized the new logger sites 
configuration. 

Naming conventions 
Probe names are limited to three characters 

Logger names are limited to 22 characters for RT6 loggers or 32 characters for non-RT6 loggers. 

Site names are limited to 32 characters 

Address column 
An address is a sequential alphanumeric reference marking the position of a sensor on a cable and the 
position of that sensor in relation to other sensors on the same cable, e.g. A4. One RT6 logger can support 
two cable runs consisting of an arrangement of probes and sensors. Cable runs may be addressed as Run 
A (addresses A1-A16) or Run B (addresses B1-B16). Only the addresses A1-A16 and B1-B16 may be 
used.  

If the logger type is Unspecified rather than RT6, then Run B addresses are not available. 

Addresses are automatically assigned when each sensor is added. If, after you have added all sensors, you 
want to rearrange the address sequences you can change the address manually. If the address is dimmed, 
it cannot be altered. You must alter the address (from the sequence) that is not dimmed. 
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An address is changed by clicking on the address box and entering a new alphanumeric address or using 
the arrows within the cell to scroll to the new address. The address of each sensor must be unique. RT6 
addresses must increase sequentially on each run with no gaps. The order of the addresses is not 
dependent on the probe or site name.  

Depth (cm/inches) column 
The depth is the depth of the sensor, in position, below ground level. The depth is changed by clicking on 
the depth box and entering a new depth or scrolling to a new depth. Sensors on the same probe must have 
unique depths. 

Note: The depth indicator must be entered according to the defaults for sensor spacing (10 cm or 4 
inches). A depth of anything other than multiples of the spacing value is invalid. 

Depths of zero are permissible if the logger type is Unspecified. Sensors at zero depth are assumed to be 
above ground. They must still be added underneath a probe, however. 

Air and water columns 
The air and water columns display the normalized sensor reading for the sensors. Moisture sensors need 
to be normalized for air and water readings - the two extreme conditions. Normalizing sensors means 
taking air (no moisture) and water readings and storing them in their appropriate cells in the Logger 
Configuration dialog box. This then stores these values in the database tables. When a new logger 
configuration is created, a default air count (65535) and water count (0) display. 

Note: It is important to normalize the air reading in non air-conditioned, non-humid air for the most 
accurate base reading, as the presence of any moisture will affect readings. 

Calibration column 
The calibration column displays the calibration that is assigned to the sensor. Sensor calibration is 
selecting the right calibration equation for the soil type in which the sensor is working. The calibration 
equation is a formula used for transforming the raw sensor reading to moisture units. 

Different sensors may require different calibrations for different depths through out the soil profile. 
Therefore, a soil profile consisting of a sand surface layer on top of a clay layer below, can be measured 
accurately as different soil types respond differently when taking moisture measurements. 

Calibrations are selected for each sensor by clicking on the calibration column. A drop-down arrow 
appears and alternative calibrations can be selected from the drop down list. 

 

The default calibration (Default Sentek Calibration) is assigned to all new moisture sensors. When the 
basic logger configuration has been established and more calibration equations have been added to the 
Calibration Registry, the logger configuration is edited and accurate calibrations are assigned to sensors. 

Custom sensors are assigned (Default calibration). 

Ø  To add, change or delete a calibration 
From the Logger Configuration dialog box click Calibrations.... 

The Calibration Registry dialog box displays. See page 103. 

Click to select a calibration from the list. 
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Salinity, Matric Potential and Custom Sensors 
IrriMAX has the capability of creating  databases that comprise:  

• Moisture sensors 
• Salinity sensors, such as TriSCAN sensors 
• Matric potential sensors  
• Custom sensors e.g. temperature, wind speed, leaf wetness 

Third-party logger software can update these databases via the AutoSDB2 programming interface. 
Alternatively the data can be supplied in a text file (CSV) or Excel spreadsheet (XLS) using Data 
Exchange. These databases are not supported by RT6 loggers.  

IrriMAX can graph the resultant fertilizer/salinity data in a salinity graph pane, above the moisture pane 
and custom sensors in custom sensor panes. The Logger Configuration dialog allows you to change the 
logger type from RT6 to Unspecified. Once the logger type is Unspecified you can add moisture sensors, 
matric potential sensors, custom sensors, dual moisture/salinity, or dual matric potential/salinity sensors. 
A column on the dialog indicates the sensor type and the tree view symbols are different for salinity 
sensors.  

TriSCAN sensors are supported on Sentek EnviroSMART and EasyAG devices. 

 

A type "Unspecified" logger can be configured with up to 16 sites, 99 probes and 999 sensors, in any 
combination. 

Each sensor type has a different pictorial representation: 

•  (A) Moisture sensors 

•  (A/S) Moisture/Salinity Sensors (salinity is always dual) 

•  (M) Matric Potential 

•  (M/S) Matric Potential/Salinity Sensors (salinity is always dual) 
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•  (C initially) Custom Sensors 
Note: an asterisk will appear in the type column if the sensor properties do not match the 
properties in the sensor preset registry. 

Creating a new database 
This section illustrates the creation of databases using the Logger Configuration dialog. 

Hint: Document the cabling configuration of the loggers, sites, probes and sensors in the field on a piece 
of paper. Document the database configuration on paper as well. Ensure that the two maps represent the 
same information before loading the settings into the Logger Configuration dialog box. 

The dialog can operate in two modes corresponding to the type of logger - RT6 or Unspecified. If RT6 is 
selected, then you can only add moisture sensors and the validation rules are stricter. 

 

Ø  To create a new RT6-compatible database 
1. From the Workspace Manager File menu select New and click Database. Alternatively click the 

corresponding toolbar button. 
The Logger Configuration dialog box displays the text, 'New Logger', in the Logger Tree column. 
Note the Add Site button at the top right. 
 

 
 
 

2. Click on the text, 'New Logger', and enter the "Logger ID" of the logger as used in the field. 
For example, 'Log12'. 
If you are unsure of the Logger ID, you can use Logger Manager to obtain it. 
Note: Logger names are limited to 22 characters 
 

 
 
 

3. With the cursor still in the logger name, click Add Site. A site is added under the logger with the 
default name of 'Site 1'. Note the Add Site button changes to Add Probe. 
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4. Click on the text 'Site 1' and enter the name of the site as used in the field. 
A site represents a block with similar physical characteristics such as crop type, soil type or 
irrigation facility. There may be more than one probe per site. This is the name given to the site on 
the Layout top cap image. If there are multiple probes in a site the image is shown as a cluster of top 
caps. 
For example, 'Shiraz' for one block of shiraz grapes. 
Note: Site names are limited to 18 characters. 
 

 
 
 

5. With the cursor still in the site name, click Add Probe. A probe is added under the site with the 
default name of 'P1'. Note the Add Probe button changes to Add Sensor. 
 

 
 
 

6. Click on the text 'P1' and enter the name of the probe as it is labeled in the field.  
In this example, the probe name is left as 'P1'. 
Note: Probe names are limited to 3 characters. 

7. With the cursor still in the probe name, click Add Sensor. A sensor is added under the probe with 
the name 'S1'. Each sensor is assigned a sequential number based on this format. 
 

 
 
 

8. Continue adding sites, probes and sensors as required. 
Note: The buttons for adding and deleting components are dynamic. The button name and function 
depend on which component is selected. 

9. Click Save New As.... 
The Save As dialog box displays. 

10. In the Save in: dialog box, click on the down-arrow and select a location for the new database. 
The contents of the selected directory displays. 

11. In the File name: box, enter a file name for the new database. 

12. Click Save. 
The Save As dialog box closes. 

13. Click Quit. 
The Logger Configuration dialog box closes. 
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Ø  To create a database containing salinity and other sensors  
These databases are created in the same way as an RT6-compatible database, but on the Logger 
Configuration dialog the Logger Type field must be set to "Unspecified". Once this is done, adding 
sensors is done in the same manner but with the ability to add any type of sensor without the restrictions 
imposed by the RT6. 

1. Open the database (SDB file) for which you wish to create a matching irrigation & rainfall database 
(.wdb) in the Logger Configuration dialog. 

2. Select Unspecified in the Logger Type field. 

 
 

3. Change the Logger name, and add sites and probes. 

4. Click the Add Sensor button and select the type of sensor to add. Moisture sensor addresses are 
always prefixed by "A", salinity sensors are prefixed by "S", matric potential "M", Irrigation "I", 
Rainfall "R" and custom "C" (that can be changed). The sensor number can be in the range 1 to 999.  

 
5. Custom sensors require an additional step to configure their characteristics. Click in the custom 

sensor address field and the sensor type and address become editable. Enter a new type in the range 
A to Z excluding reserved types of A, B, M, I, R, V and S, then the sensor address number. Then 
click the Properties button to set its properties 
 

 

 Select the desired sensor type or enter the units and valid range and optional description for the 
sensor and click OK. See Sensor Properties Dialog for further details. Only sensors with matching 
characteristic can be graphed in the one graph pane. 
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6. When the configuration is built as required, click Save New As and save the database in your 
desired folder. 

Note: 
There are various restrictions when you create databases containing salinity sensors. 

You cannot change calibration equations or normalization values. This data is supplied during 
the download of the data from third-party loggers. For TriSCAN sensors these values are preset 

during the configuration of EnviroSMART and EasyAG devices. 

Ø  To create a new irrigation & rainfall database  
1. Open the database (SDB file) for which you wish to create a matching irrigation & rainfall database 

(.wdb) in the Logger Configuration dialog. 

2. Make sure you have finished adding sites to the soil moisture database 

3. Click 'Create I&R DB' to create a matching irrigation & rainfall database (one irrigation and one 
rainfall sensor for each site in the soil moisture database). 
Note: If the button is dimmed, there is an I&R database already existing. 

4. A message informing you that a new irrigation & rainfall database was created successfully will 
appear. 

 

Sending configurations to the RT6 logger 
When a database is configured, the new configuration settings can be sent to an RT6 logger. A direct 
physical connection between the logger and the PC serial port is required. When a connection to the 
logger has been established, adjustments to the current sampling interval and PC and logger time can be 
made. 

Ø  To send configurations to the RT6 logger: 
1. From the Logger Configuration dialog box, click Send to Logger. 

If the Logger Configuration dialog box has not yet established a connection to the logger, or if the 
connection was broken, the Connect to Logger dialog box displays. 
 

 
 

2. Select the COM port and baud rate for connection to the logger, and click OK. 

3. The Send Configuration to Logger dialog box appears. 
 



 IrriMAX User Guide 
 Software Reference Guide 

Sentek Pty Ltd 100 

 
 
Note: The section titled Existing logger configuration (will be erased) shows the information 
currently stored in the logger; the logger ID, the sensor addresses and the sampling interval. If you 
do not want to overwrite this information click Cancel. 

4. The Time comparison section shows the computer's system time and the time in the logger. Click 
Set to System Time if you wish to synchronize the time settings on the logger and the computer. 
Note: Make sure that your computer's clock is correct. 
Note: The logger records data against a date and time. This is known as a time stamp. 
If the logger's clock is set backwards, the new time stamps overlap the previous time stamps. Data 
corresponding to the new time stamps is not available. 

5. Enter the sampling interval required for this database. 

Warning:  
The next step will erase all existing data in the logger. Please make sure that you have already 

downloaded that data. 

6. Click Send. 
This will overwrite the logger ID, sensor list and sampling interval in the logger. It will also erase 
all readings in the logger. A message displays asking you to confirm this action. 

7. Click OK. 
The database configuration is sent to the logger. 
The Send configuration to Logger dialog box closes but a connection still exists to the logger. 

 
Note: If the connection to the logger is broken while you are working in the Send configuration to Logger 
dialog box, you will receive an error message and the Send button will be disabled. Use the Connect 
button to attempt to re-establish a connection. Changes to the COM port or baud rate cannot be 
performed. If these settings need to be changed, click Cancel to return to the Logger Configuration dialog 
box, and then click Send to Logger again. 

Normalizing RT6 sensors 
RT6 Sensors need to be normalized for air (dry) and water (saturated) readings, the two extreme 
conditions of soil moisture content. Normalization takes into account variations between sensor 
responsiveness. Normalizing sensors means taking air and water readings and storing them in their 
appropriate cells in the Logger Configuration dialog box. These values are then stored in the database 
tables. When a new logger configuration is created, default air count (65535) and water count (0) are set.  

The Logger Configuration Read Sensor button is dimmed until you select, in the logger tree, either the air 
or water cell for a sensor. The air or water count is then read by clicking the Read Sensor button, with the 
probe in an access tube. 

The Read Sensor button remains depressed while the air or water count readings are taken. On one 
probe, air counts can be read sequentially by moving up and down the air count column using the arrow 
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keys on the keyboard. From this column, you can use the arrow keys to move to the water count column 
and start water readings when the probe is in place in the water filled chamber. Alternatively, click Read 
Sensor again to release it. In this way you can move to a new probe and start taking readings again. 

 

The following steps assume that: 
• The computer is connected to the logger 
• Probe is installed in an access tube in dry air when taking air counts 
• Probe is inserted into a "normalization container" when taking the water counts 

Note: Make sure the sensors do not get wet. 
 

Ø  To Normalize the sensors 
1. Insert the probe into an access tube held clear from its surroundings. Click in the air value of the 

first sensor. 
The Read Sensor button is activated 

2. Click Read Sensor. 
Note: If you have just sent your configuration to the logger, you will still be connected to the 
logger. If the logger is not already connected, the Connect to Logger dialog box displays. Select the 
logger baud rate and appropriate COM port and click OK to make the connection. 

3. The air count is measured at regular intervals. The air count fluctuates at first and then stabilizes. 
When the air count has stabilized, press the keyboard down arrow to move to the next sensor. 

4. When the air values are established, press the keyboard right arrow to move to the last reading in the 
water count column. 

5. Insert the probe into the normalization container and position each sensor, in turn, to the middle of 
the container. The water count is measured at regular intervals. The water count fluctuates at first 
and then stabilizes. When the water count has stabilized, press the keyboard up arrow to move to the 
next sensor. 

6. When all sensor readings on the probe have been taken, either: 

• Click Read Sensor again to stop the reading process, or  
• Press the keyboard up arrow once more to take you into the inactive cells. 

Note: Pressing Enter on the keyboard will also stop the sensor reading. 
 

Sensor Properties Dialog 
Sensor properties .are accessible from the Logger Configuration dialog by selecting a sensor row then 
either clicking the Properties button or right click on the row and selecting Properties from the popup 
menu.  

Start the air and water 
reading sequence here. 

End the sequence here. 

Start the second 
sequence here. 
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The values for a newly created custom sensor are: 
• Sensor Type: "Custom" 
• Measurement Unit: "?" 
• Unit Description: "Unknown" 
• Invalid Value -1 
• Unitialized Value -2 
• Minimum Value 0 
• Maximum Value 100 
• Prevent Recalculation: unchecked 

 
These values can be changed to reflect the characteristics of the sensor but it is recommended to save 
them in a preset which can be used later to build another sensor with the same characteristics. 

Only custom sensor properties can be changed. Properties of Sentek reserve sensor types (A, B, S, M) can 
be viewed but cannot be changed. 

Rules for custom sensors: 
• Only sensors with matching characteristics can be graphed in a single graph pane (Sensor type, 

Measurement unit, range values) 
• The graph pane vertical axis legend consists of the sensor type and measurement units in square 

brackets e.g. "Temperature [C]" 
• You cannot save a preset for the default sensor type "Custom" 
• Sensor characteristics cannot be changed once there is data in the database 
• Clicking OK changes the characteristics of the sensor to match the entered values. Not the values 

loaded from the preset. 
• If the sensor type is selected from the type list on the Logger Configuration dialog it inherits the 

characteristics from the preset registry. 
 

Sensor Preset Registry 
Once you have set the characteristics of a custom sensor you can save them in the custom sensor presets 
registry. When you add another custom sensor you can select the sensor type for the Sensor Type list, 
which will then set the characteristics to match the preset values. 

Note: 
For clarity and self documentation purposes it is recommended you assign a different sensor 
address symbol for each sensor type e.g. "T" for temperature sensors, "L" for leaf wetness 
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sensors. 
It is also recommended that all sensors of a particular sensor type have the same properties. If 
sensor current properties do not match the preset registry properties an asterisk is added in the 

sensor type column of the logger tree. 

Initially the preset registry is empty but as you Save Preset the information is saved in the file 
Sensors.ini, which is stored in the Sentek Public Folder. 

Calibration Registry Dialog 
The calibration registry stores all calibration equations. Each calibration equation relates to a particular 
soil type.  

Note: See the "Calibration of Sentek Pty Ltd soil Moisture Sensors" manual for further technical 
information. Advanced users can access the set of calibration equations that are described in the 
"Calibration-Readme.txt" file on the IrriMAX CD. 

Each time a layout is opened in IrriMAX, the database calibration values are compared to the calibration 
registry. If the database calibration values are different to the registry values, you are notified of a 
discrepancy. This could occur if, for example, you have changed a calibration equation after the 
calibration was assigned to a sensor. 

Similarly, if a database contains a calibration that is not in the registry, you are notified that the 
calibration is unregistered and have the option of adding the calibration to your registry. This could occur 
if, for example, you are using a database (with calibrations) that was configured on another computer.  

Note: The boxes in the calibration registry dialog box that are marked with an asterisk (*) must be 
completed. 

 

The calibration registry displays a list of all installed calibration equations and their details. If a database 
is loaded that has a calibration equation that is not present in the registry, you will be prompted to add it 
to the calibration registry. 

Click this button... ...to perform this function 

 
add a new calibration equation to the Calibration Registry. 

 
change a calibration equation. 

Equation 
details 

List of calibrations 
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Click this button... ...to perform this function 

 
delete a calibration equation from the registry. 

 
accept the changes made to a calibration. 

 
discard the changes made to a calibration. 

 access online help. 

 
save the changes and closes the Calibration Registry dialog box. 

 
close the calibration Registry dialog box without saving the changes. 

Calibrations are specific to soil types. A calibration is a statistical equation that is based on a scattered 
group of sample values. This equation is represented by the Coefficient A, Exponent B and Constant C 
boxes. 

When adding new calibrations to the registry it is important to complete as many details boxes as 
possible. The boxes marked with an asterisk (*) are mandatory. 

In this box... ...enter the following details. 

Calibration Name The name of the new calibration. Calibrations may be named by institution, usage, developer 
or for a specific soil type. This field is limited to 99 characters 

*Origin The name of the organization or person who supplied the equation. This field is limited to 99 
characters 

*Soil Texture The specific soil profile. This calibration equation is used to analyze. This field is limited to 
99 characters 

*Coefficient A Calibration equation coefficient 

*Exponent B Calibration equation exponent 

*Constant C Calibration equation value 

Equation display No data is entered in this box. This box displays the formula that is used to calculate the raw 
sensor readings to calibrated moisture values. 

R2 The coefficient of determination (R-squared). This is a number between 0 and 1 that provides 
an indication of accuracy where 0 is inaccurate and 1 is accurate. 

CV(%) The coefficient of variation. 

N The number of sample values used. The higher the number the more objective the equation. 

Author / Publication The details of the author of the calibration and the publication details of where it first 
appeared. This field is limited to 99 characters 

Warning: 
Assign the correct calibration equation to your logger configuration. Calculations differ for 
different soil types. If the wrong calibration equation is used, data may be incorrect and 

misleading. 
 

Sentek sensors are precise measurement instruments, however accurate absolute data for all 
soil types are not generated automatically. 

 
If you wish to obtain accurate absolute readings of volumetric soil water content for scientific or 

other purposes, you must calibrate the Sentek sensors for every given soil type. See the manual 
"Calibration of Sentek Pty Ltd Soil Moisture Sensors" for a detailed description of the calibration 

procedure. 

Calibration of sensors in a specific soil is done by comparing scaled frequency readings from an access 
tube installed in the field, or in a container in the laboratory, with values of volumetric water content 
determined gravimetrically from soil immediately adjacent to the tube. 
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When these values are plotted on a graph they form a relationship that is described by a mathematical 
calibration equation. In this way the moisture levels from the sensor are directly related to the real values 
determined from the soil. 

Standard calibration equations are provided with the IrriMAX software. New equations can be added as 
required. These equations transform normalized raw data into volumetric soil water content values. 

You can use the default calibration equation to convert the very first raw data into a graphical or text 
format. This shows the trends of soil water dynamics, before a site-specific calibration of the sensors can 
be undertaken. To obtain absolute data, you can insert your own calibration equation for every single 
sensor later. Alternatively, you can continue to use the default calibration equation to visualize changes 
on a relative scale. 

Most IrriMAX users do not require absolute volumetric water content readings because they are using 
the relative changes in soil water dynamics for their daily irrigation management practices. Scientific 
users or users interested in the absolute values must carry out calibration of the Sentek sensor, as is the 
case with all other volumetric soil water monitoring devices. 

Ø  To add new calibrations to the registry 
1. In the Logger Configuration dialog box, click Calibrations. 

The Calibration Registry displays. 

2. Click Add. 

3. Complete all boxes marked with an asterisk (*). 
Complete other boxes as required. 

4. Click Accept. 

5. Click Save & Close to save the changes and close the Calibration Registry dialog box. 

 

Ø  To change calibrations 
1. In the Logger Configuration dialog box, click Calibrations. 

The Calibration Registry displays. 

2. If adding a calibration from an existing database file, select the new equation from the registry list. 

3. Click Change. 

4. Complete or edit boxes as required. Ensure all boxes marked with an asterisk (*) are completed. 
Click Accept. 

5. Click Save & Close to save the changes and close the Calibration Registry dialog box. 

 

Ø  To delete calibrations 
1. In the Logger Configuration dialog box, click Calibrations. 

The Calibration Registry displays. 

2. Select the equation to be deleted from the registry list. 

3. Click Delete. 
The message "Do you wish to proceed with deletion?" displays. 

4. Click OK to continue. 

5. Click Save & Close to save the changes and close the Calibration Registry dialog box. 
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Editing and cloning soil moisture databases 
Once you open a soil moisture database in the Logger Configuration dialog box, you can edit or clone the 
database as required. You cannot edit or clone irrigation & rainfall databases with the Logger 
Configuration dialog box. 

Note for Diviner® 2000 users: If the database originates from a Diviner® 2000 unit, no parts of the 
configuration are editable and the database cannot be cloned. The Logger Configuration dialog box can 
only be used to view the configuration. 

Cloning a soil moisture database 
Cloning a database is the process of duplicating the configuration into a new file, but without the 
readings. When two loggers have the same or similar configurations, cloning the configuration and 
editing it may save time instead of creating a new one from scratch. 

Note: Data Exchange also offers a method for cloning databases. 

Ø  To clone a database 
1. Open the database file you wish to clone. 

2. From the Logger Configuration dialog box, with the source configuration displayed, click Save New 
As.... 
The Save As dialog box displays. 

3. In the Save in: dialog box, click on the down-arrow and select a location for the new database. 
The contents of the selected directory display. 

4. In the File name: box, enter a file name for the new database 

5. Click Save. 
The Save As dialog box closes. The Logger Configuration dialog box is now displaying the cloned 
database. 

6. If you require a new irrigation & rainfall database, click 'Create I&R DB'. 

7. Click Quit. 
The Logger Configuration dialog box closes. 

Editing a soil moisture database 
The degree to which a database can be edited depends on whether it contains readings or not. The 
differences are described below. 

Editing a database without readings 
If the database does not contain moisture readings, all aspects of its configuration are editable. You can 
do any of the following: 

ü Change Logger ID, site labels and probe labels. 
ü Create and delete sites, probes and sensors. 
ü Change sensor addresses and depths. 
ü Change normalization values (air and water counts) for each sensor. 
ü Change sensor calibration equations.  
ü Create an I&R database 

 

Editing a database containing readings 
Once moisture readings are added to a database, the configuration of its sensors becomes fixed. If the 
database contains readings, you are limited to doing the following: 

ü Changing Logger ID, site labels and probe labels. 
ü Changing normalization values (air and water counts) for each sensor. 
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ü Changing sensor calibration equations.  
 

To protect the validity of the moisture readings already collected, you are prevented from: 

û Creating and deleting sites, probes and sensors. 
û Changing sensor addresses and depths.  

 

Editing a database's sensor configuration after readings are taken 
If it becomes necessary to change the physical layout of sites, probes and sensors after collecting moisture 
readings, you will need to clone the database. This will result in a database with an identical 
configuration, but no moisture readings. This new database can then be edited as desired, the 
configuration sent to the logger and readings downloaded. 

Note: Readings can be transferred from the old database to the new one, using Data Exchange. 

All existing graphs and layouts will still refer to the old database. You will have to add the new database 
to your layouts as required, and will have to create new graphs from it. 

See page 106 for details on cloning a database. See below for details on editing a database. 

Ø  To edit a database 
1. Open the database file you wish to edit. 

2. From the Logger Configuration dialog box, do one or more of the following, as appropriate: 

• Make changes to the logger, site and probe labels as required by clicking on the existing labels 
and entering the new name. 

• Make changes to the normalization values as required, by clicking on the fields and reading new 
values from the sensors. 

• Make changes to the calibration equations for each sensor as required, by selecting new values 
from the drop-down list. 

• If the database does not yet contain moisture readings: 
• Make changes to the sensor addresses and depths as required, by clicking on the fields and 

entering new values. 
• If you want to delete any sites, probes or sensors, select the item. 

Click Delete Site, Delete Probe or Delete Sensor as required. 
Note: This is a single button but the text changes as different logger tree items are selected. 
Note: Deleting a site deletes all probes and sensors attached to that site. Deleting a probe deletes 
all sensors attached to the probe. 

• If you want to add an item, select the logger, site or probe to which you want to add a site, probe 
or sensor respectively. 
For example, to add a probe to a site, select the site. 
Click Add Site, Add Probe or Add Sensor as required. 
Note: This is a single button but the text changes as different logger tree items are selected. 

3. Click Save. 
The changes are saved. 

4. If the database is for an RT6 logger and you have changed the logger ID label or altered the 
configuration of sensors, you should update the logger by clicking Send to Logger. 
Note: This will erase all moisture readings in the logger's memory. If the readings have not yet been 
downloaded to a database, they will be lost. 

5. Click Quit. 
The Logger Configuration dialog box closes. 
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Database Tools 
IrriMAX provides a selection of tools for manipulating the readings in IrriMAX databases. These tools 
can be accessed from the following locations: 

• In the Workspace Manager window, reveal the Database List and click on a database. Choose a 
tool from the Tools menu or the right-button popup menu for the database. 

• In the Workspace Manager window, if the Database List is not visible or there is no database 
highlighted, choose a tool from the Tools menu. You can then browse for the required database 
using a file dialog. 

• In the Graph window, click on a pane to select it then choose a tool from the Tools menu. The 
tool will apply to the database whose readings are shown in the currently selected pane. 

 

Export from a database 
The export function is a quick way to invoke Data Exchange with the chosen database preset as a source. 
You can export to any of the supported Data Exchange destination formats. 

Ø  To export data from a database 
1. From the Tools menu of the workspace window or a graph window, select Export… 

2. The Data Exchange dialog opens with the source database preset.  

3. Click the Set Range button if you any want only a portion of the database. Then setup the 
destination parameters as wanted. 

4. Click the Start button and wait for the export of data to complete. Then click the Quit button and 
return to the workspace or graph  

Trim/extract data from a database 
The Trim/Extract command is used to remove data from a database or to copy data from one database to 
a new database. This command may be used to: 

• remove old data that is no longer required 
• remove corrupt data from the end of a database prior to reloading data. 
• completely empty a database. 
• copy an important part of the data to a new database file for archiving or demonstration purposes. 

 

Ø To trim a database 
1. In the Database List of the Workspace Manager window, click on the database to be trimmed. 

2. From the Tools menu, or the right-button popup menu, click Trim/Extract. 
The Trim/Extract Database dialog box displays. 
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Note: The colored data slide bar represents the data that is to be kept in the database. 

3. Select the data you wish to delete or extract using one of the following methods: 

• Click the left mouse button on the data slide bars and drag them to a specific time and date 
The changing date is displayed under the Beginning and End Index fields. 

• Enter an index number in the Beginning and End Index fields or scrolling to the correct date. 
 

4. It is possible to completely empty a database by selecting an end index that is less than the start 
index. For example, drag the end slider all the way to the left to select a range of 0 to -1. 

5. Select Trim this database to delete the unwanted data from the beginning and/or end of the 
database. 

6. Click OK. 
The database is resized and the Trim/Extract Database dialog box closes. 

 

Ø To extract data from a database 
1. From the Tools menu, click Trim/Extract. 

The Trim/Extract Database dialog box displays. 

2. Select the data you wish to extract using one of the following methods: 

• Click the left mouse button on the data slide bars and drag them to a specific time and date. 
The changing date is displayed under the Beginning and End Index fields. 

• Enter an index number in the Beginning and End Index fields or scroll to the correct date. 
 

 
3. Select Extract to new database to copy the data from the current database to a new database. 

4. Click Browse. 
The Specify Destination File Name dialog box displays. 

Data slide bar 



 IrriMAX User Guide 
 Software Reference Guide 

Sentek Pty Ltd 110 

5. In the Save in: box, click on the down-arrow and select a location for the new database. 
The contents of the selected directory displays. 

6. In the File name: box enter a file name for the new database 

7. Click Save. 
The Save dialog box closes. 

8. Click OK. 
The data is extracted to a new database and the Trim/Extract Database dialog box closes. 

 

Remove spikes from a database 
A spike is an unexpected change in a graph's shape. An orphan is a reading on its own with a gap on 
either side. Spikes and orphans can occur in logger data because of environmental factors, like lightning 
strikes, faulty battery connections etc. It can be helpful to remove them using Spike Remover.  

Spike Severity 
The Severity of a spike is defined by the angle of that spike, so that a smaller angle (sharper spike) will be 
graded as more severe than a shallow angle (wider spike).  

Orphans are not considered to be spikes. 

 

 
 

What happens to the 'Removed' spike? 
When a reading (from a spike or orphan) is 'removed', its calculated value is set to INVALID (-1), 
indicating that this value is not to be graphed. The original raw value is not removed and can be used to 
recalculate the calculated value. 

How do I restore the removed spikes? 
When you use the database tool Recalculate, Select the check box "Recalculate INVALID moisture 
values" and the calculated values will be recalculated from the raw values using the calibration 
coefficients in the database. See page 110 

Spike Remover Dialog 
This dialog can be accessed from two places: 

• In Workspace Manager - from the Tools menu select Spike Remover 
• On a Graph window - from the Tools menu select Spike Remover  

 
The Spike remover window contains two main sections: 

• The list of spikes which were found in the database (if any) 
• A sketch of the graph section of the first selected spike in the list 
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Using the Spike Remover List section you can: 
• Sort spikes & orphans by clicking on the header buttons. For example by clicking on Severity, 

the most severe spikes and orphans are placed at the top. 
• Select a single spike and view a sketch of it in the sketch area. 
• Select a single spike and view the true graph window by clicking View. 
• Select one or multiple spikes (hold down the SHIFT key and select first and last of a range, the 

CTRL key to select each individually), and remove them all by clicking Remove. 
 

Spike remover controls 
  

Click this 
button... 

...to perform this function 

 (All list control column Header Buttons) - sort the list of 
spikes in incremental order by a column. 
(the sorted column is identified by an asterisk on the column 
header button). 

 
View the selected spike or orphan on the graph window 

 
Remove the selected reading(s) 

 

Show the Range Blanker dialog See page 112 

 
Close the Spike Remover dialog 

  

Ø  To Remove spikes from a database 
1a. From the Tools menu of the workspace window or a graph window, select Spike Remover…  
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2. The spike remover dialog displays 

 

3. Sort through the list (if any) and click Remove to remove any spikes or orphans you do not want. 

4. Click Close to close the dialog. 

 
To recover INVALID readings, use the Recalculate database tool with the 'Recalculate INVALID 
moisture values' checkbox checked. See page 110 

Blank a range of data in a database 
The Range Blanker is used to hide a range of readings from the soil moisture database. This means ALL 
of the readings in this range will have their calculated values set to INVALID (-1) so that they don't show 
on the graphs. This can be done for one single sensor, or all the sensors.  

The Range Blanker is used if a period of instability has occurred, and you want to remove the entire 
period. 

To access the Range Blanker, click on the Range Blanker… button on the Spike Remover dialog. See 
page 112. 

 

The 'removed' values can be retrieved by using the Recalculate dialog, with the 'Recalculate INVALID 
moisture values' checkbox checked. See page 110 
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Recalculate a database 
Recalculating a database re-applies the calibration formula(s) to every raw value in the database, giving a 
new set of calculated "cooked" values (which are the values used for graphs). Some databases may have 
some of their data hidden because of erroneous readings, invalid formulas or other reasons (like 
incorrectly calculated data being imported using AutoSDB 2 or Data Exchange). The way to restore this 
data is to Recalculate the data. 

It is also possible to back-calculate raw values from the current cooked values. This can be useful if you 
wish to change a calibration formula but the database does not contain raw values (typically they will be 
set to the special empty value of 65535.) This is a dangerous operation that depends on the current 
calibration formula and an accurate normalization history for success, otherwise raw values outside the 
allowed range of 0 to 65534 might be calculated and data loss will result. 

Ø  To Recalculate readings in one or more databases 
1. Select one or more databases from the workspace manager database list and choose Recalculate 

Database… from the Tools menu or the right-click popup menu. Alternatively you can select 
Recalculate Database… from the Tools menu of a graph window to recalculate the database 
graphed in the currently selected graph pane. 

 2. The following Database Recalculation dialog appears: 

 
3. Ensure that the Recalculate Values button is chosen. 

4a. Leave the "Recalculate INVALID moisture readings" check box clear and click Recalculate to 
recalculate error readings e.g. after changing calibration equation coefficients. 

OR 

4b. Select the "Recalculate INVALID moisture readings" check box  

Warning: 
The following steps will restore every spike that was previously removed by the Spike Remover. 

5. The following warning appears: 
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6. Click OK  

7. Click Recalculate to restore every spike. 

 

Ø  To Back-calculate raw values in a database (Advanced) 
This is a potentially dangerous operation that should be attempted by advanced users only. 

1. Make sure that you have a backup copy of your database. 

2. Select the database from the workspace manager's database list, and select Open> Database from 
the File menu. Alternatively, right-click the database and choose Open from the popup menu. 

3. Use the Logger Configuration dialog to ensure that an accurate normalization history of air and water 
counts exists for each sensor, by right-clicking on each sensor and choosing Edit Normalization 
History… from the popup menu. Then resave the database and close the dialog. 

4. Select the database from the workspace manager's database list, and choose Recalculate 
Database… from the Tools menu. Alternatively, right-click the selected database and choose 
Recalculate from the popup menu. The Database Recalculation dialog appears. 

5. Click the Calculate Raw Counts (Advanced) button. 

6. Click the Recalculate button. 
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Sensor Selection Dialog 
The Sensor Selection dialog is used to create new graphs, and to add panes to existing graphs. The dialog 
can be opened from either: 

• The Workspace Manager window (see page 49.) 
• The Layout window (see page 120.) 
• The Graph window (see page 143.) 

 
The dialog presents a number of tabs, one for each type of sensor in the database, and a Probe Layout tab 
if the database contains moisture or matric potential sensors. 

Note that if the user made a site selection on the Layout window before opening the dialog, then only 
those sites will be shown in the dialog. 

 

Ø  To create a new graph or pane 
1. If necessary, select a different database by clicking the Browse… button. 

2. Select the tab containing the sensors you wish to graph. In the case of soil moisture and matric 
potential, you can also use the Probe Layout tab. 

3. Select the sensors whose readings you wish to graph. See below for more information. 



 IrriMAX User Guide 
 Software Reference Guide 

Sentek Pty Ltd 116 

4. Click on the button for the graph type you wish to create, either Summed, Stacked, Common-Y or 
Separate-Y. Note that Separate-Y is unavailable if you are adding a pane to an existing graph. 

 

Ø  To select sensors using the Probe Layout tab 
The Probe Layout tab displays a pictorial representation of the logger, sites, probes and sensors in the 
given database. 

• Click the logger icon to select or deselect all sensors 
• Click the probe cap to select or deselect all sensors on that probe, and again to show the current 

selection 
• Click a depth indicator to select or deselect all sensors at that depth 
• Click individual sensors to select or deselect them. 

 
Dual (moisture and salinity) sensors are distinguished by a different color combination. Matric potential 
sensors have a different symbol. 

You cannot mix matric potential and moisture sensors on the one graph. 

Ø  To select sensors using the sensor type tabs 
Each type of sensor in the database is represented by a tab containing a list of all sensors of that type. 

 

Sensors are selected by placing a tick in their checkbox. To assist in making the selection, you can: 
• Click on a column header to sort by that column 
• Click on one sensor then hold down the Shift key and click on another to highlight a range of 

sensors. Clicking on one checkbox will place a tick in the checkboxes of all other highlighted 
sensors. 

• Click on multiple sensors with the CTRL key held down to highlight a number of sensors. 
Clicking on one checkbox will place a tick in the checkboxes of all other highlighted sensors. 

• Hit CTRL+A to select all sensors. 
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• Use the TAB key, the arrow keys and the space bar to select sensors using the keyboard. 
 

Ø  To select a graph type 
Click on the button corresponding to the graph type you require. The four graph types are: 

• Summed graph - representing the sum of the data from all selected sensors, on a common Y axis 
(the average soil water content of two or more probes can be displayed if the sensor depths are 
compatible) 

• Stacked graph - representing individual soil water sensors in order of increasing depths 
• Separate Y graph - representing the individual soil water sensors in order of increasing depths 

with individual Y scales per sensor 
• Common Y graph - representing all selected soil water sensors. 

 



 IrriMAX User Guide 
 Software Reference Guide 

Sentek Pty Ltd 118 

Layout Window 
The Layout window provides a pictorial representation of logger configurations. From the Layout window 
you create a picture of your site, and create new graphs from the databases displayed. 

From the Layout window you can: 
• create new layouts from existing databases 
• view and modify layouts 
• create graphs from layouts. 
• add / edit Irrigation & Rainfall data 

 

About the Layout window 
The Layout window opens when you view a workspace in IrriMAX that contains a layout, or create a 
new layout. 

 

The Layout window consists of a menu bar, toolbar, status bar and a layout area. 

The components of a layout are: 
• logger image(s) 
• one or more site images with probes and sensors 
• a background image or color 

 
The images can be moved around the window as appropriate. For example, You could use an aerial 
photograph of the site area as the background image and place the logger and site image at the appropriate 
places on the background. 
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Note: If a site contains more than three probes the image shows three probes with a '+' sign. 

Menu bar 
The Layout window menu bar contains all commands under four menus - File, Edit, View and Help. 
Each menu contains commands or submenus with commands. Where available the menu commands 
display the shortcut keys that perform the equivalent command. 

Ø  To return to the Workspace Manager window from the Layout window 

Click on  in the menu bar. 

Toolbar 
The Layout window toolbar is used to quickly access major editing and viewing commands that are 
applicable to the Layout window. The toolbar displays by default but can be hidden or displayed as 
required. 

Status bar 
The status bar at the bottom of a window displays information about the window. As you use the mouse 
to point to icons on a menu or toolbar, the name of the command being selected appears in the status bar. 

Missing databases 
If you open a layout and the original database file has been removed or renamed, a large red question 
mark displays over the logger and sites images. You can search for the missing database to update the 
layout. See page 127 for details of finding missing databases. 

 

Layout window commands 
All Layout window commands are available from one of the following: 

• menus on the menu bar 
• buttons on the toolbar 
• shortcut keys on the keyboard 
• options from the shortcut menu (right-click an item in a window to see the menu in context with 

the item) 
 

Note: Not all commands are available using all methods. 

Ø  To display the shortcut menus 
Right-click any item (object) in the window. A shortcut menu displays if available. If you do not see a 
menu, no shortcut options are available for that item. 

For example: 
• Right-click on a blank layout to display a list of commands for the layout space. 
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• Right-click on a logger image to display the commands specific to the logger or a whole database. 
• Right-click on a site image to display the commands specific to the site. 

Layout File Menu 
The File menu displays file commands for layouts. 
The menu commands, equivalent shortcuts and tool buttons are: 

Menu item Shortcut key Button To... 
New CTRL+N 

or 
ALT, F, N 

 
Create a new layout. See page 120. 

Open CTRL+O 
or 
ALT, F, O 

 
Open an existing layout. See page 121. 

Save CTRL+S 
or 
ALT, F, S 

 
Save the current layout. See page 121. 

Save As... ALT, F, A  Save the current layout with a new name. 

Print CTRL+P 
or 
ALT, F, P 

 
Print the layout. See page 122. 

Print Preview ALT, F, V 
 

Preview the file as it will print. 

Page Setup... ALT, F, U  Change the current page setup.. 

Close ALT, F, C  
on the 
title bar 

Close the layout window. 

Creating new files in the Layout window 
The layout window is used to create new graphs based on databases included in the layout window. It can 
also create new layout windows. 

Ø  To create a new graph 
Graphs can be created from any open layout provided that the database contains at least one reading. 

1. From the Layout window, double-click either a logger image (to display a Sensor Selection dialog 
with all sites) or a site image (to display a Sensor Selection dialog with only the selected sites). 

2. The Sensor Selection dialog displays the sensor configuration for the selected object. Sensors can 
be selected or deselected, then a new graph window created. See page 115. 

Ø  To create a new layout 
1. From the File menu, click New. 

A blank layout displays. 
Note: Follow the steps below to use the current layout displayed. 

2. From the Edit menu, click Add Database.... 
The Open dialog box displays. 

3. In the Look in: box, click on the drop-down arrow and select the directory where the database is 
located. 

4. In the Directory contents: box, click on the file to be opened. 
Database files have a file extension of .SDB. 

5. Click Open. 
A pictorial representation of the logger configuration database displays in the Layout window. 
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This is a new unsaved layout. From here you can alter the way any component of the layout appears using 
the Edit menu options. 

Opening layouts 
Each layout opens in its own layout window. Open layouts are placed in the currently open workspace of 
the Workspace Manager window. 
You can open files in the Layout window by: 

• browsing to the directory containing the file and selecting the file 
• selecting a file from the recently used file list in the File menu. 

 

Ø  To open a layout 
1. From the File menu, click Open.... 

The Open dialog box displays. 

2. In the Look in: box, click on the drop-down arrow and select the directory where the file is located. 

3. In the Directory contents: box, click on the file to be opened. 
Layout files have a file extension of *.SLL. 

4. Click Open. 
The layout displays. 

 

Ø  To open a recently used layout from the layout window 
From the File menu, click on the filename of the layout to be opened. 
The layout displays. 

Saving layouts 
If you require a copy of the layout, the Save As command can be used to save a copy of the layout with a 
new name. If you close an unsaved layout you are prompted to save the layout. 

Ø  To save a layout 
1. From the File menu, click Save. 

The layout file is saved. 
If the layout has not yet been saved, the Save As dialog box displays. 

2. Select a file location for the layout file. 
Note that the default name for a new layout is 'Layout1'. 
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3. Enter a file name for the new file. 

4. Click Save. 
The new file is saved. 

 

Ø  To save a layout as a new file 
1. From the File menu, click Save As.... 

The Save As dialog box displays. 

2. Select a file location for the new layout. 

3. Enter a file name for the new layout file. Note that the current file name displays in the File name 
box. Note: If you do not enter a new file name, the original file will be replaced with this file.  

4. Click Save. 
The new layout is saved.  

Printing layouts 
Layouts can be printed from the Layout window. You can print a layout with or without its background. 

Note:  Printing without backgrounds on black and white or slow printers may save time and printer 
resources. Some darker backgrounds may obscure logger setups when printed on low resolution, black 
and white printers. 

The Print Preview command displays the current file, as it would appear when printed. Using the Print 
Preview command, you can ensure that margin, printer settings and selected content are correct, before 
sending layouts to the printer. 

You can also print your layout to a printer file. A printer file saves all necessary information in a file that 
can be used on another printer supporting the same printer language. For example, you could use this 
feature to print a layout using another computer that doesn't have IrriMAX installed. 

Before you print, you should check that the page setup is correct for the document being printed. The 
Page Setup command is used to control how the document is printed on the page. For example, to set 
whether the document is printed in portrait or landscape orientation. 

Ø  To change page setup for a layout 
1. From the File menu, click Page Setup.... 

The Page Setup dialog box displays. 
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2. Under Paper, select from the drop-down lists: 

• The required paper size 
• The paper source 

3. Under Orientation, select either Portrait or Landscape. 

4. Under Margins, enter any special requirements for margins. 
Note how the sample page reflects these changes. 

5. Under Layout, select any or neither of the following options: 

• Center layout on the page 
• Print layout background 

6. Click OK to save the changes and close the Page Setup dialog box. 

 

Ø  To view a layout in print preview 
1. From the File menu, click Print Preview. 

The Print Preview window displays. 
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2. From the Print Preview window toolbar you can: 

Click... To... 

 
send the file in its current state to the printer. 

 
display the second page of the file where the file has more than one page. 

 
display the previous page of a file where you are on a page other than the first page. 

 
display one page of the file, where the file has more than one page. 

 
display two pages of the file simultaneously, where the file has more than one page. 

 
enlarge a specific area of the file. 

 
minimize the view of a specific area of the file. 

 
close the print preview window. 

 

Ø  To print a layout 
1. From the File menu, click Print.... 

The Print dialog box displays. 
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2. Under Copies, select the number of copies you want to print. 

3. Click OK. 
The layout is sent to the printer. 

 

Ø  To print to a printer file 
1. From the File menu, click Print.... 

The Print dialog box displays. 

2. Click the Print to file option. 

3. Click OK. 
The Print to File dialog box displays. 

4. Select a destination for the file. 

5. Enter a file name. Printer files have a file extension of *.PRN. 

6. Click Save to save the layout printer file. 

Closing layouts 
Since each layout file opens in its own window, closing a layout file also closes the window. Closing a 
layout removes the layout from the currently displayed workspace in the Workspace Manager window. If 
you close an unsaved layout, you are prompted to save the layout and the Save As dialog box displays. 

Note: You should not close a layout if you want to retain it in the workspace, instead you could click 
Workspace on the menu bar. 

Ø  To close layouts 
From the File menu, click Close. 
The Layout window is closed. 

Layout Edit Menu 
The Edit menu displays commands to format and configure a layout. The menu commands, equivalent 
shortcuts and tool buttons are: 

Menu item Shortcut key Button To... 
Selection Ø ALT, E, S  Access the options for a selected item(s) 

 New Graph... ALT, E, S, G 
 

View the Sensor Selection dialog to create graphs. See 
page 115. 

This dialog is also displayed by double-clicking the 
logger image or site image in the layout window. 

 Logger Configuration... ALT, E, S, C 
 

Edit the selected logger configuration. 

 Enter Readings... ALT, E, S, E 
 

Enter readings into the SDB file. 

 Enter Irrigation & Rainfall... ALT, E, S, R 
 

Edit Irrigation & Rainfall data into the WDB file. 

 Hide Sites ALT, E, S, H  Hide or show the sites associated with the logger 

 Remove Database ALT, E, S, M 
 

Remove selected database (configuration). 

 Image Ø ALT, E, S, I  Access the image options for the selected item. See 
page 129. 

  Choose... ALT, E, S, I, C  Choose a new image 

  Default Small ALT, E, S, I, S  Select the small default icon 
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Menu item Shortcut key Button To... 
  Default Medium ALT, E, S, I, M  Select the medium default icon 

  Default Large ALT, E, S, I, L  Select the large default icon 

  Label Position Ø ALT, E, S, L  Access label position options for the selected item. 

    Center ALT, E, S, L, C  Position the label in the center of the icon 

    Above ALT, E, S, L, A  Position the label above the icon 

    Below ALT, E, S, L, B  Position the label below the icon 

    Left ALT, E, S, L, L  Position the label to the left of the icon 

    Right ALT, E, S, L, R  Position the label to the right of the icon 

Add Database... ALT, E, A 
 

Add a database to the current layout. 

Refresh Databases ALT, E, R 
 

Refresh the databases in the current layout. 

This causes all the databases in the layout to reload 
their configuration and update the layout window. 

Select All ALT, E, A  Select all the elements of the layout window. 

Font... CTRL+F 
or 
ALT, E, F 

 
Change the font settings. See page 129. 

Background Ø ALT, E, B  Access the background options. See page 129. 

 Color... CTRL+B 
or 
ALT, E, B, C 

 
Select a background color. 

 Image... CTRL+I 
or 
ALT, E, B, I 

 
Select a background image. 

 Tile Image ALT, E, B, T  Tile the background image. 

Links Ø ALT, E, L  Access the links option. See page 129. 

 Straighten all Links ALT, E, L, S  Straighten links. 

 Color... ALT, E, L, C  Select a link color. 

 Thin ALT, E, L, T 
 

Make links thinner. 

 Normal Thickness ALT, E, L, N 
 

Make links normal thickness. 

 Fat ALT, E, L, F 
 

Make links fatter. 

 

Snap-To Grid Ø ALT, E, G  Change  the alignment of links and images. See page 
129. 

 Off ALT, E, G, O   

 Fine ALT, E, G, F   

 Medium ALT, E, G, M   

 Coarse ALT, E, G, C   

Enable Editing CTRL+E 
OR 
ALT, E, E 

 
Enable layout editing. 

Editing layouts 
Layouts may be edited to change elements of the layout window such as appearance, colors and fonts. 
These changes can only be made when the layout window is in editing mode. Logger configurations can 
be edited through the Logger Configuration dialog box accessed from the Edit menu. 

See page 91 for details on the Logger Configuration dialog box 
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Note: It is recommended to turn off edit mode when the layout has a background image, to prevent 
accidental movement of a logger in relation to the background picture. When editing mode is turned off, 
no editing commands are available. The buttons and menu options are dimmed. 

Note: Logger configurations are not a part of the layout window, so can still be edited when edit mode is 
turned off. 

Loggers and probes are displayed using the default images or customized with either the crop images 
supplied or your own images. Note that IrriMAX only supports bitmap (*.BMP) images. 

You can edit the following objects in editing mode: 
• The layout by adding or removing databases. 
• The images and links that represent the logger and its sites and probes, see page 129 for details. 
• The background by changing colors, fonts and background images, see page 129 for details. 

 

Ø  To enable editing 
From the Edit menu, click Enable Editing. 
Changes can now be made to the layout file. 

Selecting objects for editing 
All objects, except the background, must be selected before they can be edited. Selected objects can also 
be moved about the layout by dragging a selected object(s) with the mouse. 

Note: When editing mode is turned off, objects cannot be moved within the layout.  

Ø  To select objects for editing 
You can select one or more objects by doing one of the following: 

• One object 
Click on one object; the object is highlighted 

• Multiple adjacent objects (not including links) 
Place the cursor at a point, for example, above and to the left of the objects to be selected. Click 
and drag the mouse until the selection encloses the objects. As the mouse moves, a line displays 
the borders of the selection. Release the mouse button and the selected objects are highlighted.  

• Multiple scattered objects (not including links) 
Press and hold the ctrl key; click each object to be selected. Each object is highlighted as it is 
selected. 

• All objects in the layout 
From the Edit menu, click Select All. 

 
Note: If you right-click an object, you can select the object and view the shortcut menu at the same time. 

Editing selected objects 
The Edit menu only displays the edit commands available for the selected object(s). If no object is 
selected or more than one object is selected, the Selection menu is empty. 

If, for example, you select a logger image, the editing commands include Remove Database, Image and 
Label Position submenus. 
If you select a probe, the only editing commands available are in the Image and Label Position 
submenus. 
If you select both a logger and a probe, the Selection submenu is empty. 

Managing databases 
Databases can be added, removed and refreshed in a layout when using edit mode. 
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If a database has changed since the layout was first created, for example, you have changed logger or site 
names; you can refresh the database(s) appearance in a layout. If a database file is restored, the layout 
window will not know until the Refresh Databases command is used.  

Ø  To edit the logger configuration (logger selection only) 
1. From the Edit menu, select the Selection submenu or right-click the logger image. 

The Selection submenu displays. 

2. Select Logger Configuration... 
The Logger Configuration dialog box displays. 
See page 91 for details on how to configure a logger.  

Note: Logger and probe labels are defined in the logger configuration and display in the Layout window. 
To edit label text you have to edit the logger configuration in the Logger Configuration dialog box. 

Ø  To enter readings into a database 
1. From the Layout window, do one of the following: 

• Select a logger & click the Enter Readings icon  on the toolbar. 
• Right click on a logger & select 'Enter Readings...' 

2. The Database Entry utility opens with the database already loaded. 
Please see the Database Entry documentation for more information.  

Ø  To enter Irrigation & Rainfall events 
A Logger with an associated irrigation & rainfall database will have an icon like this: 

 

1. From the Layout window, do one of the following: 

• Select a logger & click the 'Enter Irrigation & Rainfall data' icon  on the toolbar. 
• Right click on a logger & select 'Enter Irrigation & Rainfall...' 
• Right click one or more Site(s) & select 'Enter Irrigation & Rainfall...'  

(this will pre-select this site or sites in the I&R data entry dialog). 
2. The Database Entry utility opens with the database already loaded. 

Please see the Database Entry documentation for more information.  

Note: If there is no I&R database associated with the selected soil moisture logger (database), you will be 
given the opportunity to create a new Irrigation & Rainfall database. You should not create it yet if the 
site configuration of the soil moisture database is not final. 

Ø  To hide or show sites for a logger 
1. From the Layout window, do one of the following: 

• Right-click on a logger and select 'Hide Sites'. 
• Left-click on a logger and choose 'Hide Sites' from the Selection submenu of the Edit menu. 

2. If the sites were shown, they will be hidden. If the sites were hidden, they will be shown.  

Ø  To remove a database from the layout (logger selection only) 
1. From the Edit menu, select the Selection submenu or right-click the logger image. 

The Selection submenu displays. 
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2. Select Remove Database. 
You are prompted to confirm that you want to remove the database from the layout. 

3. Click OK to remove the database. 
The logger and site images are removed from the layout. 

 

Ø  To refresh all databases (no selection necessary) 
From the Edit menu, click Refresh Databases 
All data is updated in the layout window.  

Ø  To find a missing database (logger selection only) 
1. Right-click on the affected logger and click Find Missing Database.... 

The Missing Database dialog box displays. 

 

2. Click Browse to browse for the missing database. 
The Open dialog box displays. 

3. In the Look in: box, click on the drop-down arrow and browse for the directory where the database 
file is located. A list of available files displays. 

4. Click on the database to be included in the layout. 

5. Click Open. 
The red question marks are removed from the images. 

 

Editing the appearance of a layout window 
The appearance of a Layout window, and the images that represent loggers and probes, can be edited 
individually. Backgrounds can be displayed as block colors or images. Where an image is chosen, the 
image may be tiled (repeated across the window). 

Changing the layout font setting changes the font of all the labels displayed in the Layout window. 
Individual labels cannot be formatted separately.  

Layout links are the lines that join site images to logger images in the Layout window. By default the 
links display as straight lines. You can also place bends into any link. You may want to do this if, for 
example, you use a background image to represent your irrigation layout and you may want to place the 
logger and site images on the background image to reflect their true physical positions. Link color and 
line thickness can be changed so that the link clearly contrasts against colored backgrounds. 

Links can be: 
• bent (individually selected links) 
• straightened (individually selected or all links) 
• changed in color (all links) 
• changed in line thickness (all links). 
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Ø  To change the size of an object (any selected image) 
1. From the Edit menu, select the Selection submenu. 

The Selection submenu displays. 

2. Select Image. 
The Image submenu displays. 

3. Do one of the following 

• Click Choose... to select a new image. 
The Open dialog box displays. 
In the Look in: box, click on the drop-down arrow and select the directory where the image is 
located. 
In the Directory contents: box, click on the image to be opened. Allowable image files have the 
extensions *.BMP, *.GIF, *.JPG, *.PNG, *.TIFF and *.EMF. 
Click Open. 

• Click Default Small to select the default small image 
• Click Default Medium to select the default medium image 
• Click Default Large to select the default large image. 

The new image displays in the Layout window. 
 

Ø  To change a label position (any selected image) 
1. From the Edit menu, select the Selection submenu. 

The Selection submenu displays. 

2. Select Label Position. 
The Label Position submenu displays. 

3. To position the label, click: 

• Center to position the label in the center of the image. 
• Above to position the label directly above the image. 
• Below to position the label directly below the image. 
• Left to position the label to the left of the image. 
• Right to position the label to the right of the image. 

 
The label is repositioned. 

Ø  To change layout fonts 
1. From the Edit menu, click Font.... 

The Font dialog box displays. 
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2. In the Font box, scroll and select a font or enter the first letter/s of the font to automatically scroll to 
that area of the list. 
A sample of how the font will display is shown in the Sample box. 

3. In the Font style box, select a style from those listed, for example, Italic. 
A sample of how the font will display is shown in the Sample box. 

4. In the Size box, select an appropriate size to match your font. 
A sample of how the font will display is shown in the Sample box. 

5. In the Script box, click on the drop-down arrow and select a preferred script. Not all fonts have 
multiple script settings. Only fonts that have special character sets, such as Central European, 
Symbol or Mac will list multiple script settings. 

6. Click OK. 
The Font dialog box closes. 

 

Ø  Changing the background color 
1. From the Edit menu, select Background and click Color.... 

The Color dialog box displays. 

 
 
Do one of the following: 

2. To change the current link color using the Basic colors palette, select a color and click OK. 
The Color dialog box closes and the links are refreshed with the new color. 

3. To change the current link color using the Custom Colors palette: 

• Click Define Custom Colors>>. 
• Select a color using the custom color controls. 
• Click Add to Custom Colors. 
• Click OK. 

The Color dialog box closes and the background refreshes with the new color. 
 

Ø  Changing the background image 
1. From the Edit menu, select Background and click Image.... 

The Open dialog box displays. 

2. In the Look in: box, click on the drop-down arrow and select the directory where the image is 
located. 

3. In the Directory contents: box, click on the image to be opened. 
Allowable image files have the extensions *.BMP, *.GIF, *.JPG, *.PNG, *.TIFF and *.EMF. 
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4. Click Open. 
The image displays in the Layout window. 

Note: The layout window does not control the image size. You may need to alter the image size in a 
graphics software package if you want it to fill the window. 

Ø  Tiling a background image 
From the Edit menu, select Background and click Tile Image. 
The image is replicated across the window. 

Note: The current background must contain a background image for this command to work. 

Ø  To straighten all links 
1. From the Edit menu, select Links and click Straighten all Links. 

You are prompted to confirm that you want to straighten all links.  

2. Click OK. 
The window is refreshed and all links are straightened. 

 

Ø  To change the color of all links 
1. From the Edit menu, select Links and click Color... 

The Color dialog box displays. 
Do one of the following:  

2. To change the current link color using the Basic colors palette, select a color and click OK. 
The Color dialog box closes and the links are refreshed with the new color. 

3. To change the current link color using the Custom Colors palette: 

• Click Define Custom Colors>>. 
• Select a color using the custom color controls. 
• Click Add to Custom Colors. 
• Click OK. 

The Color dialog box closes and the links are refreshed with the new color. 
 

Ø  To change the link width 
From the Edit menu, select Links and click the desired width, from:  

• Thin 
• Normal Thickness 
• Fat 

All links display at the chosen width. 

Ø  To bend a link 
1. Click on the desired link in the layout. 

The link is highlighted. 

2. Click and hold the mouse button at the point on the link where you want to place the bend. 

3. Drag the link to place the desired bend. The link now has two straight segments joined at the bend. 

4. Repeat this process to place all required bends in the links. 

Note: If you click and drag a logger or site image after the bends are placed, the bends remain intact but 
the segments closest to the image adjust in length to conform with the new position. 
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Ø  To straighten selected links 
Do one of the following:  

• Right-click anywhere on the link, and click Straighten. 
The whole link is straightened. 

• Right-click on a bend, and click Remove Bend. 
The selected bend is removed. 

 

Using Snap-To Grid 
Snap-To Grid is used to control how objects are aligned in the Layout window. Snap-To Grid settings 
'draw' an invisible grid across the window and elements can only be moved to the intersecting points on 
the grid. When Snap-To Grid is on and you move an object such as a site image, you can see the image 
moves in 'jumps' reflecting the grid cell size. The more coarse the setting, the bigger the 'jumps'. Snap-To 
Grid can also be switched off; this allows you to place objects anywhere in the layout. Use Snap-To 
Grid when you want neat alignment of images in the layout.  

Ø  To use Snap-To Grid 
From the Edit menu, select Snap-To Grid and click the required setting from: 

• Off 
• Fine 
• Medium 
• Coarse. 

 
The layout links and images will conform to the chosen setting when moved. 

Layout View Menu 
The View menu lists elements of the window that may be displayed or removed from view, for example, 
toolbars. 

The menu commands, equivalent shortcuts and tool buttons are: 

Menu item Shortcut 
key 

To... 

Toolbar ALT, V, T Display or hide the toolbar. When ticked, the toolbar is displayed. 

Status Bar ALT, V, S Display or hide the status bar. When ticked, the status bar is displayed. 

Viewing the toolbar and status bar 
The toolbar is used to quickly access major editing and viewing commands that are applicable to the 
window. The toolbar displays by default but can be hidden or displayed as required. 

The status bar at the bottom of a window displays information about the window. As you use the mouse 
to point to icons on a menu or toolbar, the name of the command being selected appears in the status bar. 

Ø  To display the toolbar and status bar 
From the View menu, click: 

• Toolbar to display the toolbar. 
• Status Bar to display the status bar. After clicking on a logger image, the staus bar shows the 

database name. When a menu or toolbar item is being selected a short description of the item is 
shown on the status bar. 

Layout Help Menu 
The Help menu provides access to the online user guide contents and search utilities. 
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The menu commands, equivalent shortcuts and tool buttons are: 

Menu item Shortcut 
key 

Button To... 

Help Topics F1 
 

Display the online help file. 

About IrriMAX...  
 

Display current version information. 

Ø  To access online help 
From the Help menu, click Help Topics. 
The Help window displays. 

Click the Contents tab to scroll through a table of contents for online help. 
Click the Index tab to search for topics by using an index of keywords and phrases. 
Click the Find tab to use full-text search and look for specific words. 

Ø  To access version information about IrriMAX 
1. From the Help menu, click About IrriMAX... 

The IrriMAX about dialog box displays. 

2. Click OK to close the dialog box. 
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Graph Window 
The Graph window presents readings from one or more databases in an easily manipulatable graphical 
format. 

The Graph window contains one or more panes. Every graph has a primary pane at the bottom, with 
various optional secondary panes stacked on top. Each pane shows readings from a single underlying 
database file. 

Secondary panes can be of the following types: 

• The Irrigation & Rainfall pane is always at the top. This pane normally contains irrigation and 
rainfall data sourced from a WDB database file with the same filename as the SDB database file 
in the primary pane. 

• The Salinity (or Volumetric Ion Content) pane is always directly above the primary pane. It 
displays the volumetric ion content readings from TriSCAN sensors whose moisture readings are 
displayed in the primary pane. 

• Finally, several Generic panes can be created to display readings for any sensor type, sourced 
from any database. 

 
Some graph menu items and toolbar buttons affect only the data shown by the graph in the currently 
selected pane. The selected pane is identified by the bold, underlined title in the left hand pane margin. 

 
 

The relative height of the panes can be adjusted by dragging the splitter bars that separate the panes up or 
down. 

Data for the currently selected pane can also be displayed in a separate Text Data Viewer window and 
saved as an ASCII text file. See page 184. 
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Graphs can be created from the Workspace Manager window (see page 49) or the Layout window (see 
page 120). 

Menu bar 
The Graph window menu bar contains all commands under six menus - File, Edit, View, Zoom and 
Help. Each of these menus contains sub menus and commands. Where available the menu commands 
display the shortcut keys that perform the equivalent command. 

Ø  To return to the Workspace Manager window from the Graph window 

Click on  in the menu bar. 

Toolbar 
The Graph window toolbar is used to quickly access major editing and viewing commands that are 
applicable to the Graph window. The toolbar displays by default but can be hidden or displayed as 
required. 

 

Graph Header 
The Graph Header (the header, for short) of the Graph window displays details about the database whose 
readings are shown in the current pane: 

• The Logger ID 
• The database filename (excluding the folder path) 
• The last reading time 
• The current sample interval (the time difference between the last two readings) 

 
These details update as the current pane changes. 

The bottom row of the header section contains a Comment box where you can enter your own comment. 
You can add, edit or delete the header comment. 

Each row of the header displays by default but if you do not need to see the details or require a larger area 
to display the graph, you can disable any or all of the rows in the header. Disabled rows are hidden from 
view until you enable them again. 

Autohide is a convenient feature of the header. Using Autohide you can hide all enabled rows until you 
point the cursor to the dividing bar above the graph. All enabled rows display while the cursor remains in 
the header. 

Ø  To add, edit or delete a header comment 
The graph header comment is used to provide extra information about the graph window. It is shown in 
the Workspace Manager graph list, and on mailed or webified graphs. It is distinct from the Graph 
Comments, which are added directly to the graph (see page 168.) 

1. Double-click on the Comment box. 
The Edit Comment dialog box displays. 
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2. Type any comments about this graph in the Edit Comment dialog box. 
To delete a comment, just delete the text in this dialog box. 

3. Click  to save the comments or  to close the comment box without saving. 
The comment displays in the Comment box. 

 

Ø  To enable or disable a header row 
1. Right-click anywhere in the window header. 

A shortcut menu displays. 

 
Checked menu items indicate that a row is enabled. 

2. Click the name of the row to enable or disable. 
You can choose from: 

• Logger Details 
• Comments. 

 
Enabled (checked) rows display and disabled (unchecked) rows are hidden. 

Note: If all rows are disabled, right-click the dividing bar above the graph (a small remnant strip of the 
header section) to display the shortcut menu.  

 
 

Ø  To use Autohide 
1. User the menu View submenu Auto Hide Graph Header (the item has a tick mark when Autohide 

is enabled), or 
Right-click anywhere in the graph header or in the dividing bar above the graph (when the header is 
hidden).  

 
A shortcut menu displays. 

2. Click Autohide to toggle selected or cleared flag. If the menu item is: 

• checked, all enabled rows hide until you point the cursor to the dividing bar above the graph 
• unchecked, all enabled rows remain display at all times. 

3. Unhide the header by pointing to the dividing bar above the graph, right-click in the revealed header 
and in the shortcut menu deselect Autohide. 

Note: Disabled rows do not display at any time. 
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Graph Popup menu 
There is a shortcut to commonly used graph operations using the graph popup menu. This menu is 
displayed when you click the right mouse button while the mouse pointer is anywhere in graph window, 
excluding the axis areas.  

 

The items in the menu depend on the type of graph pane in which you click. 
• Properties (available on all pane types). Used to display the graph Properties dialog for the pane. 
• Unit of Measure (available on all pane types). This submenu allows you to change the unit of 

measurement used for the display of values in the pane. Choose IrriMAX Setting (if available) 
to use the unit specified on the Measurement tab of the IrriMAX Settings dialog (see page 77) or 
choose Database Unit to use the unit as stored in the database. Depending on the type of sensor, 
there may be other units available on the menu. If you have defined a custom unit (see page 149), 
it will be selectable from here. 

• Zoom to Horizontal Extent (available on all pane types). Changes the horizontal time range to 
show the full extents of the graph. Hold down the Shift key when selecting this function to zoom 
to the combined horizontal extents of all panes. 

• Zoom to Vertical Extent (available on all pane types). Changes the vertical range to show the 
full vertical extents of the visible part of the graph. Hold down the Shift key when selecting this 
function to zoom all panes to their individual vertical extents. The behavior of this function can 
be customized from the IrriMAX Settings dialog (see page 80) 

• Reset Graph (available on all pane types). Scrolls the graph so that the end point is visible, and 
optionally zooms to vertical extents. The behavior of this function can be customized from the 
IrriMAX Settings dialog (see page 80). Hold down the Shift key when selecting this function to 
zoom all panes to their individual vertical extents. 

• Stack (available for panes with more than one vertical axes - i.e. stacked and separate-y graphs). 
Arranges the graph lines in sensor order so that none overlap. 

• New, Edit, Delete Growth Stage (only available on a pane with a single vertical axis). Used to 
create a new growth stage with the time preset to the position of the right-click, or to edit or 
delete the growth stage encompassing the position of the right-click. 

• Copy Pane, Paste Pane, Paste Properties (available on all pane types). Used to copy a pane to a 
copy buffer, paste the copied pane into the graph, and paste various properties from the copied 
pane into an existing pane. See page 170. 

• Remove Pane (not available on the primary pane). 

Status bar 
The status bar at the bottom of a graph window displays information about the window. As you use the 
mouse to point to icons on a menu or toolbar, the name of the command being selected appears in the 
status bar. 
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The graph status bar can contain the following information: 
• 'Ready' or a description of toolbar and menu items when they are selected 
• Time span of the X-axis 
• Vertical span of the Y-Axis in the currently selected pane 
• Database available icon. 

The icon will have a red-cross  if the database cannot be read. Pointing 
to this icon will show a ToolTip containing the path and filename of the database e.g. 

 
• Database being accessed message 

 

Line Legends 
Each pane of the graph window has a Line Legend describing the sensors associated with each line in the 
pane. 

If the cursor hovers over a legend, it changes to a finger. Clicking the legend brings up a menu that allows 
selection of a number of common graph modes. The More… option opens the graph's Properties dialog. 

 

The position of each legend can changed, or the legend can be hidden completely. See page 149 for 
legend options. 

Graph symbols 
As well as the graph lines, symbols can appear: within the graph panes. 

Symbol Name Usage 

 Diamond Last data point in the database 

 Cross Orphan data point or very short line segment, having invalid points on 
either side  

 Gap in line One or more invalid data points 

 
Bold number in label   The bold number is the sensor number as shown in the line legend in the 

graph header 

 Arrow, left and right in 
line labels 

The arrow points in the direction and value of the next valid data reading, 
when there is no line intersecting the axis 

 Arrow, up and down in 
labels 

The arrow points in the direction of the graph line when the line is above 
or below the display area 

 
Chevron, left right, up 
and down. 

Appears when graph window size reduced to a size where there is no 
room to display the axis as well as the data.  

 
Units of measurement Measurement units of the vertical axis (metric or imperial) 
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Scrolling graphs 
Scrolling can be done across the horizontal axis (time scale) or up and down the vertical axis (I&R or 
moisture scale). You can scroll a graph using the standard scroll bars and scroll buttons, by dragging a 
graph axis, or you can scroll horizontally and vertically at the same time by dragging the graph itself. 

Ø  To scroll a graph along the horizontal axis 
1. Point the mouse cursor to the horizontal axis. 

The cursor changes to a hand symbol . 

2. Click the left mouse button and drag the axis left or right. 
The graph scrolls along with the mouse. 

 

Ø  To scroll a graph along the vertical axis 
1. Point the mouse cursor to the vertical axis. 

The cursor changes to a hand symbol . 

2. Click the left mouse button and drag the axis up or down. 
The graph scrolls along with the mouse. 

 

Ø  To scroll a graph horizontally and vertically 
1. Point the mouse cursor to the graph window (not the legend part) and click the left mouse button 

without releasing it. 

2. Start moving the mouse. 
The cursor changes to a four-way arrow symbol and the graph scrolls along with your mouse 
movement.. 

 

Summed graph 
This represents the sum of the data from all selected soil moisture sensors (the average soil water content 
of two or more probes can be displayed if the sensor depths are compatible) 

Note: You cannot sum multiple matric potential sensors, but a summed graph can be created for a single 
one to allow use of agronomic lines and regions. 

 

Stacked graph 
This represents individual sensors in order of increasing depths. 
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Separate Y graph 
The separate Y graph represents the individual sensors in order of increasing depths, within each probe. 
There is an individual Y scale per sensor. To allow comparative analysis, each Y scale can be 
independently dragged to overlap the graph lines of other sensors. 

 

Common Y graph 
This represents all selected sensors against a common axis. 
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Growth Stages 
If the lines in your graph do not have independent axes, you can add budget lines which can define 
agronomic regions (full point to onset of stress). See page 157 for setting up the growth stage budget line 
values and the growth stage start points. 

The following example shows four growth stages in grapes, and the water demands of the vines at those 
stages. 

 
 

Salinity pane 

The Salinity pane is displayed when menu View, Volumetric Ion Content or toolbar button  is 
selected. It displays a graph in the following format:: 

• The pane is only available if the database has salinity sensors. 
• Stacked and summed moisture graphs display salinity sensors as stacked graphs of separately 

movable graph lines for each sensor.  
• Common-Y and separate-Y graphs display the salinity data with the same axis type as the 

moisture pane. 
• Salinity is displayed in units of Volumetric Ion Content (V.I.C.) 
• The color of each graph line is the same color as the corresponding moisture sensor. 
• The vertical ruler is common to all graph panes. 
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See the "TriSCAN Agronomic User Manual" for interpretation of salinity data. 

Custom Sensor Pane 

A Custom Sensor pane is created from menu View, New Pane… or toolbar "+" button  is 
selected.  

Warning: 
Closing a custom sensor pane loses all of its sensors selections and graph comments. 

This opens the Sensor Selection dialog which enables you to choose a database, the sensors to include in 
the custom sensor pane, and the graph type. See page 115. 

Note that the Separate-Y graph type is not available for custom sensor panes. 

When the graph type button is activated the new pane is created. 

 

The new pane has following format:. 

• Α line graph, summed, stacked or common-Y 
• Α vertical axis legend contains the units description and unit abbreviation in square brackets 

 
Up to 9 custom sensor panes can be created on one graph. 

Removing a Custom sensor pane 
You can remove a Custom Sensor pane by either : 

• Click in the desired pane then click the remove "-" button   
• Right mouse click in the desired pane and select Remove Pane from the popup menu. 
• Select menu View then select the pane name (ticked) from the menu list to remove the pane. 



 IrriMAX User Guide 
 Software Reference Guide 

Sentek Pty Ltd 144 

 

Irrigation and Rainfall pane 
The Irrigation & Rainfall pane is displayed when the View, Irrigation and Rainfall menu item is selected. 
There are six possible modes for this pane: Event Rates, Event Amounts, Hourly Totals, Daily Totals, 
Weekly Totals, and Monthly Totals. The event modes present the amount applied or rate of application of 
each specific irrigation or rainfall event. The totals modes present the total amount of water applied in a 
predefined period of time. 

Each mode has the following format: 

• Clicking on the pane's legend allows selection of the six different modes. This popup menu is 
equivalent to the main menu View, Irrigation and Rainfall.  A new I&R graph pane is created 
with the type of mode that was previously selected. 

 
• A bar graph representing Irrigation and Rainfall. 

The default color of the rainfall bars is blue and the default color of irrigation bars is magenta. 
These defaults can be changed using the colors tab in Workspace Settings. The color of Rate 
mode bars can be different to the other modes. Where there is an overlap between irrigation and 
rainfall events the irrigation bar is placed above the rainfall bar to show an accumulated total. 
Note: When I&R data is averaged across multiple sites the totals bars have a horizontal highlight 
to distinguish the parts comprising the average. 

• Below the bars on event modes are segmented totals for rainfall plus irrigation with subtotals for 
rainfall, in blue, and irrigation, in magenta. The segment size changes with different horizontal x-
axis zoom levels 

• Total mode graphs have a narrow space present between each bar to distinguish the period 
boundaries. 

• The vertical y-axis on the rate graph shows the application rate in millimeters (or inches) per hour 
(mm/h or inches/h). 

• The vertical y-axis on totals graphs show total applied water in the mode selected.  
• At the top border of event graphs, the duration of irrigation is shown. The numbers only appear at 

zoom levels where space permits the display of numbers such as 12:00 (12 hours). 
 

Event Rates Mode 
This graph display the application rate (mm/hour or inches/hour) for all I&R events. The height of each 
bar represents the rate of application. 

The color of the I&R bars can be changed using the Workspace Settings for "Irrigation rate bars" and 
"Rainfall rate bars". These colors can be different to the bars on other mode options. 
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Event Amount Mode 
The total amount of water (mm or inches) and start time for each recorded event is shown as a solid bar 
followed by shading that progresses until the end of the event. The height of each bar indicates the total 
amount of water applied during the event. 

 
 

Hourly Totals Mode 
This graph displays the total water applied in each hour. When an event spans an hour boundary the total 
in each hour is partitioned according to the number of minutes the event covered. 

The start time of each hour is set to the time specified in I&R Global Settings for Graph "Day Start". The 
default is 9:00am 
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Daily Totals Mode 
This graph displays the total water applied in each day. When an event spans a day boundary the total in 
each day is partitioned according to the number of minutes the event covered.  

The start time of daily totals is set to the time specified in I&R Global Settings for Graph "Day Start". 
The default is 9:00am. 

 
 

Weekly Totals Mode 
This graph displays the total of water applied in each week (7 days). When an event spans a week 
boundary the total in each week is partitioned according to the number of minutes the event covered. 

The start day of each week is set to the time specified in I&R Global Settings for Graph "Week Start". 
The default is Monday. The start time of each week is set to the time specified in I&R Global Settings for 
Graph "Day Start". The default is 9:00am. 

 
 

Monthly Totals Mode 
This graph displays the total water applied in each calendar month. When an event spans a month 
boundary the total in each month is partitioned according to the number of minutes the event covered. 
Because each month is a calendar month there may be different number of days in each period. 

The start time of the first day of the month is set to the time specified in I&R Global Settings for Graph 
"Day Start". The default is 9:00am. 

Note: If the rainfall data entry Settings are set to "Daily Totals", "End Date" and 9:00am (the defaults) the 
data entered on the first day of the month will be accumulated in last day of the previous month. This is 
an internationally accepted method of recording daily rainfall observations.  
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Interpretation of I&R graphs: 
The following guidelines can assist in the interpretation of I&R graphs 

• The I&R graph segment total is the total amount applied for the time-period demarcated by the 
solid vertical bars. The larger font size value is the sum of the smaller font size irrigation value 
and rainfall value. 

• To read the time-period, follow the dotted lines down to the Soil-Water graph x-axis. 
• To show a daily rate on the I&R segment totals, X-zoom in or out until the Soil-Water and I&R 

x-axes are at a time-scale of 1 day.  
• The ruler can be used at any point to measure the instantaneous time and rate. 

 

Missing databases in graphs 
If a graph is opened and the database on which it is based was removed or renamed, the graph window 
displays a red cross on top of the database icon at the right of the Graph status bar. If you attempt to 
access the data by, for example, resetting the graph, the Missing Database dialog box displays. 

 

Ø  To find a missing database 
1. From the Missing Database dialog box. 

2. Click Browse to browse for the missing database. 
The Open dialog box displays. 

3. In the Look in: box, click on the drop-down arrow and browse for the directory where the database 
file is located. A list of available files displays. 

4. Click on the required database. 

5. Click Open. 

6. There are three possible outcomes: 

• The connection is restored. Save the graph to make the new connection permanent. 
• An error message box displays. The selected database is incompatible with the graph, and cannot 

be connected. 
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• A warning message box displays. The selected database is not the one that created the graph, but 
is compatible with it. You can proceed with connecting the database, but you should be aware of 
the possibility that you are connecting the wrong one. If you connect the wrong database the 
graph will adapt, but the water-budget lines and comments will become meaningless. If this 
happens, close the graph without saving it, and try again. 

Graph Properties 
The graph Properties dialog is used to modify various persistent properties of a graph document, 
including:  

• Whether a graph is drawn as lines, bars or change bars 
• How line legends are displayed 
• Colors of lines or bars 
• Values and display options for budget lines and regions 
• Growth stages (different budget lines and regions for different time periods) 
• Mail and webify options 

 
Most properties are specific to the current graph pane. In the case of multi-pane graphs, the current pane 
is the one most recently clicked-on, whose title is drawn bold and underlined. 

Depending on the type of the current pane, some properties may not be available: 

• The special Irrigation and Rainfall pane does not allow changing line colors, budget lines or 
growth stages. 

• The Volumetric Ion Content pane will disallow changing line colors if the same lines are shown in 
the primary pane. 

• Budget lines and growth stages cannot be created on any pane containing independent vertical 
axes (i.e. a stacked or separate-Y graph). 

 
Some properties pertain to the graph document as a whole and are not pane specific. These include those 
found on the Mail and Webify tab and the Miscellaneous section on the General tab. 

Note: You can alter some of the default properties for new graphs by using the IrriMAX Settings dialog in 
Workspace Manager. See page 74. 

Ø  To view (or change) graph properties 
1. Left-click on the pane whose properties you want to change to make it the current pane. 

2. From the File menu, click Properties.... or select the Properties button  on the toolbar. 

3. The Properties dialog box displays for the current graph pane. 

Alternatively you can right-click on a graph pane and select Properties… from the popup menu. The 
Properties dialog box displays for the graph pane that you right-clicked on. The current pane does not 
change. 

 
All tabs of the Properties window have a common set of buttons 

Click this 
button... 

...to perform this function 

 
Apply all changes and close the Properties dialog box. 

 
Cancel the Properties dialog box without applying any 
changes. The settings remain unchanged. 

 
Apply all changes without closing the Properties dialog box. 
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Click this 
button... 

...to perform this function 

 
Display the online help. 

  

General Graph Properties 
General Properties control the way a graph displays in the window. 
There are four sections in the General tab: 

• Graph Mode (choose lines, bars or change bars, and set bar properties for the current pane) 
• Unit of Measure (choose the displayed unit for the values in the pane) 
• Legend (governs appearance and content of the line legend for the current pane) 
• Time Shift (allows comparison with historical data and corrections to timestamps) 
• Miscellaneous (non-pane-specific settings) 

 

 

Graph Mode 
The Graph Mode section contains controls that govern how the readings are represented on screen. 
Moisture and salinity are usually best represented as Lines, but other types of data may be better shown 
as Bars. Finally, Change Bars can be used with any type of data to show how each value has changed 
compared to the previous value. 

Note: Bar graphs are most effective when there is a single vertical axis controlling all bars, in order that 
all bars have the same vertical origin. If you have more than one sensor graphed in the pane, the pane type 
should therefore be either Summed or Common-Y. 

Ø  To select a graph mode 
1. Choose either the Lines, Bars or Change Bars radio button in the Graph Mode section of the 

General tab. 
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2. If you chose Bars or Change Bars, set the bar properties (see below). 

3. If some lines, bars or line comments are consistently obscuring others, you can elect to draw the 
graphs in reverse order (see below).  

 

Ø  To set the bar properties 
1. Choose a duration that will apply to every bar, by selecting a preset duration from the Duration 

drop-down list, or typing a duration directly into the Duration edit control. The maximum duration 
is one week. 

2. Choose a method for determining the value of the bar from the Bar Value drop-down list. This 
method is used when more than one reading falls inside the period covered by a given bar. The 
choices are: 

• End - the bar displays the value closest to the end of the period 
• Start - the bar displays the value closest to the start of the period 
• Minimum - the bar displays the smallest value from the period 
• Maximum - the bar displays the largest value from the period 
• Average - the bar displays the average of all values within the period 
• Total - the bar displays the sum total of all values within the period 
• Total Positive - the bar displays the total of only the positive values within the period 
• Total Negative - the bar displays the total of only the negative values within the period 

 
3. If you chose a duration of one week for the bars, then choose which day of the week each bar should 

start on, by selecting a day from the Week Start drop-down list. 

4. If the duration you choose is an exact multiple or divisor of one day, then choose what time each 
day should start by entering a time in the Day Start drop-down list. The format of this field is 
controlled by Windows Regional setting for Time (12 hour with AM/PM, or 24 hour clock). 

5. The Stagger Time property is used when the pane contains bars for more than one sensor, to ensure 
that all bars are visible (i.e. not completely covered by other bars). 
When the bars are drawn, the second and subsequent sensors' bars are offset by multiples of the 
stagger time, and the width of all the bars is reduced so that all bars still fit within the period 
specified in the Duration control. 
To set a stagger time, select a preset from the Stagger Time drop-down list, or type a duration into 
the Stagger Time edit control. 
The maximum allowable stagger time depends on the bar duration and the number of sensors. If you 
enter a value greater than the maximum, then the maximum will be used. For example, if daily bars 
for two sensors are graphed, the maximum stagger time is 12 hours, which will result in the bars 
being plotted next to each other with no overlap, within each 24 hour period. 

 

Ø  To draw the graphs in reverse order 
Lines, bars and comments are drawn in order from the first sensor to the last. This means that graph 
elements for later sensors will overlap those for earlier sensors. If this is consistently a problem for your 
graph, you can choose to reverse the drawing order by placing a tick in the Draw in reverse checkbox. 

 

Unit of Measure 
The Unit of Measure drop-down list allows you to change the unit of measurement used for the display of 
values in the pane. Choose IrriMAX Setting (if available) to use the unit specified on the Measurement 
tab of the IrriMAX Settings dialog (see page 77) or choose Database Unit to use the unit as stored in the 
database. Depending on the type of sensor, there may be other units available in the list. 

You may also define your own unit conversion to use in the pane. 
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Ø  To define a custom unit conversion 
1. Click the Edit… button in the Unit of Measure section. The Edit Custom Graph Unit dialog appears. 

 

2. Enter a name for your new unit. This must be short enough to display under the graph's axes. 

3. You can enter an offset value. The first step of the conversion will be to add this offset to the value 
found in the database. Enter zero if you do not wish to use an offset. 

4. Enter a multiplier. The second step of the conversion is to multiply by the multiplier. If you wish to 
perform a division, you will need to calculate the inverse of the divisor and use that as the 
multiplier. Enter a multiplier of 1 if you do not wish to use a multiplier. 

5. Finally, you can add a constant. The third step of the conversion is to add the constant to the result 
obtained by applying the offset and then the multiplier. Enter a constant of zero if you to not wish to 
use a constant. 

6. Click OK to save the custom unit. You unit will now be selected and available in the Unit of 
Measure drop-down list. 

7. You can click Delete to delete the unit definition so that it does not appear as a selectable unit. The 
Delete button will be disabled if there is no custom unit defined, or the custom unit is currently 
being used by the pane. 

 

Legend 
Each pane has a line legend that describes the sensor represented by the lines or bars of a particular color. 
The physical positioning and some of the content of the legend can be altered. 

Ø  To change the position of a pane's line legend 
From the Position drop-down list in the Legend section, choose one of the following: 

• Above - Positions the legend above the graph, stretching across the entire width. No part of the 
graph is obscured by the legend. This is the default position. Other positions can be chosen to 
increase the available space for graphing. 

• Top-Right - Positions the legend over the top-right corner of the graph. This is the recommended 
position for an Irrigation and Rainfall legend. 

• Top-Left - Positions the legend over the top-left corner of the graph. 
• Bottom-Left - Positions the legend over the bottom-left corner of the graph. 
• Bottom-Right - Positions the legend over the bottom-right corner of the graph. 
• Hidden - Hides the legend completely. Sometimes the legend isn't required, for example in a 

Volumetric Ion Content pane when the lines are already described in the main pane, or in an 
Irrigation and Rainfall pane where the colors are the same system-wide. 
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Ø  To change the content of a pane's line legend 
There are four optional pieces of information that can be displayed in the pane's legend. These are 
optional because they are also displayed in the Header section of the graph window (but only for the 
current pane, not all panes at once). 

It can be useful to display this information for clarity, particularly if a pane shows readings from a 
different database/logger to that of the primary pane. This is particularly true if you wish to mail or 
webify a graph, since a mailed or webified graph lacks the pane-sensitive Header section. 

To change the legend content, select one or more of these checkboxes: 

• Logger Id - Shows the logger id from the pane's underlying database 
• Database name - Shows the file name of the pane's underlying database 
• Last reading time - Shows the timestamp of the last reading in the pane's underlying database 
• Sample interval - Shows the time difference between the last two readings in te pane's underlying 

database. This is usually the sample interval of the logger. 
 

Ø  To change the default legend properties 
If you have changed the legend's position and content and would like these properties to apply to all new 
graphs and panes, click the Save as defaults button in the Legend section. 

Time Shift 
The graph can be offset from the time axis in the primary pane by a user-definable time offset. This can 
be useful for comparing current data with historical data, for example comparing the current graph with 
that of the previous year. To do this, you would create a second pane with a time shift of -52 weeks. 

It can also be useful for making corrections to the timestamps of the readings if they are incorrect by a 
known amount. A common case is that of bar graphs of pulse sensors (e.g. a tipping bucket), where the 
timestamp denotes the end of a sample interval rather than the start. In this case, the pane should be 
shifted by a positive amount equal to the sample interval. 

Ø  To set a time shift 
• Either choose a preset time shift from the Offset of this pane from time axis drop-down list 
• Or type a value into the Offset of this pane from time axis edit control. You can type "seconds", 

"minutes", "hours", "days" or "weeks", or the control will recognize 's', 'm', 'h', 'd' and 'w' 
respectively. When you move off the control it reformats itself and you can verify that your input 
was recognized. 

 

Miscellaneous 

• Stick to end of main graph on open 
By default, when a graph file is opened, it displays the same section of the graph that displayed 
before it was last saved. 
The 'stick to end' feature can be used to ensure that the graph always shows the latest data. If the 
end point of the graph is visible prior to a database update, then after the database update the 
graph will be scrolled so that the new end point is at the same horizontal position within the graph 
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window. 

 
• Preset date range 

The preset date range refers to the time scale along the horizontal axis. This can be set to the 
number of days that are significant for your agricultural watering cycle, for example, 7 days. 
This setting is used by the Reset Graph and Zoom To Preset Date Range commands. 

 

Line Color Properties 
The Graph Lines tab allows you to set the color of the graph lines. The number of lines available to be 
changed depends on the type of graph being used. 

 

Ø  To set graph line attributes 
1. From the Properties dialog box click the Graph Lines tab (if not already displayed). 
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2. Click on the Color down arrow of the line you wish to change. 
The Color dialog box displays. 

 

3. Do one of the following: 

• select a color from the Basic colors palette 
• click Define Custom Colors>> and click on the variegated palette. Click Add to Custom Colors 

to select the non-basic color and return to the Basic colors palette. 
4. Click OK. 

The Color dialog box closes. 

5. Do one of the following: 

• click OK to apply the changes and close the Properties dialog box 
• click Apply to apply the changes without closing the dialog box (you can now change other 

settings) 
• click Cancel to discard the changes and close the dialog box. 

Budget Line Properties 
Note: Budget lines are only available for graphs with a single vertical axis. 

Budget lines allow you to specify indicators for different states of soil saturation. For example, you can 
specify the moisture content considered to be the refill point where irrigation is necessary. 
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The budget lines can be used in two ways. 

1. The Full Point and Onset of Stress settings are used to display three, color-coded sections in the 
graph. These colored bands are reflected in the soil moisture gauge displayed in the Workspace 
Manager window. 
Note: It is recommended a Sentek trained agronomist or distributor analyze how these budget lines 
should be set for correct irrigation practice. 

2. Marker lines can also be used to highlight strategic reference points. 

 
The following budget lines can be used: 

• Saturation 
All soil pores (spaces between solids) are filled with water. 

• Field capacity 
The moisture content after drainage of the gravitational water is known as field capacity and it is 
the upper limit of moisture held in the soil. 

• Full Point 
The 'Full Point' is the soil water content after an irrigation. Irrigation should replace the amount of 
soil water extracted by the plant root zone without producing significant excess that drains below 
the bottom of the root zone wasting water and fertilizer. 

• Water logging 
A soil water content usually between field capacity and saturation threshold, where the rate of 
crop water use is reduced by a limited supply of soil air to the root zone. 

• Refill Points 1,2,3 
The concept of a 'Refill point', is the soil water content at which point irrigation should occur, 
usually in order to replenish the soil water content to the Full Point. The Refill Point can be set 
when an applied irrigation quantity has been used up and before the crop has reached the onset of 
stress. Multiple Refill Points can be set to gain a desired physiological plant response (i.e. To 
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regulate cell expansion, maximize cell reproduction, regulate concentrations of cell content 
components i.e. sugars, etc.). 

• Onset of stress 
The soil water content in the plant root zone, when the first observable slow down of the 
maximum daily crop water use rate after irrigation or rainfall occurs. This slow down should not 
be caused by a change in weather conditions, phenological stage of the crop, crop disease, 
harvest, spraying with chemicals, insect damage, etc. These factors need to be excluded through 
crop observation and weather monitoring. The slow down of daily intake should correlate only 
with the starting difficulties of the plant to develop sufficient osmotic pressure to extract soil 
water from a diminishing soil water reservoir. 

• Driest ever 
This indicates the driest soil water level ever measured on that site. 

• Permanent Wilting 
The soil water content at which the crop is subjected to irreversible wilting. 

• Marker 1,2 
Marker lines can be used to denote other important thresholds in a soil water budget i.e. water 
content during flowering and fruit set etc. 

 

Ø  To set budget lines 
1. From the Properties dialog box click the Budget Lines tab. 

2. Click the Full Point check box to enable this budget line. 

 

3. Enter the value for Full Point. 
Note: It is recommended a Sentek trained agronomist or distributor assists in setting this value. 
 

 
The graph reflects this value using colored sections. 

4. Select a line style and color. 
 

 

5. Repeat this sequence to set the Onset of Stress line. 

6. Repeat this sequence to set other budget lines as required. 
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7. Do one of the following: 

• click OK to apply the changes and close the Settings dialog box 
• click Apply to apply the changes without closing the dialog box (you can now change other 

settings) 
• click Cancel to discard the changes and close the dialog box. 

 

Ø  To change budget line names 
Budget Line Names describe the meaning of each budget line. These names may be changed as required 
by enabling the line and typing a new name into the Name field for the line. 

A set of default names suitable for soil moisture content are provided by default. The default names can 
be changed. See page 80.  

Note: The Full Point and Onset of Stress names, and the colors used to set the graph regions are fixed and 
cannot be altered. 

Growth Stage Properties 
  Growth stages allow the user to specify agronomic lines and regions that reflect the plant's varying 
moisture demands at various stages of its growth cycle. 

A growth stage consists of a starting date/time, and a new set of agronomic line and region values that 
apply from that time onward, until the start of the next growth stage. 

For scientific purposes there could be 20 different growth stages but typical farming uses is four or five 
stages. 

Growth stages are created using the Graph Properties dialog and are stored in the graph so are therefore 
unique to that particular graph. Only lines that are enabled on the Budget Lines tab page are displayed. 

Growth Stages are defined on the Growth Stages tab page. Only lines that are enabled on the Budget 
Lines tab page are available for editing. 

There are two method of opening the Growth Stages dialog: 

• Click the Graph Properties button  on the graph toolbar and select the Growth Stages tab. 
This initializes the date and time of the growth stage to today.  

• Right-mouse click on the graph, at the date and time you wish the start the growth stage to display 
the popup menu and select menu item New Growth Stage.. This initializes the date and time of 
the growth stage to the date and time at which you positioned your mouse. 
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To edit or delete an existing growth stage using this popup menu you can click anywhere to the right of 
the growth stage start line. It is not necessary to click on the start line. 

 

Name 
Enter a short, descriptive name for the growth stage. 

Start Date 
Enter the starting date for this growth stage. 

 

Click this button... ...to perform this function 

 

An existing growth stage can be selected from this combo-box if you want to modify or delete 
it. The names do not appear here until they have been added via the New button. The list is 
presented in chronological order. The stage name and its start date are displayed  

 
Use this to add a new growth stage.  

 
Delete the selected Growth Stage name. 

 
Save the currently displayed growth stage. Either from the growth stage selection list or the 
new name. Note: For an existing name, changing the name field changes the name in the 
growth stage list. 

 

Set the agronomic line value onwards from the start date for this line. The initial value is set to 
the value set on the Budget Lines tab page. If the value field is dimmed you must enable the 
line on the Budget Lines tab page. Fine adjustment of the value can be done using the spin 
buttons. 

The Name field can be changed on the Budget Line Names tab page. 

 
Apply all changes and close the Properties dialog box. 
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Click this button... ...to perform this function 

 
Cancel the Properties dialog box without applying any changes. The settings on other tab 
pages remain unchanged.  

 
Apply all changes without closing the Properties dialog box. This is in case you want to select 
another tab of the dialog box to make further changes to other settings. 

 
Display the online help. 

 

Alerts Properties 
The Alerts Properties tab is used to define the trigger conditions for graph-based alerts. Alert triggers can 
be added to any pane which contains budget lines. 

 

Ø  To enable or disable alerts 
Use the Enable Alerts for this pane checkbox to enable or disable alerts based on the triggers defined 
for the pane. Disabling alerts allows you to prevent the raising of alerts, while keeping the triggers you 
have defined. 

Ø  To create a new alert trigger 
1. Click the New button. 

2. Choose the severity of the alert from the drop-down list. A Red Alert is the most severe. The 
default severity is a Yellow Alert. 

3. Choose the graph line on which to base the alert. In the usual case of a summed graph, there is only 
one line to choose from, and this is selected by default. 

4. Choose the position relative to a budget line that will cause the alert to be raised. The choices are is 
above and is below. 
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5. Choose the budget line to compare the graph line's position to. 

6. The message control automatically updates to show the message that will be displayed when the 
alert is raised. You can edit this message, after which it will no longer automatically update. To 
restore automatic updating, delete the entire message. 
You can include the value of the last reading in the message by using %V as a placeholder. For 
example, enter "Soil Water Content %V is below Onset Of Stress". 

7. Click the Save Changes button to save the alert trigger. The trigger is saved, regardless of whether 
you later hit the Cancel button on the Properties dialog. To avoid saving your changes, select a 
different alert trigger, tab away from the page or hit the Cancel button. 

 

Ø  To edit an existing alert trigger 
1. Choose an existing alert trigger from the drop-down list. 

2. Make your changes to the various controls that define the alert trigger condition. The message 
control automatically updates to show the message that will be displayed when the alert is raised. 
You can edit this message, after which it will no longer automatically update. To restore automatic 
updating, delete the entire message. 

3. Click the Save Changes button to save the alert trigger. The trigger is saved, regardless of whether 
you later hit the Cancel button on the Properties dialog. To avoid saving your changes, select a 
different alert trigger, tab away from the page or hit the Cancel button. 

 

Ø  To delete an existing alert trigger 
1. Choose an existing alert trigger from the drop-down list. 

2. Click the Delete button. 

 

Mail and Webify Properties 
Mail & Webify Properties control the way the graph is converted to email or web-compatible form. 
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Mail Graph - Template 
A template file to use when converting this graph to an email. Leave blank to use the default template 
(see page 83.) 

Use the Browse… button to search for a different template file. 

Mail Graph - Recipients 
The email addresses of the recipients of the emailed graph snapshot, separated by commas. Enter the 
email addresses here if you will repeatedly email the same people. Otherwise you can enter the recipients 
at the time you create the email. 

Mail Graph - Subject 
Text for the subject line of the email. Leave blank to use the graph name. You can also enter the subject at 
the time you create the email. 

The subject line can contain certain macros that will be replaced with information specific to the graph 
you are mailing. These macros are: 

• GRAPH_NAME_TEXT is replaced by the name of the graph. 
• GRAPH_COMMENT_TEXT is replaced by the user-entered comment for the graph. 
• GRAPH_LOGGER_TEXT is replaced by the Logger ID from the database shown in the main 

pane of the graph. 
• GRAPH_DOWNLOAD_TEXT is replaced by the date and time of the last download into the 

database shown in the main pane of the graph. 
 

Mail Graph - Graphic Width and Height 
The width and height in pixels of the graphical part of the emailed graph snapshot. Enter 0 to use the 
same width or height as on screen. 
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Webify Graph - Template 
A template file to use when webifying this graph. Leave blank to use the default template (see page 83.) 

Use the Browse… button to search for a different template file. 

Webify Graph - Output Folder 
A folder to receive the files generated by the webification process. 

Use the Browse… button to select a folder to receive the files output by the webification process. 
Alternatively you can type the name of the folder in the edit box. 

If the folder you specify does not exist, it will be created during the webification process. 

You may enter a path relative to the location of the graph document, rather than supply a full path. 

Webify Graph - Graphic Width and Height 
The width and height in pixels of the graphical part of the emailed graph snapshot. Enter 0 to use the 
same width or height as on screen. 

Graph File Menu 
The File menu lists commands used to open, save, print and close files. 
The menu commands, equivalent shortcuts and tool buttons are: 

Menu item Shortcut 
key 

Button To... 

Open... CTRL+O 
or 
ALT, F, O 

 
Open an existing graph. See page 162. 

Save CTRL+S 
or 
ALT, F, S 

 
Save the current graph. See page 163. 

Save As... ALT, F, A  Save the current graph with a new name. 

Save Package… ALT, F, K  Save graph and database files in an IrriMAX file 
package. See page 33. 

Print... CTRL+P 
or 
ALT, F, P 

 
Print the graph. See page 163. 

Print Preview ALT, F, V 
 

Preview the file as it will print. 

Page Setup... ALT, F, U  Change the current page setup. See page 163. 

Properties... ALT+ENTER 
or 
ALT, F, R 

 
Change properties for this graph and pane only. 
See page 148. 

List of most recently 
open files 

ALT, F, 1 

2 ETC. 

 Open a recently accessed graph. 

Close ALT+F4 
or 
ALT, F, C 

 
on the 
title bar 

Close the Graph window. 

 

Opening graphs 
Only graphs can be opened in the Graph window. 

Each graph opens in a new Graph window and each graph is placed in the currently open workspace of 
the Workspace Manager window. 
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You can open graphs in the Graph window by: 
• browsing to the directory containing the file and selecting the file 
• selecting a file from the recently used file list in the File menu. 

 

Ø  To open a graph from the Graph window 
1. From the File menu, click Open.... 

The Open dialog displays 

2. In the Look in: box, click on the drop-down arrow and select the directory where the graph file is 
located. 

3. In the Directory contents: box, click on the file to be opened. 
Graph files have a file extension of *.GT, *.GSK, *.GSS and *.GSC. 
See page 31 for details of graph types. 

4. Click Open. 
The graph displays in the Graph window. 

 

Ø  To open a recently used graph 
From the File menu, click on the filename of the graph to be opened. 
The graph displays in the Graph window 

Saving graphs 
If you require a copy of the graph, the Save As command is used. 

Ø  To save a graph 
1. From the File menu, click Save Graph. 

The file information is saved. 
If the graph has not been saved before, the Save As dialog box displays. 

2. Select a file location for the graph file. 
Note that the default name for a new graph is 'Graph1'. 

3. Enter a file name for the new file. 

4. Click Save. 
The new file is saved. 

 

Ø  To save a graph as a new file 
1. From the File menu, click Save As.... 

The Save As dialog box displays. 

2. Select a file location for the new graph. 

3. Enter a file name for the new graph file. Note that the current file name displays in the File name 
box. 
Note: If you do not enter a new file name, the original file will be replaced with this file.  

4. Click Save. 
The new graph is saved.  

Printing graphs 
Graphs may be printed from the Graph window or Workspace Manager. To batch print multiple graphs 
from the Workspace Manager, see page 53. 
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The Print Preview command displays the current graph, as it would appear when printed. Using the 
Print Preview command, you can ensure that margin, printer settings and selected content are correct, 
before sending the information to the printer. 

You can also print your graph to a printer file. A printer file saves all necessary information in a file that 
can be used on another printer supporting the same printer language. You could use this feature, for 
example, to print a graph using another computer that doesn't have IrriMAX installed. 

Before you print, you should check that the page setup is correct for the document being printed. The 
Page Setup command is used to control how the document is printed on the page. For example, to set 
whether the document is printed in portrait or landscape orientation. 

Ø  To change page setup for a graph 
1. From the File menu, click Page Setup.... 

The Page Setup dialog box displays. 

 

2. Under Paper, select from the drop-down lists: 

• the required paper size 
• the paper source 

3. Under Orientation, select either Portrait or Landscape. 

4. Under Margins, enter any special requirements for margins. 
Note how the sample page reflects these changes. 

5. Under Budget Regions, select the printing style for the colored regions 
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6. Click OK to save the changes and the Page Setup dialog box closes. 

 

Ø  To view a graph in print preview 
1. From the File menu, click Print Preview. 

The Print Preview window displays. 

2. From the Print Preview window toolbar you can: 

  

Click... To... 

 
send the file in its current state to the printer. 

 
display the second page of the file where the file has 
more than one page. 

 
display the previous page of a file where you are on a 
page other than the first page. 

 
display one page of the file, where the file has more 
than one page. 

 
display two pages of the file simultaneously, where the 
file has more than one page. 

 
enlarge a specific area of the file. 

 
minimize the view of a specific area of the file. 

 
close the print preview window. 

 

Ø  To print a graph 
1. From the File menu, click Print.... 

The Print dialog box displays. 

2. Under Copies, select the number of copies you want to print. 

3. Click OK. 
The graph is sent to the printer. 

 

Ø  To print to a printer file 
1. From the File menu, click Print.... 

The Print dialog box displays. 

2. Click the Print to file option. 

3. Click OK. 
The Print to File dialog box displays. 

4. Select a destination for the file. 

5. Enter a file name. Printer files have a file extension of *.PRN. 

6. Click Save to save the graph printer file. 
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Closing graphs 

Ø  To close a graph 
From the File menu, click Close: 
If the file has not been saved a message box displays prompting you to save the changes. 

Note: You should not close a graph if you want to retain it in the workspace. To return to the Workspace 
click Workspace on the menu bar. 

Graph Edit Menu 
The Edit menu contains commands to add comments and rulers to the graph. 

The menu command, equivalent shortcuts and tool buttons are:  

Menu item Shortcut 
key 

Button To... 

Insert Vertical Ruler CTRL+L 
OR 
ALT, E, V 

 
Add a new vertical ruler to the graph. 

Remove All Vertical 
Rulers 

ALT, E, R 
 

Remove all vertical rulers from the graph. 

Insert Horizontal 
Ruler 

ALT, E, H 
 

Add a new horizontal ruler to the selected pane. 

Remove All 
Horizontal Rulers 

ALT, E, E 
 

Remove all horizontal rulers from the selected 
pane. 

Insert Comment ALT, E, C 

 

Add a new comment to the graph. 

Copy Pane ALT, E, O  Copy the selected pane to the copy buffer. 

Paste Pane ALT, E, P  Paste the copied pane. 

Paste Properties Ø ALT, E, A  Open the submenu for pasting pane properties. 

 Line Colors ALT, E, A, C  Paste the graph line colors from the copied pane 
into the selected pane. 

 Budget Lines ALT, E, A, B  Replace the budget lines and growth stages in the 
current pane with those in the copied pane.  

 Growth Stages ALT, E, A, G  Replace the growth stages in the current pane with 
those in the copied pane. Budget line values are not 
changed. 

 Graph Mode ALT, E, A, M  Change the graph mode of the current pane (line or 
bar, bar width etc) to that of the copied pane. 

Ruler commands 
The Edit menu displays commands to add and remove rulers on a graph. A vertical ruler is able to be 
moved to a date/time on the horizontal scale and displays values where it intersects the graph(s). If you 
add two or more vertical rulers, the second and subsequent rulers will display differences or totals relative 
to the ruler on their left. 

Horizontal rulers can be moved up and down the vertical axis. They only display a value label when there 
is a single vertical axis for the pane.  

Up to 64 rulers can be added to a graph. Once a ruler is added to a graph you can move the ruler by 
clicking and dragging the ruler line. Each ruler has a set of labels in small boxes. Each of these labels can 
be dragged to four positions with respect to the ruler and graph line intersection (top left, top right, 
bottom left, bottom right). In addition, all the labels on a ruler can be to the opposite position (flipped) 
with the graph right-mouse popup menu. 
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Note that the cursor changes from an arrow symbol  to a pointing finger symbol . 

Note: Rulers remain stationary in the window when you scroll a graph. 

Vertical Rulers 
The following picture shows a vertical ruler on 19/Jun/1997 at 8:12:39 am. The ruler labels show the 
value of the graph at the ruler intersection points. 

 

Two rulers can be used to show the difference in value and time between two points. Note the Delta 
symbol in the time label and the value label of the second ruler. 

 

No difference will be shown if you are graphing Change Bars, because the bars are showing the 
difference themselves. 
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Two rulers can also be used to sum the values between two points, when the rulers are applied to a bar 
graph in totals mode. Note the Sigma symbol in the value label of the second ruler. 

 

Horizontal Rulers 
The following picture shows horizontal rulers at 30.10 mm and 11.44 mm. 

 

Ø  To insert a ruler into a graph 
1. From the Edit menu, click Insert Vertical Ruler or click in the graph pane where you want a 

horizontal ruler then on the Edit menu click Insert Horizontal Ruler. 
A ruler appears on the graph. 

2. Click the left mouse button on the ruler and drag it to the required position. 

 

Ø  To remove a single ruler from the graph 
1. Hold the mouse over the ruler so that the pointing finger displays. 

2. Right-click and click Remove Ruler. 
The ruler is removed. 

 

Ø  To remove all rulers from a graph 
From the Edit menu, click Remove All Vertical Rulers. Or click in the graph pane where you want to 
remove horizontal rulers then on the Edit menu click Remove All Horizontal Rulers. 
All vertical rulers are removed from the graph.. Horizontal rulers are only removed for the currently 
selected pane. 

Graph comments 
Graphs can be annotated with multiple comments. Each comment comprises a balloon containing text and 
an arrow pointing to the creation position.  Comments are saved and restored with the graph. 



 IrriMAX User Guide 
 Software Reference Guide 

Sentek Pty Ltd 169 

 

The comments can be anchored to either a point on a graph line or the x-axis of any of the graph panes. 
There is no limit on the size or number of comments, but obviously too many comments will obscure the 
underlying graphs.  

Once a comment has been created the following actions can be performed: 
• Modify the text in a comment (word wrapping occurs automatically) 
• Remove the comment 
• Drag the balloon to another location in the current pane 
• Adjust the comment width (height is automatically adjusted with automatic word wrapping) 
• Hide or show the comment arrow and /or the comment border 
• Change the font of the text in all comments 
• Change the background color of all comments (the text remains the color of the associated graph 

lines) 
 

Ø  To insert a comment into a graph pane 
1. From the Edit menu, click Insert Comment or click the comment icon on the toolbar. 

A comment cursor appears on the graph. 

2. Drag the comment cursor to the desired position. While the cursor is a comment arrow pointing 
down the comment will anchor to the x-axis of the current pane. When the icon arrow points to a 

point on a graph line the icon changes to an angled-arrow  and the comment will anchor to that 
point on the graph line. The initial text is set to "new comment". 

3. If you want to abandon comment creation, move the cursor to the Edit menu and click Insert 
Comment (to remove the tick). Or click the comment icon on the toolbar. 

 

Ø  To remove a comment from the graph 
1. Move the mouse to anywhere in the balloon (but don't left-click because that will cause text edit 

mode to be entered). 

2. Right-click and click Remove Comment. 
The comment is removed. 

 



 IrriMAX User Guide 
 Software Reference Guide 

Sentek Pty Ltd 170 

Ø  To change the text in a comment 
1. Move the mouse to anywhere in the balloon and click once. 

The balloon border change from solid to dotted and the cursor changes to an edit box I-beam. 

2. The text can be modified using arrow-keys and mouse movements as with any multi-line edit box. 

3. Click outside the balloon to exit edit mode. 

 

Ø  To reposition a comment balloon 
1. Move the mouse to anywhere in the balloon and click once. 

The balloon border changes from solid to a dotted box. 

2. Move the cursor towards a corner of the dotted border and it will change into a four-way arrow 
cursor. 

3. Drag the cursor, and the balloon will move to the new position. 

4. Click outside the balloon. 

 

Ø  To change the width of a comment balloon 
1. Move the mouse to anywhere in the balloon and click once. 

The balloon border changes from solid to a dotted box. 

2. Move the cursor towards the dot in the middle of either side of the dotted border and it will change 
into a two-way arrow cursor. 

3. Drag the cursor left or right cursor, and balloon width changes. The balloon height will adjust 
automatically and will allow for word wrapping. 

 

Ø  To hide or show the arrow or border of a comment 
1. Move the mouse to anywhere in the balloon (but don't left-click because that will cause text edit 

mode to be entered). 

2. Right-click to display the popup menu and choose Show Arrow or Show Border. 
The arrow or border is either shown or hidden, depending on the previous state. 

 

Ø  To change the background color or text font of all comments 
1. See the description in global settings for Font Settings and Color Settings. 

Graph pane copy and paste 
The graph window's Copy and Paste feature can be used to copy entire graph panes and paste them into 
the same graph window, or a different graph window. It is also possible to replace the following 
properties of an existing pane with those from a single copied pane: 

• Line or bar colors 
• Budget lines (and, by implication, growth stages) 
• Growth stages 
• Graph mode (line, bar etc) 

 

Ø  To copy one or more panes to the copy buffer 
1. A pane can be copied by doing one of the following: 
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• Click within the pane to select it, then choose Copy Pane from the Edit menu. 
• Right-click within the pane to be copied, then choose Copy Pane from the popup menu. 

 
2. To copy an additional pane to the copy buffer, hold down the SHIFT key and choose Copy Pane 

again. 

 

Ø  To paste copied panes into a graph 
Choose Paste Pane (or Paste 2 Panes, Paste 3 Panes etc) from the Edit menu or the graph's right-click 
popup menu. Copied panes will be added at the top of the graph window, below any Irrigation and 
Rainfall pane. The most recently copied pane will be topmost. 

Note that it is not possible to have more than one Irrigation and Rainfall pane on a graph. Paste Pane will 
not add a second I&R pane if one already exists. 

Ø  To paste copied line colors into an existing pane 

• Click within the pane to select it, then choose Line Colors from the Paste Properties submenu of 
the Edit menu. 

• Alternatively, right-click within the pane, then choose Line Colors from the Paste Properties 
submenu of the popup menu. 

 
If there are fewer lines in the copied pane than in the target pane, the remaining lines in the target pane 
will be unchanged. 

It is not possible to paste line colors into an Irrigation and Rainfall pane. 

Ø  To paste copied budget lines and growth stages into an existing pane 

• Click within the pane to select it, then choose Budget Lines from the Paste Properties submenu 
of the Edit menu. 

• Alternatively, right-click within the pane, then choose Budget Lines from the Paste Properties 
submenu of the popup menu. 

 
The budget lines and growth stages in the target pane will be replaced with those from the copied pane. 

If the target pane does not support budget lines (due to having more than one vertical axis, or being an 
Irrigation and Rainfall pane), only the growth stages will be copied. 

Ø  To paste copied growth stages into an existing pane 

• Click within the pane to select it, then choose Growth Stages from the Paste Properties 
submenu of the Edit menu. 

• Alternatively, right-click within the pane, then choose Growth Stages from the Paste Properties 
submenu of the popup menu. 

 
The growth stages in the target pane will be replaced with those from the copied pane.The values of any 
existing budget lines will not be changed. 

If the target pane does not support budget lines, only the growth stages will be copied. 

Ø  To paste a copied graph mode into an existing pane 
• Click within the pane to select it, then choose Graph Mode from the Paste Properties submenu 

of the Edit menu. 
• Alternatively, right-click within the pane, then choose Graph Mode from the Paste Properties 

submenu of the popup menu. 
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The mode properties of the target pane will be replaced with those from the copied pane.These include 
whether the graph shows lines, bars or change bars, and the bar graph properties such as duration and bar 
value. 

It is not possible to paste the graph mode into an Irrigation and Rainfall pane or a V.I.C. pane. 

 

Graph View Menu 
The View menu lists commands used to view window objects, settings or text files. The menu commands, 
equivalent shortcuts and tool buttons are: 

Menu item Shortcut 
key 

Button To... 

Irrigation & Rainfall  Ø ALT, V, R 
 

Click button to view or hide the Irrigation & Rainfall graph pane 
(if I&R data is present). Select from menu to show Irrigation & 
Rainfall submenu. 

 Rate ALT, V, R, R   

 Amount ALT, V, R, A   

 Hourly Totals ALT, V, R, H   

 Daily Totals ALT, V, R, D   

 Weekly Totals ALT, V, R, W   

 Monthly Totals ALT, V, R, M   

Volumetric Ion Content ALT, V, V 
 

View or hide the Volumetric Ion Content (salinity VIC) graph 
pane (if salinity sensors exist in the database). See page 142. 

New Pane… ALT, V, P Open the Select Sensors for New Pane dialog, to create a 
custom sensor graph. See page 143.. 

Equalize Pane Heights… ALT, V, E  Adjust the height of all the panes so that the graph portion of all 
panes is approximately the same. 

Enlarge Pane ALT, V, N   

Text... ALT, V, X 
 

Access theText Data Viewer, to view the underlying data values 
for the graph in the currently selected pane. See page 184. 

Interpolation CTRL+I 
or 
ALT, V, I 

 
Interpolate the current graph (summed graphs only), to take 
account of depths that have no associated sensor. See page 
173. 

Comments ALT, V, C  View or hide all the comments on every pane. When ticked, the 
comments are visible. 

Tags  Ø ALT, V, G  Show the Tags submenu. . 

 Last Value ALT, V, G, V 
or 
F8 

 View or hide tags that show the last value of the lines in the 
currently selected pane (not supported for Stacked or Separate-
Y graphs with more than one line). 

 Last Value and 
Budget Line Distance 

ALT, V, G, D 
or 
F8 

 View or hide tags that show the last value of the lines in the 
currently selected pane, and the distance from adjacent budget 
lines (not supported for Stacked or Separate-Y graphs with 
more than one line). 

 Last Value and 
Budget Line Percent 

ALT, V, G, P 
or 
F8 

 View or hide tags that show the last value of the lines in the 
currently selected pane, and the percentage distance from 
adjacent budget lines (not supported for Stacked or Separate-Y 
graphs with more than one line). 

Auto Hide Graph Header ALT, V, A  Display or hide the graph header information. When ticked, the 
header only displays when the mouse hovers over the dividing 
line above the top graph pane. See page 136. 

Toolbar ALT, V, T  Display or hide the toolbar. When ticked, the toolbar displays. 

Status Bar ALT, V, S  Display or hide the status bar. When ticked, the status bar 
displays. 
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Interpolating graphs 
Interpolation is the process of estimating unknown intermediate values between two or more known 
values. For example, if you have sensors at 10, 20, 30 and 50cm on a probe but no sensor at 40cm, the 
software interpolates the value at 40cm and adds that value to the summed values in the graph. 

Note: Interpolation is only possible if: 
• one or more sensors are missing between the shallowest and deepest selected sensors 
• the graph is a summed graph, where you are adding the moisture values for all sensors per probe. 

 

Ø  To interpolate a summed graph 
From the View menu, click Interpolation. 
The graph updates with the (added) interpolated sensor values. 

Note: Any budget lines that have been created for a graph without interpolation are likely to be invalid 
when interpolation is turned on. 

Graph Zoom Menu 
The Zoom menu displays commands to change the scale of the horizontal or vertical axes. 

Time is displayed along the horizontal (X) axis. Soil water content displays along the vertical (Y) axis of 
the moisture pane. Irrigation &and rainfall application rate is displayed in I&R pane. 

Note: 
Y-axis zooming is applied to the pane that is currently active. Clicking anywhere in a pane 

makes that pane active, so its vertical axis title text is shown bold. 
X-axis zooming uses the current center point of the x-axis as the center of the next zoom level. 

Zoom to rectangle to increase or decrease the size of a selected section of data or Zoom X or Zoom Y to 
increase or decrease the current display. The menu commands, equivalent shortcuts and tool buttons are: 

Menu item Shortcut 
key 

Button To... 

Zoom X Ø ALT, Z, X   

 In SHIFT+X 
or 
ALT, Z, X, I 

 
Zoom in on the horizontal axis, displaying a more detailed 
time scale (less data) 

 Out X 
or 
ALT, Z, X O 

 
Zoom out on the horizontal axis, displaying a less detailed 
time scale (more data) 

 Extents CTRL+X 
or 
ALT, Z, X, E 

 
Zoom to the horizontal extents to fit all available data to the 
width of the window. The scale is adjusted to display the 
first and last readings. Also available from the graph popup 
menu. 

 All Extents SHIFT+CTRL+X 
or 
ALT, Z, X, E 

 Zoom the horizontal axis so that the full extents of the 
graphs in every pane are visible simultaneously. 

 1 Hour 
 12 Hours 
 1 Day 
 1 Week 
 30 Days 
 3 Months 
 6 Months 
 1 Year 
 

  Horizontal zoom, around the current graph center point, so 
the graph with covers the select time range 

Zoom Y Ø ALT, Z, Y   
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Menu item Shortcut 
key 

Button To... 

 In SHIFT+Y 
or 
ALT, Z, Y, I 

 
Zoom in on the vertical axis, displaying a more detailed 
scale, for the current graph pane. 

 Out Y 
or 
ALT, Z, Y, O 

 
Zoom out on the vertical axis, displaying a less detailed 
scale, for the current graph pane. 

 Extents CTRL+Y 
OR 
ALT, Z, Y, E 

 
Zoom to the vertical extents, to fit all available data to the 
height of the current graph pane. The scale is adjusted to 
display the maximum and minimum readings. Also 
available from the graph popup menu. 

 All Extents SHIFT+CTRL+Y 
or 
ALT, Z, Y, A 

 Zoom the graphs in every pane to show their respective 
vertical extents. 

 5% 
 10% 
 25% 
 50% 
 75% 
 100% 

  Vertically zoom the current graph pane to a fixed amount. 
The number indicates the percentage of the allowable 
range for the sensor type in the pane. 

Soil moisture has an allowable range of 0..100mm, so 
choosing 10% will zoom vertically to a 10mm range. 

Hold the SHIFT key to zoom all panes to the same 
percentage amount. 

Zoom to Rectangle Z 
or 
ALT, Z, Z 

 
Zoom in on a selected rectangle, allowing you to choose a 
specific area to enlarge. The cursor changes to a cross-
hair to allow you to drag-select the area. 

Zoom to Preset Date Range ALT, Z, P 
 

Zoom in on the preset date range, restoring the time scale 
to match the numbers of days in the preset date range, 
see page 149 for details on how to change the range.  

Reset Graph CTRL+R 
or 
ALT, Z, R 

 
Scrolls the graph in the current pane to reveal the last data 
point(s). 

Stack ALT, Z, S  Arranges graph lines in increasing sensor order, zoomed 
and scrolled so that the vertical space is fully utilized 
without any overlap of graphs. This feature only applies to 
stacked and separate-y graphs. 

Undo Zoom CTRL+Z 
or 
ALT, Z, U 

 
Revert to the last zoom level, in the current pane. 
Repeating the function reverts one more level, until all 
zooms have been undone. This does not reposition the 
horizontal or vertical scales, so graph lines may disappear 
off the screen. You cannot redo an undo. 

 

Note: Zoom to Horizontal Extent, Zoom to Vertical Extent, Reset Graph and Stack are also available 
from the graph popup menu, by clicking the right mouse button and selecting the desired zoom from the 
popup menu. See page 138. 

 

Ø  To zoom the horizontal axis 
From the Zoom menu, select Zoom X and click:  

 • In - the X-axis is magnified 

 • Out - the X-axis displays a greater time range 

 • Extents - the entire time range covered by the graph in the current pane displays. 
 • All Extents - The entire time range covered by all the graphs in every pane displays.. 
 • 1 Hour .. 1 Year - The X axis displays the chosen time range, centered on the same 

point as the previous range. 
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When the zoom level displays the vertical dashed lines at seven-day intervals (weekly) the date on the 
line is the day of the week (Monday through Sunday) that is set in Workspace Manager Settings for the 
"Week start day". 

When the zoom level displays the vertical dashed lines at month level, the date on each line is the first 
day of the month (not 30 day intervals). 

Ø  To zoom the vertical axis 
From the Zoom menu, select Zoom Y and click:  

 • In - the Y-axis for the current pane is magnified 

 • Out - the Y-axis for the current pane displays a greater range 

 • Extents - the entire vertical range for the graph in the current pane displays. 
 • All Extents - all graphs in each pane display their respective vertical ranges 
 • 5%..100% - the vertical range of the graph in the current pane is set to a percentage of 

the allowable range for the sensor type. Hold the SHIFT key to zoom all panes to the 
chosen percentage. 

 
The behavior of Zoom to Vertical Extents can be modified so that any budget lines are also included in 
the extents. See page 80. 

Ø  To zoom to a rectangle 
1. From the Zoom menu, click Zoom to Rectangle. 

The mouse pointer changes to cross hairs when pointing to a section of the graph. Also note that the 
Zoom to Rectangle button is depressed. 

2. Click and drag the mouse until the selection encloses the required section of the graph. As the 
mouse moves, a line displays the borders of the selection. 

3. Release the mouse button and the selected section enlarges to fill the available window. 
 
Note: This feature remains on until you turn it off by completing step 3 or click Zoom to rectangle 
again 

 

Ø  To zoom to a preset date range 
From the Zoom menu, click Zoom to Preset Date Range. 
The graph resizes to display the preset date range defined in General tab of the Settings dialog box. 

Ø  To reset a graph 
From the Zoom menu, click Reset Graph. 
The graph is scrolled to reveal the end-point in the current pane. 

The behavior of Reset Graph can be modified to also perform a Zoom to Vertical Extent and/or a 
Zoom to Preset Date Range. See page 80. 

Ø  To stack a stacked or separate-y graph 
From the Zoom menu, click Stack. 
The graph lines in the current pane are placed in sensor order and zoomed so that the vertical space is 
fully utilized without any lines overlapping.. 

Ø  To revert to the previous zoom level 
From the Zoom menu, click Undo Zoom. 
The window is refreshed to the previous zoom level (X-zoom or Y-zoom). The graph axis remains 
positioned with the new center point the same as the previous center point. 
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Graph Tools Menu 
The Tools menu contains commands for manipulating the graph, and the database in the currently active 
graph pane. 
The menu commands, equivalent shortcuts and tool buttons are: 

Menu item Shortcut 
key 

Button To... 

Logger Configuration… ALT, T, L  Open the Logger Configuration Dialog for the 
database in the current pane. See page 91. 

Enter Readings… ALT, T, E  Open the Database Entry utility for the database 
in the current pane. See the Database Entry 
documentation for more information. 

Download… ALT, T, D 
 

Setup and open Data Exchange to download 
readings into the current pane's database. See 
page Error! Bookmark not defined..  

Export… ALT, T, E  Open Data Exchange to export data from the 
current pane's database. See page 108. 

Spike Remover… ALT, T, S  Remove spikes from the current pane's 
database. See page 110. 

Recalculate 
Database… 

ALT, T, R  Recalculate the readings in the current pane's 
database. See page 113. 

Zip Graph… ALT, T, Z  Copy the graph document and all related 
database files to a Zip archive. See page 176. 

Mail Graph… ALT, T, M  Generate an email containing a snapshot of the 
graph. See page 176. 

Webify Graph… ALT, T, W  Save a snapshot of the graph in Web-compatible 
format. See page 178. 

Zip Graph 
A single graph document and its associated database files can be copied to a Zip archive. This is 
convenient for making back-ups, or for giving the files to another person. 

Ø  To copy a graph and associated databases to a Zip archive 
1. From the Tools menu of the graph window, select Zip Graph… 

2. A file selection dialog appears. Choose the name and location for the Zip file and click Save. 

 
If the Zip file already exists, IrriMAX will prompt for confirmation before overwriting it. It will not add 
files to an existing archive. 

The archive will contain the graph document, and each database (.SDB file) that is currently being viewed 
in the graph window. If an irrigation and rainfall database (.WDB file) exists with the same name as the 
database in the main pane, it will be backed up regardless of whether it is being viewed or not. 

The Zip file will contain full path information for each file. However, Zip files cannot store volume 
information, so the volume name will be represented as the top-level folder in the path. For example, the 
file C:\FILES\GRAPH.GT will be stored within the Zip file as C\FILES\GRAPH.GT. 

Mail Graph 
A snapshot of the graph as currently shown on screen can be sent as a HTML email, viewable within the 
recipient's email client. Alternatively the actual graph document and any related database files can be sent 
as an IrriMAX package file or as a Zip archive. 
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Note: Sending a graph as a HTML email requires that the recipient's email client is configured 
to allow HTML emails with embedded pictures. If the recipient's security policy forbids this, it 

should be possible for them to create an exception for emails originating from you. 

Ø  To mail a graph 
1. From the Tools menu of the graph window, select Mail Graph… 

2. The Mail Graph dialog appears 

 

 

Recipients 
Enter the email addresses of the recipients of the emailed graph, separated by commas. This field is 
mandatory. The value you enter here will update the stored property in the graph document. 

Subject 
Enter text for the subject line of the email. Leave blank to use the graph name. The value you enter here 
will update the stored property in the graph document. 

The subject text can contain certain macros that will be replaced with information specific to the graph 
you are mailing. These macros are: 

• GRAPH_NAME_TEXT is replaced by the name of the graph. 
• GRAPH_COMMENT_TEXT is replaced by the user-entered comment for the graph. 
• GRAPH_LOGGER_TEXT is replaced by the Logger ID from the database shown in the main 

pane of the graph. 
• GRAPH_DOWNLOAD_TEXT is replaced by the date and time of the last download into the 

database shown in the main pane of the graph. 
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Message 
Enter an optional message for the recipients of the graph. Unlike the other values entered on this dialog, 
the message text is not saved within the graph document. 

Send 
Choose the type of email to send. Select HTML Email to mail a static snapshot of the graph that the 
recipient can view in their Email client software. 

Select IrriMAX Package to send the graph document and related databases in an IrriMAX package 
(.imxpak) file. The recipient will be able to open the package directly from the email if they have 
IrriMAX 9.1 or later installed. 

Select Zipped Graph to send the graph document and related databases in a standard Zip archive. 

More Properties… 
Click this button to invoke the Mail and Webify properties page for the graph (see page 160). From there 
you can specify additional properties to fine-tune the way a HTML email will appear. 

OK 
Finally, click OK to email the graph. At this point, the Mail Settings page might appear if you have not 
already configured IrriMAX for sending mail (see page 82). 

Webify Graph 
A snapshot of the graph as currently shown on screen can be converted into web-compatible files. This is 
useful for converting the graph into a universal format for use in presentations or for publishing on the 
Internet. 

The webification process produces a web-compatible document (usually a HTML file) with an embedded 
graphic file showing those elements of the graph that cannot be otherwise represented. The graphic file is 
in PNG (portable network graphics) format and is viewable in most modern browsers. 

Ø  To webify a graph 
1. From the Tools menu of the graph window, select Webify Graph… 

2. The Webify Graph dialog appears 

 

 

Output Folder 
Use the Browse… button to select a folder to receive the files output by the webification process. 
Alternatively you can type the name of the folder in the edit box. The value you enter here will update the 
stored property in the graph document. 

If the folder you specify does not exist, it will be created during the webification process. 

You may enter a path relative to the location of the graph document, rather than supply a full path. 
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More Properties… 
Click this button to invoke the Mail and Webify properties page for the graph (see page 160). From there 
you can specify additional properties to fine-tune the way the webified graph will appear. 

OK 
Finally, click OK to webify the graph. When the process is complete, you will be asked if you wish to 
view the output. IrriMAX will open the files using your default web browser. 

Note that, unlike the Webify Workspace feature, there is no option for automatically uploading the files to 
the Internet using FTP. 

Graph Reports Menu 
The Reports menu contains commands for generating text-format reports, based on the readings in the 
currently selected pane. 
The menu commands, equivalent shortcuts and tool buttons are: 

Menu item Shortcut 
key 

Button To... 

Graphed Values… ALT, R, V  Run the Graphed Values Report 

Cumulative Values… ALT, R, C  Run the Cumulative Values Report 

Budget Line Periods… ALT, R, B  Run the Budget Line Periods Report 

Daily Crop Water Use… ALT, R, W  Run the Daily Crop Water Use Report 

Graphed Values Report 
The Graphed Values Report outputs the values as displayed in the current pane. In the case of bar graphs, 
these values are usually different from the underlying values of the individual readings (as displayed in 
the Text Data Viewer). 

Ø  To run the Graphed Values Report 
1. If the graph window contains more than one pane, select the pane from which to run the report by 

clicking within it. 

2. Optionally create one or two vertical rulers on the graph. The first ruler will provide the initial start 
time for the report, and the second will provide the initial end time. 

3. From the Reports menu, click Graphed Values… 
The Graphed Values Report dialog appears: 
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4. Select the time range for the report by dragging the ends of the Time Range slider control, typing 
the ranges into the From and To controls, or by using the drop-down calendar pickers of the From 
and To controls. Alternatively, select the Growth Stages tab and choose the first and last growth 
stage to be included in the report. 

5. To report only on whole days, check the Whole days only checkbox. Use the days starting at 
control to enter the time you want each day period to start. In the unlikely event that you want day 
periods to start in the afternoon, use 24-hour time notation. 

6. Choose where to send the output of the report. To create a temporary file and view it in Notepad, 
select Notepad. To save the file in text format to disk, select Text File and enter the path to the text 
file. To create or update an IrriMAX database containing the output, select Database and enter the 
path to the database. 

7. Click the OK button to run the report. 

 

Cumulative Values Report 
The Cumulative Values Report is similar to the Graphed Values Report, except that it outputs the values 
displayed in the current pane as a running total. 

Ø  To run the Cumulative Values Report 
1. If the graph window contains more than one pane, select the pane from which to run the report by 

clicking within it. 

2. Optionally create one or two vertical rulers on the graph. The first ruler will provide the initial start 
time for the report, and the second will provide the initial end time. 

3. From the Reports menu, click Cumulative Values… 
The Cumulative Values Report dialog appears: 

 

4. Select the time range for the report by dragging the ends of the Time Range slider control, typing 
the ranges into the From and To controls, or by using the drop-down calendar pickers of the From 
and To controls. Alternatively, select the Growth Stages tab and choose the first and last growth 
stage to be included in the report. 

5. To report only on whole days, check the Whole days only checkbox. Use the days starting at 
control to enter the time you want each day period to start. In the unlikely event that you want day 
periods to start in the afternoon, use 24-hour time notation. 

6. Choose where to send the output of the report. To create a temporary file and view it in Notepad, 
select Notepad. To save the file in text format to disk, select Text File and enter the path to the text 
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file. To create or update an IrriMAX database containing the output, select Database and enter the 
path to the database. 

7. Click the OK button to run the report. 

 

Budget Line Periods Report 
The Budget Line Periods Report lists the amount of time the graph line spends between each pair of 
visible budget lines. A list of time ranges is output, with total time spent in each budget region expressed 
as a total and a percentage over the nominated report range. 

Ø  To run the Budget Line Periods Report 
1. If the graph window contains more than one pane, select the pane from which to run the report by 

clicking within it. 

2. Optionally create one or two vertical rulers on the graph. The first ruler will provide the initial start 
time for the report, and the second will provide the initial end time. 

3. From the Reports menu, click Budget Line Periods… 
The Budget Line Periods Report dialog appears: 

 

4. Select the time range for the report by dragging the ends of the Time Range slider control, typing 
the ranges into the From and To controls, or by using the drop-down calendar pickers of the From 
and To controls. Alternatively, select the Growth Stages tab and choose the first and last growth 
stage to be included in the report. 

5. To report only on whole days, check the Whole days only checkbox. Use the days starting at 
control to enter the time you want each day period to start. In the unlikely event that you want day 
periods to start in the afternoon, use 24-hour time notation. 

6. Choose where to send the output of the report. To create a temporary file and view it in Notepad, 
select Notepad. To save the file in text format to disk, select Text File and enter the path to the text 
file. There is no option to output this report to a database. 

7. Click the OK button to run the report. 

 

Daily Crop Water Use Report 
The Daily Crop Water Use Report attempts to give a more accurate indication of crop water use than 
simply graphing "daily negative change". It uses "negative change" during daylight hours as a starting 
point for crop water use, and uses "negative change" during night hours to estimate drainage. 
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Ø  To run the Daily Crop Water Use Report 
1. If the graph window contains more than one pane, select the pane from which to run the report by 

clicking within it. The pane must contain soil moisture values. 

2. Optionally create one or two vertical rulers on the graph. The first ruler will provide the initial start 
time for the report, and the second will provide the initial end time. 

3. From the Reports menu, click Daily Crop Water Use… 
The Daily Crop Water Use Report dialog appears: 

 

4. Select the time range for the report by dragging the ends of the Time Range slider control, typing 
the ranges into the From and To controls, or by using the drop-down calendar pickers of the From 
and To controls. Alternatively, select the Growth Stages tab and choose the first and last growth 
stage to be included in the report. 

5. Select the hours of daylight by dragging the ends of the Daylight Hours slider control or by 
clicking the up and down arrows of the controls displaying the first and last daylight hour. The 
accuracy of the report depends on setting the daylight hours correctly. It assumes that these are the 
hours during which the crop will actively extract water from the soil. 

6. If you have a database storing relevant Reference ET (ETo), you can include these values in the 
report by clicking the Select… button in the Reference ET (ETo) section. The Sensor Selection 
dialog appears and allows selection of a single sensor. See page 115. 

7. If you have a database storing relevant Crop ET (ETc), you can include these values in the report by 
clicking the Select… button in the Reference ET (ETc) section. The Sensor Selection dialog 
appears and allows selection of a single sensor. See page 115. 

8. Choose where to send the output of the report. To create a temporary file and view it in Notepad, 
select Notepad. To save the file in text format to disk, select Text File and enter the path to the text 
file. To create or update an IrriMAX database containing the output, select Database and enter the 
path to the database. 

9. Click the OK button to run the report. 
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Graph Help Menu 
The Help menu provides access to the online user guide contents and search utilities. 
The menu commands, equivalent shortcuts and tool buttons are: 

Menu item Shortcut 
key 

Button To... 

Help Topics F1 
or 
ALT, H, H 

 
Display the online help file. 

About IrriMAX... ALT, H, A 
 

Display current version information. 

Ø  To access online help 
From the Help menu, click Help Topics. 
The Help window displays. 
Click the Contents tab to scroll through a table of contents for online help. 
Click the Index tab to search for topics by using an index of keywords and phrases. 
Click the Find tab to use full-text search and look for specific words. 

Ø  To access version information about IrriMAX 
1. From the Help menu, click About IrriMAX... 

The IrriMAX about dialog box displays. 

2. Click OK to close the dialog box. 
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Text Data Viewer 
The Text Data Viewer is a facility used to view and save raw and soil moisture data, salinity data or I&R 
data in ASCII text format. The viewer does not read text files but can save the viewed data in a text file. 

Note: This feature is normally used for scientific analysis of data where data values are critical. 

From the Text Data Viewer window you can: 
• view raw and soil moisture data (per sensor or summed) from the moisture graph pane 
• view salinity raw and VIC data from the salinity graph pane 
• view irrigation and rainfall, duration and amount values (per site) from an I&R graph pane 
• use the column colors, which make different sensor data easier to distinguish 
• print the data 
• save the data to a text file. 

 
Text files are saved with a *.TXT extension. 

Warning: 
The Text Data Viewer cannot not be used to read text files, open graphs or update databases. 

Data Exchange cannot read Text Data Viewer files but it offers a more flexible method of 
exporting data in text format, which can also be reloaded into an IrriMAX database. 

Ø  To view the data in the Text Data Viewer 
On the graph, click anywhere in the pane containing the data to be viewed. Then, from the View menu, 

click Text, or press the toolbar button . 

The Text Data Viewer will display the data applicable to the active Pane. If the I&R pane is visible, and 
was the last pane you clicked in, then the I&R graph data will be displayed.  (The current pane is signified 
by the vertical axis title text being bold (e.g. Soil Water Content, salinity or I&R data). Soil moisture data 
will be displayed if the Soil moisture pane is active. 

The Text Data Viewer displays the data that corresponds to the date range currently visible in the graph. 
For example, if the graph is viewing a three-day period of data, only that data is displayed in the viewer. 

The whole database can be viewed by selecting Entire Database from the View menu.  

A Text Data Viewer showing Soil Moisture Content: 
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The Text Data Viewer window has two main sections. 

1. The text header section is static and displays: 

• the logger ID 
• last sampling interval 
• selected sites 
• crop or probe name 
• type of graph (summed or separate type, and if summed, whether the data is interpolated). 

2. The data section lists the data that constitutes the graph. It shows the time, the raw value for each 
sensor, and its calculated moisture value. 
 
There are two special kinds of moisture value, both of which appear as a break in the graph line: 

• INVALID (-1) indicates a value that cannot be graphed. These are typically inserted to cause a 
break in the graph line. They also occur if the raw value is zero, or if the Scaled Frequency (SF) 
calculation is invalid or the Spike Remover blanked or removed this reading. 

• ERROR (-2) indicates a value that could not be calculated, possibly due to a problem with the 
calibration equation for that sensor or an out-of-range condition. Unlike INVALID moisture 
values, ERROR values may be corrected by changing the calibration equation. 
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A Text Data Viewer window showing Rainfall & Irrigation data: 

 

The Rainfall Text Data Viewer window has two main sections. 

1. The text header section is static and displays:  

• the logger ID 
• selected site names and a map to the sensors in each site 

2. The data section lists the data that constitutes the graph. It shows the time, the duration and amount 
values for each sensor. 

In the above picture, I1 is the irrigation sensor for the "North Pivot" site, and R1 is the Rainfall sensor for 
the "North Pivot" site. 

Menu bar 
The Text Data Viewer menu bar contains all commands under four menu items. Each menu item contains 
commands or submenus with commands. Where available the menu commands display the shortcut keys 
that perform the equivalent command. 

Ø  To return to the Workspace Manager window from the Text Data Viewer 

Click on  in the menu bar. 

Toolbar 
The Text Data Viewer toolbar is used to quickly access major editing and viewing commands that are 
applicable to the Text Data Viewer window. The toolbar displays by default but can be hidden or 
displayed as required. 

Status bar 
The status bar at the bottom of a window displays information about the window. As you use the mouse 
to point to icons on a menu or toolbar, the name of the command being selected appears in the status bar. 
Unlike the status bars in other windows, the status bar in the Text Data Viewer cannot be hidden. 

Missing databases 
If you open the Text Data Viewer and the original database file has been removed or renamed, a message 
box displays advising that the database could not be found. Click OK to continue. See page 147 for 
details of finding missing databases. 
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Text Data Viewer window commands 
All Text Data Viewer commands are available from one of the following: 

• menus on the menu bar 
• buttons on the toolbar 
• shortcut keys on the keyboard 
• options from the shortcut menu (right-click an item in a window to see the menu in context with 

the item) 
 

Note: Not all commands are available using all methods. 

Ø  To copy the header text 
Right-click in the header section click Select All 
Type CTRL+C to copy the header contents to the Windows Clipboard from which it can be pasted to, for 
example, a word processing document. 

Note: The only shortcut menu available in the Text Data Viewer is the Windows text-editing menu. Since 
the header is a read-only section containing text you can, if required, copy all or a selected part of the 
header text to the Windows Clipboard. You cannot paste or edit the header details directly, as the 
information is stored in the database. 

Text Data Viewer File Menu 
The File menu displays file commands for the displayed text file. 
The menu commands, equivalent shortcuts and tool buttons are: 

    

Menu item Shortcut 
key 

Button To... 

Save As... ALT, F, A 
 

Save the current text file. 

Print ALT, F, P  Print the text file. 

Print Preview ALT, F, V  Preview the file as it will print. 

Page Setup... ALT, F, U  Change the current page setup. 

Close ALT, F, C  
on the 
title bar 

Close the viewer window. 

Saving data to a text file 
Data from the Text Data Viewer can be saved as a text file (*.TXT) for use in other applications that do not 
support the IrriMAX database file format. 

Warning: 
The data structure exported by Text Data Viewer cannot be reloaded into an IrriMAX database. 
It is recommended to use the functionality in Data Exchange to select a destination of Comma 

Separated Values (csv) or Microsoft Excel spreadsheet (xls). 

What am I saving? 
You can choose what to save in the text file. You can include the following information in the file: 

• logger details as shown in the header section 
• all data records that correspond to the displayed section of the graph (in the Graph window) 
• all data records from the database if viewing the entire database 
• selected data records (rows), contiguous or non-contiguous. 

Note: To select multiple data rows press and hold the ctrl key and left-click each row. To select 
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multiple adjacent rows, select the first row in the list, press and hold the SHIFT key and select the 
last file in the list. 

 

Ø  To save data as text 
1. From the File menu, click Save As.... 

The Save As dialog box displays. 

 

2. Select a file location for the file. 

3. Enter a file name for the new file. 

4. Select one or more of the following as required: 

• Output Logger Information to include the header information 
• Align Columns Evenly to make the text file easier to view 
• Output only highlighted rows to save only the selected rows in the Text Data Viewer 
• Column Delimiter as a space, comma or semicolon as required. 

5. Click Save. 
The text file is saved.  

Printing data from the Text Data Viewer 
Text data can be printed from the Text Data Viewer window. You may print a text data in color or black 
and white. 

Warning: 
Some color printers are unable to print in colors other than the standard Windows colors. If this 

occurs, remove any custom colors being used to define text data sets. 

Before you print, you should check that the page setup is correct for the document being printed. The 
Page Setup command is used to control how the document is printed on the page. For example, to set 
whether the document is printed in portrait or landscape orientation. 

The Print Preview command displays the current file, as it would appear when printed. Using the Print 
Preview command, you can ensure that margin, printer settings and selected content are correct, before 
sending the information to the printer. 
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Ø  To change page setup in Text Data Viewer 
1. From the File menu, click Page Setup.... 

The Page Setup dialog box displays. 

2. Under Paper, select from the drop-down lists: 

• the required paper size 
• the paper source 

3. Under Orientation, select either Portrait or Landscape. 

4. Under Margins, enter any special requirements for margins. 
Note how the sample page reflects these changes. 

5. Click OK to save the changes and close the Page Setup dialog box. 

 

Ø  To view a text file in print preview 
1. From the File menu, click Print Preview. 

The Print Preview window displays. 

2. From the Print Preview window toolbar you can: 

 
Click... To... 

 
send the file in its current state to the printer. 

 
display the second page of the file where the file has more than one page. 

 
display the previous page of a file where you are on a page other than the first page. 

 
display one page of the file, where the file has more than one page. 

 
display two pages of the file simultaneously, where the file has more than one page. 

 
enlarge a specific area of the file. 

 
minimize the view of a specific area of the file. 

 
close the print preview window. 

 

Ø  To print a text data file 
1. From the File menu, click Print.... 

The Print dialog box displays. 
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2. Under Print range, select to print all records in the viewer or just the selected records. 

3. Under Appearance, select if you want to print the text using the colors in the viewer. 

4. Under Copies, select the number of copies you want to print. 

5. Click OK. 
The layout is sent to the printer. 

 

Ø  To print to a printer file 
1. From the File menu, click Print.... 

The Print dialog box displays. 

2. Click the Print to file option. 

3. Click OK. 
The Print to File dialog box displays. 

4. Select a destination for the file. 

5. Enter a file name. Printer files have a file extension of *.PRN. 

6. Click Save to save the layout printer file. 

Closing the text data viewer window 
You can close the Text Data Viewer at any time. 

Ø  To close the Text Data Viewer 
From the File menu click Close.  
The Text Data Viewer closes. 

Text Data Viewer View Menu 
From the View menu you can select the toolbar, view an entire database or view sensors in different 
colors so that they are easily distinguished on the report. 
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The toolbar is used to quickly access commands that are applicable to the window. The toolbar displays 
by default but can be hidden or displayed as required. 

What am I viewing? 
When you open the Text Data Viewer from the Graph window, only the data visible in the graph window 
is shown in the viewer. For example, if you zoom to a smaller time period in the horizontal axis of the 
graph, fewer data records display in the viewer. You can use the Graph window zoom and scroll features 
to select the specific period that you want to send to the viewer. Once the viewer is open, you can still 
choose to include all data from the source database. 

Viewing sensors in different colors makes it easier to distinguish between multiple columns. The column 
colors are the same as the graph line settings. 

The columns in the Text Data Viewer window can be sized manually using the mouse or automatically 
using the menu paths or toolbar buttons. The column-sizing feature is provided to make it easier to view 
multiple columns. 

Ø  To display the toolbar 
From the View menu, click Toolbar. 
The toolbar displays. 

Ø  To view an entire database 
From the View menu, click Entire Database. 
All data in the database is displayed. 

Ø  To view sensors in color or black & white 
From the View menu, click Sensor Colors. 
When Sensor colors is checked the data is displayed in color, when clear the text is in black and white 

Ø  To compact columns 
From the View menu, click Compact Columns. 
Each column contracts to a minimum required width to show the values without stripping them, to display 
more columns. 

Ø  To expand columns 
From the View menu, click Expand Columns. 
Each column expands to fit both the data as well as the column header width. 

Webify Template Reference 
IrriMAX generates Web-compatible files by performing text-substitution into pre-defined templates. The 
templates contain all the HTML code for displaying the graph or workspace in an Internet Browser, with 
placeholders for the graph-specific and workspace-specific information. These placeholders are called 
macros.  

In addition to macros, templates also contain directives. Directives are additional instructions to IrriMAX 
that are required to correctly interpret the template. They take the form of special HTML comments. 

If the user does not choose a specific template, then IrriMAX will use WORKSPACE.HTML and 
GRAPH.HTML, which can be found within the Templates folder in the IrriMAX installation folder. 

Workspace-Specific Directives 
The following directives are recognized only when part of a workspace template. They will be ignored if 
included in a graph template. 
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<!--FOR_EACH_GRAPH--> … <!--/FOR_EACH_GRAPH--> 
These directives are used to mark the start and the end of a section of the workspace template that is to be 
repeated for each graph in the workspace. There can be only one such section in the template. 

The graph-specific macros and directives only have meaning within these directives. They will be ignored 
if they appear outside the section. 

<!--GAUGE_SIZE:40,100--> 
Include this directive to specify a size for the "fuel-gauge" images that represent the last reading in the 
database. This example specifies an image 40 pixels wide by 100 pixels high. Substitute your own values 
to create larger or smaller images. 

<!--THUMB_SIZE:140,100--> 
Include this directive to specify a size for the thumbnail images that represent each graph. This example 
specifies an image 140 pixels wide by 100 pixels high. Substitute your own values to create larger or 
smaller images. 

Workspace-Specific Macros 
The following macros are unique to the workspace template. With the exceptions of 
WORKSPACE_COMMENT_TEXT and WORKSPACE_ZIP_LINK, they all relate to a specific 
graph and therefore must appear within a FOR_EACH_GRAPH section. 

GRAPH_DESCRIPTION_TEXT 
This macro is replaced by a description of the logger, sites and probes of the current graph. 

GRAPH_GAUGE_LINK 
If this macro is present, IrriMAX will create a picture representing the value of the last reading in the 
database in relation to the agronomic regions of a summed graph. The macro is replaced by the file name 
of the generated picture. 

The default size for the picture is 780 pixels wide by 350 pixels high. A different size can be specified by 
using the GRAPH_SIZE directive. 

When used in a workspace template, it must be within the <!--FOR_EACH_GRAPH> section 

GRAPH_LINK 
This macro is replaced by the filename of the generated web page that represents the current graph. If the 
macro is not present, graph pages will not be generated. 

GRAPH_THUMBNAIL_LINK 
If this macro is present, IrriMAX will create a small "thumbnail" picture representing the graph  The 
macro is replaced by the filename of the generated picture. 

The default size for the picture is 40 pixels wide by 100 pixels high. A different size can be specified by 
using the THUMB_SIZE directive. 

GRAPH_TYPE_TEXT 
This macro is replaced by a description of the type of graph (e.g. summed, stacked) and the type of data 
stored in any additional graph panes (e.g. V.I.C., I & R). 

WORKSPACE_COMMENT_TEXT 
This macro is replaced by the comment field in the workspace properties. 
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WORKSPACE_PACKAGE_LINK 
If this macro is present, all files referenced by the workspace will be added to an IrriMAX Package 
(.imxpak) file. The macro is replaced by the filename of the package file. 

WORKSPACE_ZIP_LINK 
If this macro is present, all files referenced by the workspace will be added to a ZIP file. The macro is 
replaced by the filename of the ZIP file. 

Graph and Workspace Directives 
The following directives can be used in both the workspace and the graph templates. 

<!--FOR_EACH_LINE--> … <!--/FOR_EACH_LINE--> 
These directives are used to mark the start and the end of a section of the template that is to be repeated 
for each line in the current pane. There can be only one such section in the template. 

These directives must appear within a FOR_EACH_PANE section. 

<!--FOR_EACH_PANE--> … <!--/FOR_EACH_PANE--> 
These directives are used to mark the start and the end of a section of the template that is to be repeated 
for each pane in the graph. There can be only one such section in the template. 

If these directives are used on a workspace template, they must appear within a FOR_EACH_GRAPH 
section. 

<!--GRAPH_SIZE:780,350--> 
Include this directive to specify a size for the images that contain the graphical component of each graph 
in the workspace. This example specifies an image 780 pixels wide by 350 pixels high. Substitute your 
own values to create larger or smaller images. 

If this directive is included it overrides the "Graphic Dimensions" properties of the graph and the 
workspace documents in IrriMAX. 

Graph and Workspace Macros 
The following macros can be used in both the workspace and graph templates. Those whose names start 
with GRAPH_ are specific to an individual graph, and so must appear within a FOR_EACH_GRAPH 
section if used in a workspace template. 

GENERATION_DATE 
This macro is replaced by the date on which the web files were generated. 

GENERATION_TIME 
This macro is replaced by the time at which the web files were generated. 

GRAPH_COMMENT_TEXT 
This macro is replaced by the user-entered comment from the graph. 

GRAPH_DOWNLOAD_TEXT 
This macro is replaced by the date and time of the last download from the logger to the database in the 
primary pane of the graph. 
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GRAPH_LOGGER_TEXT 
This macro is replaced by the Logger ID from the database in the primary pane of the graph. 

GRAPH_NAME_TEXT 
This macro is replaced by the name of the graph. 

GRAPH_PACKAGE_LINK 
If this macro is present, all files referenced by the graph will be added to an IrriMAX Package (.imxpak) 
file. The macro is replaced by the filename of the package file. 

GRAPH_PIC_HEIGHT 
This macro is replaced by a number representing the height of the graph picture in pixels. 

GRAPH_PIC_LINK 
If this macro is present, IrriMAX will create a picture representing the graph. The macro is replaced by 
the file name of the picture. 

GRAPH_PIC_WIDTH 
This macro is replaced by a number representing the width of the graph picture in pixels. 

GRAPH_ZIP_LINK 
If this macro is present, all files referenced by the graph will be added to a ZIP file. The macro is replaced 
by the filename of the ZIP file. 

LINE_COLOR_TEXT 
This macro is replaced by a hexadecimal number representing the color of the current line (sensor). It 
must appear within a FOR_EACH_LINE section. 

LINE_NAME_TEXT 
This macro is replaced by the name of the current line (sensor). It must appear within a 
FOR_EACH_LINE section. 

MESSAGE_TEXT 
This macro is replaced by a message typed by the user when a graph is emailed. 

PANE_NAME_TEXT 
This macro is replaced by the name of the current pane. It must appear within a FOR_EACH_PANE 
section. 

WORKSPACE_NAME_TEXT 
This macro is replaced by the name of the workspace. 

Graph-Specific Macros 
The following macros are unique to the graph template. 
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<!--IF_NO_WORKSPACE--> ... <!--/IF_NO_WORKSPACE--> 
These directives are used to mark the start and end of a section of the graph template that is only included 
if the graph is stand-alone. The section will only be included if the user chose Webify Graph… from the 
graph window. 

<!--IF_WORKSPACE--> … <!--/IF_WORKSPACE--> 
These directives are used to mark the start and end of a section of the graph template that is only included 
if the graph is part of a workspace. The section will be ignored if the user chose Webify Graph… from 
the graph window. 

GRAPH_NEXT_LINK 
This macro is replaced by the filename of the next graph in the workspace. It has no meaning if the user 
chose Webify Graph… from the graph window, and therefore should appear within an 
IF_WORKSPACE section of the template. 

GRAPH_PREV_LINK 
This macro is replaced by the filename of the previous graph in the workspace. It has no meaning if the 
user chose Webify Graph… from the graph window, and therefore should appear within an 
IF_WORKSPACE section of the template. 

WORKSPACE_LINK 
This macro is replaced by the filename of the workspace page. It has no meaning if the user chose 
Webify Graph… from the graph window, and therefore should appear within an IF_WORKSPACE 
section of the template. 
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Troubleshooting 
This section covers error message and how to interpret them for the following areas:. 

• Troubleshooting Workspace Manager 
• Troubleshooting layouts 
• Troubleshooting graphs 
• Troubleshooting the Text Data Viewer 
• Troubleshooting logger configurations 
• Troubleshooting Registration and Licensing 

 

Troubleshooting Workspace Manager 
The following error and warning messages display under the conditions described. 

Message Meaning/Action 

'Error reading file [file name] 
[error description]' 

This error means that either the file is corrupt or truncated, or there is a 
hardware error (rare). You should restore the file from a backup. 

  

'Error writing file [file name] 
[error description]' 

This error will only occur if there is no more disk space or there is a hardware 
error (rare). You should check to see if you have run out of space, and remove 
unwanted files (e.g. empty Recycle Bin). You can then try to save the file 
again. 

  

'Error opening file [file name] 
[error description]' 

This message could mean that the file does not exist, or that another process has 
an exclusive lock on it. In the first case you should try to find and restore the 
file. In the second case, you can close any windows that may be accessing the 
file and try again. In a network situation, you may need to find the other user 
who is accessing the file, or simply try again later. 

  

'There is no default printer. 
To install and detect a default 
printer, open the Start button, 
choose Settings, select Printer and 
then select Add Printer.' 

This message displays when you are trying to print from the Workspace 
Manager window and there is no printer installed. You need to install your 
printer in accordance with the instructions from the manufacturer. 

  
 

Troubleshooting layouts 
The following error and warning messages display under the conditions described. 

Message Meaning/Action 

'Error reading file [file name] 
[error description]' 

This error means that either the file is corrupt or truncated, or there is a 
hardware error (rare). You should restore the file from a backup. 

  

'Error writing file [file name] 
[error description]' 

This error will only occur if there is no more disk space or there is a hardware 
error (rare). You should check to see if you have run out of space, and remove 
unwanted files (e.g. empty Recycle Bin). You can then try to save the file 
again. 
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Message Meaning/Action 

'Error opening file [file name] 
[error description]' 

This message could mean that the file does not exist, or that another process 
has an exclusive lock on it. In the first case you should try to find and restore 
the file. In the second case, you can close any windows that may be accessing 
the file and try again. In a network situation, you may need to find the other 
user who is accessing the file, or simply try again later. 

  

'The document will be printed very 
small. You may wish to change 
page orientation and margins, or 
alter your layout to cover a smaller 
area. 
Do you wish to continue printing?' 

This message displays in the Layout window when printing a layout whose 
elements will probably be illegibly small after it is scaled to fit the page. This 
will happen if the page margins are set too wide, or the loggers and sites are 
placed very far apart on the layout. You can use the print preview feature to 
verify that the layout will be printed as you expect. Adjust the page setup or 
layout, or click Yes to continue. 

  

'Calibration change detected! 
The following databases contain 
calibrations which differ from those 
in the registry with the same name: 
[filename]' 

This message displays when opening a layout file, and the listed databases are 
detected to be using one or more calibrations that differ from calibrations in the 
calibration registry with the same name. This may happen if you have updated 
a calibration in the registry since the database was created. To bring the 
database up to date, you can use the Logger Configuration dialog box to change 
the calibrations for the affected sensors to the calibrations in the registry. 
Another possibility is that you have two distinct calibrations that share the 
same name. You can use the Logger Configuration and Calibration Registry 
dialog boxes to edit the unregistered calibration, change its name and register 
it, then select it into the affected sensors.  

  

'When creating a summed graph, the 
sensor depths selected must be the 
same across all probes that have 
sensors selected. ' 

This message displays in the Layout window when you are creating a summed 
graph and select sensors from multiple probes in the Site Selection window. 
The selected probes use different depths. Either de-select the sensors that are a 
different depth and causing a conflict or correct the logger configuration before 
creating a summed graph. 

  

'Cannot create graph 
More than 8 sensors are selected' 

This message displays in the Layout window when you select a Separate Y 
graph to be generated from a selection of more than 8 sensors, in the Sensor 
Selection dialog. Click OK to continue. Re-select the sensors ensuring eight or 
less are chosen before clicking the Separate Y graph button. 

  

'Cannot create graph 
No sensors are selected' 

This message displays in the Layout window when you select a graph to be 
generated but no sensors have been selected, in the Sensor Selection dialog. 
Click OK to continue. Select the sensors to be graphed then click the graph 
type again. 

  

'Cannot create graph 
More than 16 sensors are selected' 

This message displays in the Layout window when you select a Common Y or 
Stacked graph to be generated from a selection of more than 16 sensors, in the 
Sensor Selection dialog. Click OK to continue. Re-select the sensors ensuring 
sixteen or less are chosen before clicking the Separate Y graph button. 

Troubleshooting graphs 
The following error and warning messages display under the conditions described. 

Message Meaning/Action 

'Error reading file [file name] 
[error description]' 

This error means that either the file is corrupt or truncated, or there is a 
hardware error (rare). You should restore the file from a backup. 
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Message Meaning/Action 

'Error writing file [file name] 
[error description]' 

This error will only occur if there is no more disk space or there is a hardware 
error (rare). You should check to see if you have run out of space, and remove 
unwanted files (e.g. empty Recycle Bin). You can then try to save the file 
again. 

  

'Error opening file [file name] 
[error description]' 

This message could mean that the file does not exist, or that another process 
has an exclusive lock on it. In the first case you should try to find and restore 
the file. In the second case, you can close any windows that may be accessing 
the file and try again. In a network situation, you may need to find the other 
user who is accessing the file, or simply try again later. 

  

'Interpolation is only allowed for a 
range of depths if all available 
sensors in the range are selected.' 

This message displays in the Graph window when interpolation is selected but 
the full range of available sensors between the shallowest and deepest sensor 
was not used to generate the graph. The missing value may actually exist in 
the readings. The graph needs to be regenerated from the layout window, 
selecting all available sensors, between the shallowest and deepest sensor, 
from the Sensor Selection dialog. 

  

'The following Database was not 
found: [filename] 
Press Browse to locate the missing 
Database or Press Cancel to abort 
the current operation.' 

This message displays in the Graph window when a database has gone 
missing. The database may have been moved or renamed. Click Browse and 
locate the missing database file or click Cancel to stop the operation. 

  

'Error reading file [file path] 
Graph was not created from this 
database' 

This message displays in the Graph window when a database has gone 
missing. While browsing for the correct location of the database, you have 
attempted to open and connect to the wrong database. 

  

'There are no readings in database 
[database name]' 

This message is displayed when the database is empty. To produce a graph 
you need at least one reading. Download data from the logger or select a 
database with sufficient data to generate a graph. 

Troubleshooting the Text Data Viewer 
The following error and warning messages display under the conditions described. 

Message Meaning/Action 

'Error reading file [file name] 
[error description]' 

This error means that either the file is corrupt or truncated, or there is a 
hardware error (rare). You should restore the file from a backup. 

  

'Error writing file [file name] 
[error description]' 

This error will only occur if there is no more disk space or there is a hardware 
error (rare). You should check to see if you have run out of space, and remove 
unwanted files (e.g. empty Recycle Bin). You can then try to save the file 
again. 

  

'Error opening file [file name] 
[error description]' 

This message could mean that the file does not exist, or that another process has 
an exclusive lock on it. In the first case you should try to find and restore the 
file. In the second case, you can close any windows that may be accessing the 
file and try again. In a network situation, you may need to find the other user 
who is accessing the file, or simply try again later. 
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Message Meaning/Action 

'Column exceeds paper width. 
Try using smaller margins.' 

Adjust the column margins or the page setup and try printing again. 

Troubleshooting logger configurations 
The following error and warning messages display under the conditions described. 

Message Meaning/Action 

Logger Configuration   

'Error reading file [file name] 
[error description]' 

This error means that either the file is corrupt or truncated, or there is a 
hardware error (rare). You should restore the file from a backup. 

  

'Error writing file [file name] 
[error description]' 

This error will only occur if there is no more disk space or there is a hardware 
error (rare). You should check to see if you have run out of space, and remove 
unwanted files (e.g. empty Recycle Bin). You can then try to save the file 
again. 

  

'Error opening file [file name] 
[error description]' 

This message could mean that the file does not exist, or that another process has 
an exclusive lock on it. In the first case you should try to find and restore the 
file. In the second case, you can close any windows that may be accessing the 
file and try again. In a network situation, you may need to find the other user 
who is accessing the file, or simply try again later. See What are the database 
file access rules for details about Sentek database files. 

  

'Operation causes a sensor address 
to exceed the permitted range. The 
maximum valid address on Run A 
or Run B is 16.' 

This message displays in the Logger Configuration dialog box. This error has 
two possible causes: 

• You tried to add more than 16 sensors to a single run of the logger 
configuration. Click OK to continue. 

 
• You have altered a sensor address that causes the last address in the run 

to exceed 16. Click OK to continue and change the address to a lower 
number or start a new sequence beginning at B1. 

  

'Operation causes a sensor address 
conflict.' 

This message displays in the Logger Configuration dialog box when two sensors 
have the same address. Click OK to continue and provide unique address to all 
sensors. 

  

'A site already exists with that 
name.' 

This message displays in the Logger Configuration dialog box when two sites 
have been given identical names. Site names are case sensitive and must be 
unique. Click OK to continue and correct the duplicate name. 

  

'A probe already exists with that 
name.' 

This message displays in the Logger Configuration dialog box when two probes 
have been given identical names. Probe names are case sensitive and must be 
unique. Click OK to continue and correct the duplicate name. 

  

'The entered value causes an 
address conflict. 
Please re-enter the address.' 

This message displays in the Logger Configuration dialog box when two sensors 
have been given identical addresses. Click OK to continue and correct the 
duplicate address. 
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Message Meaning/Action 

'The ID must contain at least one 
character. Please type in a valid ID.' 

This message displays in the Logger Configuration dialog box when the name of 
a logger, site or probe has been deleted. Click OK to continue and enter a valid 
name. 

  

'The logger has no sites attached.' This message displays in the Logger Configuration dialog box when trying to 
save a logger that has no sites attached. A logger must have a site, probe and 
sensor to be valid. Click OK to continue and add a site, probe and sensor. 

  

'A site has no probes attached.' This message displays in the Logger Configuration dialog box when trying to 
save a logger that has no probes attached. A logger must have a site, probe and 
sensor to be valid. Click OK to continue and add a site, probe and sensor. 

  

'A probe has no sensors attached.' This message displays in the Logger Configuration dialog box when trying to 
save a logger that has no sensors attached. A logger must have a site, probe and 
sensor to be valid. Click OK to continue and add a site, probe and sensor. 

  

'The addresses on Run A are non-
consecutive.' 

This message displays in the Logger Configuration dialog box when there is a 
gap in the sensor address sequence on Run A. Click OK to continue and correct 
the addressing. 

  

'The addresses on Run B are non-
consecutive.' 

This message displays in the Logger Configuration dialog box when there is a 
gap in the sensor address sequence on Run B. Click OK to continue and correct 
the addressing. 

  

'This database contains one or more 
calibrations, which do not exist in 
the calibration registry. You can 
add them to the registry by clicking 
'Calibrations...', highlighting them 
and clicking 'Change' then 'Accept'.' 

This message displays in the Layout window when a database is opened that has 
at least one calibration equation that does not exist in the calibration registry. 
These calibrations can be added to your calibration registry as required. Click 
OK to continue. To add the new calibrations to the calibration registry, click 
Calibrations.... Highlight the calibrations to be added. Click Change. Click 
Accept. The new calibrations will be added to the calibration registry. 

This could occur if, for example you have deleted the calibration from the 
registry or you have used a database configured on another computer. 

  

'The maximum number of sensors 
has been reached.' 

This message displays in the Logger Configuration dialog box when you try to 
add another sensor to a probe when there are already a maximum number of 
sensors on that probe. This maximum may be on the probe, site or logger. Click 
OK to continue. See page 91 for details of configuring a logger. 

  

'The air count must be greater than 
the water count' 

This message displays in the Logger Configuration dialog box when 
normalizing air and water counts. This error may display: 

• when entering normalization counts manually 
• the sensor being normalized is not attached to the computer  
• the sensor has got wet 

Click OK to continue and provide a new reading that is greater than the water 
reading. 

  

'The database is currently in use. 
You will not be able to make 
changes until it is released.' 

This message displays in the Logger Configuration dialog box when database 
information is being displayed in layouts and graphs or the database is open in 
Database Manager. Click OK to continue. Close all files using the database 
you wish to edit before proceeding. 
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Message Meaning/Action 

  

Send to Logger  

'COM port open operation failed' This message is displayed in the Connect to Logger dialog box when a 
connection attempt has been made and has failed. Click OK to continue and 
check the physical connections. See communication for details on why logger 
communication may fail. 

  

'COM port write operation failed' This message is displayed in the Connect to Logger dialog box when a 
connection to the logger has been lost. Click OK to continue and check the 
physical connections.  

  

'Logger response timeout - logger 
reply not received within the 
specified time' 

This message is displayed in the Connect to Logger dialog box when a 
connection attempt has taken too long. Click OK to continue and check the 
physical connections.  

  

'Logger's internal data structures 
corrupt' 

This message is displayed in the Connect to Logger dialog box when the 
logger's memory has errors. Click OK to continue. See Data Exchange User 
Guide for further details. 

  

'Could not find logger 
communication driver:' 

This message is displayed in the Connect to Logger dialog box when the logger 
driver could not be found. You will need to re-install the software to correct 
this problem. Click OK to continue.  

  

'Could not open port:' This message is displayed in the Connect to Logger dialog box when a 
connection to the logger could not be established and the reason is unclear. 
Click OK to continue.  

  

'Could not open logger:' This message is displayed in the Connect to Logger dialog box when a 
connection has been made with the logger but information exchange is not 
occurring. Click OK to continue. 

  

'Logger communication failed:' This message is displayed in the Connect to Logger dialog box when an attempt 
to connect to the logger has failed and the reason is unclear. The logger Id in 
the logger may not match the Logger Id name in the database. Click OK to 
continue.  

  

'Could not initialize COM library' A problem occurred loading the logger driver software.  

Reinstall IrriMAX and try again. 

  

'Could not create logger driver 
instance [error description]'' 

A problem occurred initializing the logger driver software. 

If the error description is REGDB_E_CLASSNOTREG, you did not restart 
your computer after installing IrriMAX. If restarting you computer does not 
resolve the problem, you must uninstall and reinstall IrriMAX. 

  

'Could not close logger'  The connection to the logger could not be closed. 
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Message Meaning/Action 

'Error getting <parameter>' 
'Error setting <parameter>' 

General logger error messages will report the action that failed e.g. 'Error 
getting logger clock time' and additional diagnostic values related to the failure. 

  

Calibration Registry  

'At least one item in this edit is 
incomplete or has invalid value. 
Please ensure that all required items 
have been filled in properly.' 

This message displays in the Calibration Registry dialog box when one or more 
of the mandatory fields are left blank. Click OK to continue and complete all 
boxes marked with an asterisk (*). 

  

'Calibration with this name already 
exists. 
Use different name.' 

This message displays in the Calibration Registry dialog box when you try to 
add a calibration to the calibration registry with the same name as one that is 
already registered. Click OK to continue. To add the calibration equation, 
provide a unique name for the equation. 

  

'Calibrations are being edited by 
another process. You will not be 
able to make changes until that 
process has unlocked the calibration 
file.' 

This message displays in the Calibration Registry dialog box when a calibration 
equation is being edited elsewhere, for example in the Database Manager 
utility. Click OK to continue and close down all files using that calibration 
equation before making changes. 

  

'There are one or more unregistered 
calibrations, which may be lost if 
you exit now. To save them in the 
calibration registry, click 'No' then 
'Calibrations...'. Highlight the 
calibrations to save, and click the 
'Change' and 'Accept' buttons. 
Do you wish to exit and possibly 
lose unregistered calibrations?' 

This message may be displayed in the Logger Configuration dialog box when 
you attempt to exit after changing one or more calibrations in the database. It is 
a warning that you have replaced one or more calibrations, and these 
calibrations are no longer stored in the database or in the calibration registry, 
and will therefore be lost. Click Yes to close the Logger Configuration dialog 
box without saving the calibrations or follow the instructions in the message. 

If you want to save the calibration but don't want to use it in the database, you 
must register it in the Calibration Registry. 

Click Yes to close the calibration registry dialog box without saving the 
calibrations or following the instruction in the message. 

Troubleshooting Registration and Licensing 
Unitl you are fully licensed, or after an upgrade the status of your IrriMAX license will be shown on the 
Registration & Licensing dialog. During a trial or if the license is corrupt the dialog will automatically 
apprear at IrriMAX startup. 
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Warning: 
The license manager installs some special files in the IrriMAX program directory and if these 

files are tampered with IrriMAX license management will block the software from working. You 
must then apply for a new registration site key by supplying the new site code. 

The license management files have a file attribute of "System" and must not be moved from the location 
on the disk where they were created.  

They will never move with normal Windows operations but some disk defragmentation programs are 
known to move system files. Please configure your disk defragmenter to exclude the following files: 

• IrriMAX.ent 
• IrriMAX.key 
• IrriMAX.rst 
• IrriMAX.41s 
• C:\Windows\System32\esnecil.ind 

 
A summary of the messages that may appear on this dialog is given below. If the action taken does not 
resolve your problem the file IrriMAX.ckn is needed to help to resolve the problem. This file is store in 
the folder (directory) where IrriMAX was installed e.g. C:\Program Files\Sentek\IrriMAX\IrriMAX.ckn. 

Please close all programs and restart your computer. If the problem persists and the table below does not 
describe the problem, please contact you distributor or Sentek Registrations Department. Re-registering 
with the new site code should resolve the problem. 

Message Reason Action 

The entered site key cannot be 
confirmed. [<reason> ] 

1. Invalid site key 

OR 

 

1. You may have mistyped the site 
key. Check that it is the same as the 
one that you received from Sentek 
Registration department. 

 2. The site code was generated 
before the pre-registration 
period expired, but it has now 
expired. 

2. You must click Register Now to 
get another site key from Sentek. 

Authorization time too early The computer's clock has been 
set back, possibly in an attempt 
to extend the pre-registration 
period. 

Click Register Now to get a new site 
key from Sentek. 

Clock change - reboot to 
activate time license 

The system clock date or time 
has been modified, possible by a 
scheduled time 
resynchronization  process 

Close all programs and restart the 
computer. 

No list file found A backup copy of the disk 
image containing IrriMAX may 
have been used 

Click Register Now to get a new site 
key from Sentek. 

Site key file has been moved 
OR 

Program moved or site key 
bad password 

The directory where IrriMAX 
was installed may have been 
relocated. The license manager 
checks the physical location on 
the hard disk to prevent 
unauthorized copies of 
IrriMAX. 

Click Register Now to get a new site 
key from Sentek.  
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Restriction file moved This can occur if the physical 
position of license manger files 
is changed. Some disk 
defragmentation programs and 
disk performance management 
utilities may move hidden-
system files. 

Check if there are disk management 
tools on your computer. See 
Registration and Licensing for 
information and guidance for license 
management files. 

Click Register Now to get a new site 
key from Sentek. 
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Frequently asked questions 
This section covers common questions and suggested answers: 

• Questions about superseded Sentek software 

• Questions about logger configuration rules 
• Questions about changing logger configurations 
• Questions about logging (sampling) intervals 
• Questions about logger memory and downloading 
• Questions about logger and computer time 
• Questions about rectifying logger setup errors 
• Questions about sensor configuration 
• Questions about calibrations 
• Questions about circling loggers/probes between multiple sites 
• Questions about copying workspaces and files 
• What can you do with the Summed Graph? 
• What is Matric Potential 
• What soil volume does a single sensor measure? 
• What are the water units? 
• What parts of the soil profile do sensors on the probe measure? 
• What will be summed? 

• Checking current soil moisture 
• What are the database file access rules 
• What is involved in logger communication  
• How to register IrriMAX 
• How to transfer a license from one copy of IrriMAX to another 

Questions about superseded Sentek software 
Question: Can I convert my old EnviroSCAN 2.0 (ES2) data to run on IrriMAX software? 
Answer: Yes, using the Database Converter utility. 
EnviroSCAN 4.0 and EnviroSCAN 4.1 databases are directly compatible with IrriMAX. 

Question: Can EnviroSCAN 4 use IrriMAX databases, graphs and layouts? 
Answer: No - except EnviroSCAN can recognize IrriMAX 5 database and graphs that do not have the 
Irrigation & rainfall pane displayed. EnviroSCAN does not access I&R databases (.wdb). 

Question: Can I run dual IrriMAX and EnviroSCAN for Windows ESW on one computer? 
Answer: Sentek does not support dual installation. Installing IrriMAX will overwrite EnviroSCAN 
program files. Installing the latest IrriMAX will overwrite earlier IrriMAX program files. 

Question: Can IrriMAX 5 and earlier read IrriMAX 6 and IrriMAX 7 files? 
Answer: Databases and graphs created by IrriMAX 6 or and IrriMAX 7 cannot be read by IrriMAX 5 or 
EnviroSCAN for Windows 4.x. IrriMAX issues a warning before saving IrriMAX 5 and ESW files in the 
latest IrriMAX format. A Sentek Technical Brief describes the procedure to convert IrriMAX 6 SDB files 
to IrriMAX 5 format. 

IrriMAX 6 cannot read graphs saved by IrriMAX 7. 

Questions about logger configuration rules 
Question: How many sensors can I have on an RT6 logger? 
Answer: Up to 32 sensors in two cable runs of 16 sensors. 

Question: How many probes can I have on 1 logger? 
Answer: Up to 8 probes. 
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Question: How many sites can I have on 1 logger? 
Answer: Up to 8 sites. 

Question: How many sensors can I have on a cable run? 
Answer: Up to 16 sensors. 

Question: How many sensors can I have on a probe? 
Answer: Up to 16 sensors. 

Question: How many sites, probes and sensors can I have on a type "Other" logger?  
Answer: Up to 16 sites, 99 probes and 999 sensors, in any combination. 

Questions about changing logger configurations 
Question: How do I change the logger ID? 
Answer: Download any existing data on the logger that you wish to save. Use the Logger Configuration 
dialog box (accessible from either Database Manager or the Workspace Manager window) for editing 
the logger configuration for the pertinent database. Send the edited configuration to the logger. This resets 
the logger's memory and establishes a new file. 

Question: What happens if I change the logger ID? 
Answer: If you have changed the logger ID and saved it you have created a new database. In most cases 
you should download or reset the logger memory before changing logger ID. Any data logged under the 
previous ID will be deleted from the logger upon sending the modified configuration to the logger. 

Question: How do I change the site ID? 
Answer: There are two situations where you may wish to change site IDs. 

• To change incorrect site ID - where you wish to simply rename existing site names and keep all 
data belonging to the sites with these new names attached. 

• To create a new database while retaining normalization data - this could occur where you wish to 
move the system in its current configuration to a new location. A new logger ID is required in this 
situation. 

• In Database Manager, use the Edit DB command to change the ID and save the changes in the 
database file. 

 
Question: What happens if I change the site ID? 
Answer: 

• Option 1-You have renamed the sites, keeping the original configuration of sensors and probes. 
• Option 2-You have created a new database requiring a new logger ID. 

Questions about logging (sampling) intervals 
Question: How do I change the sampling interval? 
Answer:  

• From the Logger Configuration dialog box, click the Send to Logger button. The sampling 
interval is displayed. 

• Use Logger Manager utility to change the sampling interval 
 

Question: What happens if I change the sampling interval? 
Answer: You will notice smoother or more stepped graph shapes in the displayed data after the sampling 
interval is changed. Also with shorter sampling intervals the database file size will grow faster. 

Question: What is the shortest time interval I can log? 
Answer: 1 minute. 

Question: What is the longest time interval I can log? 
Answer: 9999 minutes (6.9 days) 
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Questions about logger memory and downloading 
Question: How long will the logger hold data when removed from the logging housing? 
Answer: 2 days 

Question: How long does it take for the logger memory to fill up? 
Answer: It depends on the number of sensors the customer has installed and the logging interval. The 
days = 69.44 multiplied by (Sampling interval (minutes) / the number of sensors). 

Questions about logger and computer time 
Question: How do I change a logger's date/time? 
Answer: The logger time can be synchronized to the computer clock or the logger time can be manually 
adjusted. 

Question: What happens if I change a logger's date/time? 
Answer: You will notice a gap equivalent to the change in time or you will loose data for the period the 
time is changed right after clock adjustment depending whether the logger's clock has been set forward or 
backward. 

Question: What happens if I download a logger where there is a time difference between the logger and 
the computer clock time? 
Answer: Nothing will happen. The readings in the logger are time stamped by the logger. The software 
uses the reading timestamps (created by logger) for all the data processing. There is absolutely no relation 
between the logger's clock and the computer clock. The only time when the computer clock is important 
is when synchronizing logger time with computer clock.  

Questions about rectifying logger setup errors 
Question: What happens if I mix up loggers when downloading in the office? 
Answer: There will not be a problem where the loggers have different logger IDs and/or different 
numbers of sensors. The software compares the logger ID and the number of sensors on the logger with 
the logger's ID and the number of sensors in the database. Where there is no match an error message will 
appear preventing download. If there is a match download to the matching database will occur. 

There will be a problem where different loggers have the same logger ID and number of sensors. The 
download will proceed, writing data to the database. To minimize the chance of this happening you 
should: 

• Assign distinctive logger IDs 
• Clearly label logger/logger housing with their IDs 
• Implement a multiple directory database structure to create a unique data directory for each 

customer. 
• Backup the database after each successful download. 

 
Question: What happens if I mix up loggers in the field and put the wrong logger in the logging housing? 
Answer: 

Warning: 
If you detect the error before download, reset memory on logger and replace logger in correct 

logging housing. You will lose the data for the period the logger was in the wrong logging 
housing. 

 
If you detect the error after downloading the data recorded for the period where the logger was 
in the wrong logging housing will not be valid. From Database Manager, use the Trim database 
command to strip the period of invalid data. Then, in Logger Manager, reset the logger memory 

and replace the logger in the correct housing. You will lose the data for that period. 

To minimize the chance of this happening you should: 
• Assign distinctive logger IDs 
• Clearly label logger/logger housing with their IDs 
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• Implement a multiple directory database structure to create unique data directory for each 
customer. 

• Backup the database after each successful download. 
 

Question: How can I transfer data from one database to a different one after I mixed up the logger ID's? 
Answer: Use Data Exchange to transfer the data to a Microsoft Excel worksheet, or to a text file, and then 
import it into the correct database. See the Data Exchange User Guide for help. 

Question: How can I regain missing data after the Logger Clock has been accidentally changed? 
Answer: Use Data Exchange to transfer the data to a Microsoft Excel worksheet, or to a text file, then 
correct the invalid dates and times and transfer back to the database. See the Data Exchange User Guide 
for help. 

Questions about sensor configuration 
Question: How do I change a faulty sensor? 
Answer: Download any existing data on the logger that you wish to save. Swap the faulty sensor/s 
making sure you replace it at the same depth and then run Database Manager, and use the Edit DB 
command to set the new air and water readings for that sensor. Save the updated logger configuration to 
the database. 

Question: How do I change sensor depths on a probe? 
Answer: Download any existing data on the logger that you wish to save. Run Database Manager, and 
use the Edit DB command. Save the configuration to a new database file using the Save As... command. 
Edit the new database, to set the configuration as desired. Save the database and send it to the logger 
using the Send to Logger command. This automatically resets the logger memory. This should only be 
done by trained staff. 

Question: Can I backup a logger's configuration? 
Answer: Yes - use Database Manager's Import/Export command, to export logger settings to floppy 
disk. 

Question: Is the complete logger configuration stored on the logger in the field? 
Answer: No - the complete logger configuration is stored only on the database. The logger stores only 
partial configuration information to ensure proper operation. 

This means you cannot access data unless you have the logger's configuration on your computer. While 
any person can access the logger with Logger Manager, only those users with the logger configuration 
on their database can access the data. This had been done for security reasons and for backup reasons as 
the logger in the field is exposed to a higher risk of damage than the user's computer. 

Hence the importance of making at least two backup copies of the logger configuration on floppy using 
export - one kept by the distributor and one by the customer. 

Question: Does export logger configuration save the database as well? 
Answer: No. 

Question: Can I backup an individual database? 
Answer: Yes - use a compression/archive program such as WinZip®. 

Question: My disk is filling up - can I archive data? 
Answer: Yes - use backup or a compression program such as WinZip® to move the data (database files) 
to archive medium and then delete the database files you no longer require regular access to. 

Note: You can also use the Trim Database command in Database Manager to keep the database file to 
a reasonable size. Refer to the Database Manager User Guide for details. 

Questions about calibrations 
Question: How do I change the coefficients in the calibration equation? 
Answer: Use the Calibration Registry dialog box to add/edit calibration equations. This can be accessed 
from the Logger Configuration dialog box. 
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Questions about circling loggers/probes between multiple sites 
Question: How do I use a logger/probe if I want to move the equipment from site to site on a weekly 
basis? 
Answer: With great care! Using the same logger or same probes on different sites can be done provided 
you are very clear and very careful about what you are doing with respect to transport, installation, 
hardware and software. 

You will need to install additional access tubes at subsequent sites, complete with bottom stopper and top 
caps. You will also need to consider the practical issues of cabling and connections - will you install cable 
at subsequent sites or move the system complete with cable? 

Most importantly, you must consider the practicalities of system transportation - how will you protect the 
system from transport damage when moving the equipment between sites? 
Transport damage where equipment is being moved between sites is outside the terms of the 
warranty. 

Because of the high risk of transportation damage and the need to do everything exactly right every time 
the system is moved, Sentek do not recommend moving the EnviroSCAN RT5/6 on a daily or weekly 
basis. 

To explain what to do with respect to software it is best to go through an example. Let's assume that you 
want to configure the logger as having four probes each with eight sensors. You want to move the system 
(i.e. logger and/or probes) between two sites and log data at each site. To do this, the logger's 
configuration must remain the same, i.e. have the same number of probes with sensors in the same 
position at both sites. 

Run Database Manager to create a new logger configuration, record air and water counts and save the 
database. Let's call the first site apples and the first logger ID 'Log-1-Apples'. After you have saved to the 
database you need to edit the logger's configuration to create the database for the second site. Be sure to 
select a different logger ID for the second logger, for example 'Log-2-Pears'. Use Save As to save the 
database. 

After you have established two databases with the one logger you can go ahead and log data. To set the 
logger with the correct configuration, simply export the correct configuration to the logger 
(Import/Export command in Database Manager) before you start to log the data. This will 
automatically reset the logger's memory and start logging data. 

Before you move to the next site, ensure you download data from the logger. 

When you download, the data will be placed in the database that corresponds to the current logger ID. 
When you physically change sites, do exactly the same thing. That is, export the correct logger 
configuration for the new site to the logger before you intend to log data. You can switch between sites as 
often as you like provided you take great care to ensure you download and you have the correct logger ID 
at the correct site. 

It is essential that you take care that the logger IDs are different and the correct one is loaded in the logger 
for the site before you start to log data. 

Question: What data can I expect if I use a logger/probe by moving the equipment from site to site? 
Answer: The data you will record for each site will have gaps in it, for example, Apples 1/11 to 7/11, 
Pears 8/11 to 15/11, Apples 16/11 to 22/11, Pears 23/11 to 29/11, etc. 

Questions about copying workspaces and files 
Question: Can I move a workspace to a different folder on my computer or from a floppy disk to my hard 
drive? 

Answer: Yes, as long as you take care of other files that the workspace may need.  

The workspace file itself (.sws file) does not contain full information about its graphs and layouts, but 
stores the location of the graph and layout files to open when opening the workspace. The graph and 
layout files in turn store the locations of their database files. In both cases, the paths of these dependent 
files are stored relative to the parent file, and in absolute terms. If you copy all associated files across with 
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the workspace, keeping any directory structure the same, everything will work correctly when the 
workspace is copied. 

When the workspace is opened from its new location, it will be able to find the files it needs using the 
relative path, and will adjust the absolute location for the files. 

Warning: 
If you do not copy all files across, your copy of the workspace will use the original layouts, 

graphs and databases. For example, if you have a workspace, graph and database on a floppy 
disc, and forget to copy the database, the graph will look in the original location (the floppy 

drive) for its database, which may lead to some confusion. 

Question: How do I tell which files my workspace is accessing? 

Answer: For graph and layout files, you can select the Save As... menu item to determine the location of 
the file. When the file dialog opens asking for a new location in which to save the file, you can click on 
the drop-down box at the top to see the directory for that file. Click on the Cancel button to close the file 
dialog. 

Databases in layouts will display their full file name if you hover the mouse over the logger icon for a 
second. Similarly, hover the mouse over the database icon in the status bar at the bottom of a graph to see  
the database file name.  

Question: Can I change the files that my workspace refers to? 

Answer: Yes. As stated above, it is recommended that you copy all files before opening the workspace 
from its new location. If you do miss some files in the initial transfer you can take the following 
corrective action. 

Open the workspace. Close any graphs and layouts that are stored in the old location and use the Open 
>Graph and Open > Layout menu commands in the Workspace Manager to load in the graph and layout 
files from the new location. Then save the workspace.  

If a layout or graph is referencing the wrong database stored in the old location (on the A: drive for 
example), you need to make the old database file unavailable. Close the graphs or layouts that reference 
the file and either rename the file or remove the floppy disk from the drive if the file is on a floppy disk. 
Reopening a layout will show the database icon dimmed with a red question mark over the top. Right  
click on the database and select the Find Missing Database... from the popup menu. This will open a file 
dialog and allow you to find the copy of the database on your machine. Save the layout to store the new 
database location. 

What can you do with the Summed Graph? 
The summed graph is used to: 

• sum all existing sensors in the profile 
• create the sum of a subset of sensors (say 30 -70cm soil depth) 
• display a single sensor  
• estimate the soil water content for soil layers, where sensors are not present using the 

interpolation command 
• average the soil water content of two or more probes if the depth setting of sensors is compatible. 
• identify the times when the soil water content goes beyond full point or onset of stress point. 
• Add agronomic budget lines and regions 
• Add growth stages to agronomic budget lines 

What is Matric Potential 
Matric Potential (matric suction, soil water suction) is defined as the negative gauge pressure, relative to 
the external gas pressure on soil water, to which a solution identical in composition with the soil solution 
must be subjected in order to be in equilibrium through a porous membrane wall with the water in the soil 
(ISSS Committee). 
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This pressure is typically measured using a tensiometer: a closed hanging column of pure water in 
contact with a porous ceramic membrane which is in intimate contact with the soil. 

Tensiometers approximate the matric potential by measuring the degree of suction (negative pressure) 
present in the soil. Variations in soil pore water ionic content and in atmospheric pressure can affect the 
readings. 

Plant roots living in the soil must exert a suction to overcome the force (matric potential) holding water in 
the soil. A saturated soil has a matric potential of zero kilopascals (0 kPa), while an almost completely 
dry soil has a matric potential of -1500 kPa. The effective range of most commercially available 
tensiometers is -10 to -85 kPa. 

What soil volume does a single sensor measure? 
A single sensor records moisture data from a soil volume outside the access tube which has a sphere of 
influence 10cm vertical height and a radial distance from the outer wall of the access tube of 10cm. 

What are the water units? 
For example, if one sensor (provided it has been calibrated) reads 1 mm that means there is 1mm of water 
content in a 100mm thick soil slice on a volume basis. For that layer (and only that layer), this amounts to 
a volumetric soil water content of 1%. 

What does 1% or 1mm volumetric soil water content / 10cm or 100mm soil depth mean? 
You require 1 liter of water to cover 1 square meter (m2) to a soil depth of 1mm. 

Ø  For metric units: 
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Ø  For Imperial measurement units: 

 

What parts of the soil profile do sensors on the probe measure? 
Probes in almost all cases have more than one sensor to monitor the depth of irrigation and the depth of 
the root zone. The first sensor is located at a soil depth of 10cm (if the datum plate of the top cap sits on 
ground level) measuring effectively the soil profile slice of 5-15cm depth. The next sensor is located at 20 
cm measuring effectively 15 -25cm soil depths. With further sensors at 10cm intervals on the probe rod, 
the measurement depth would be respectively (25-35cm, 35-45cm and so on). 

If you raise the datum plate of the top-cap 5cm above the ground surface, placing the center of the first 
sensor effectively at 5cm soil depth, the sphere of influence of the sensor will measure a soil slice from 0-
10cm. For the other sensors at 10cm depth intervals on the probe rod, the measurement depth would be 
respectively (20-30cm, 30-40cm and so on). 

 

What will be summed? 
It is your choice, given the limits of your particular number of probes, probe lengths, number of sensors 
per probe and depth location of these sensors. You choose which water content from different depth 
levels you sum up to present a total water content of an entire profile, parts of the profile or averages of 
compatible profiles. Above each graph will be a summary of which sites, probes and sensor depths you 
have selected and presented in a summed total water content. 

For example, your probe has sensors located at the following depth levels giving respective readings in 
mm: 

Depth mm H2O 
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Depth mm H2O 

10cm 13mm 

20cm 22mm 

30cm 25mm 

40cm 27mm 

50cm 28mm 

Total 115mm 

Where: 
• The total soil water content from 10 to 50 cm is 115 mm. 
• The total soil water content from 10 to 20 cm is 35mm. 
• The total soil water content from 30 to 50 cm is 80 mm. 

 
If you sum two (or more) probes with compatible sensors' depth settings, the total profile sum will be 
calculated as an average of all profile sums selected. 

How to estimate soil water content for a depth where there is no sensor? 
If you have sensors at 10, 30 and 40cm on the probe rod and no sensor at 20cm you can still calculate the 
water content from the sensors you do have and present as a summed graph.  

Note: This particular summed graph excludes the water content from 20 cm in the total sum of water 
content. It is not a true representation of the total water content in that profile. You are only adding the 
water content readings from 10cm thick, individual soil slices located at 10, 30 and 40 cm. In addition, if 
the first sensor is located at 10cm soil depth measuring effectively a depth from 5-15 cm, the water 
content from 0-5cm is being ignored. If you do not want to omit the first 5-cm of soil from your water 
content measurements, raise your datum plate of your top-cap 5 cm above ground level. 

However, the software allows you to calculate an estimation of water content for this missing value at 
20cm by using the interpolation command. This command simply takes the water content at 10 cm and 
adds it to the water content at 30 cm and then divides the value by two to give you an average or 
approximation of the missing water content. 

Note: Interpolation may only work in uniform textured and structured soil profiles. In heavy textural 
layered profiles, a correct average may not be able to be estimated. 

For example, if the 10cm sensor measures a 10cm thick, gravel band, followed by clay soil and the 30cm 
sensor measures a 10cm thick band in that clay, the average water content at 20cm would be erroneous. 

You can estimate the readings from multiple missing sensors, but only if these readings are derived in 
between an existing upper and lower sensor in the profile. You cannot estimate the water content from 
0-5cm, if your sensor is located at 10cm depth. 
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Checking current soil moisture 
After you have setup a workspace to display and manage your logger site(s), you can easily view current 
soil moisture readings at any time after data has been downloaded from the logger(s) to your database(s). 
The current soil moisture readings are displayed in summary form using the soil moisture gauge, in the 
Workspace Manager window. Multiple gauges can be displayed by adding the required graphs to your 
workspace. 

This procedure assumes that the Open last workspace on startup option is selected in the global 
settings, see page 83 for details. If you have not selected this option, you will have to open the Workspace 
from the File menu by clicking File > Open > Workspace... 

Ø  To view current soil moisture readings 
1. Open IrriMAX using one of the following methods: 

• from the desktop, double-click on  
The last workspace open displays in the Workspace Manager window. 

• from the Windows Taskbar, click the Start button and point to Programs. 
Point to Sentek, point to IrriMAX and click IrriMAX. 
The last opened workspace displays in the Workspace Manager window. 

2. The soil moisture gauge displays in the first column of the Workspace Manager window. It shows 
the condition of the most recent reading in the database. 

 

3. If the indicator on the soil moisture gauge is: 

• in the blue (top section of gauge),  the last summed value is currently above the value assigned to 
indicate the Full Point 

• in the green (middle section of gauge), the last summed value is less than the value set for the Full 
Point and greater than the value set for the Onset of Stress. Therefore, the soil water content for 
the soil profile being graphed is within the agronomic lines set. 

• in the red (bottom section of gauge), the last summed value has fallen below the value assigned to 
Onset of Stress. 
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Ø  To check soil moisture trends and details 
1. From the Workspace Manager window click on the graph Window Title. 

The graph opens and displays in the graph window. See page 135 for details of viewing graphs.  

2. When you have finished viewing the graphs, click Workspace on the graph menu bar, close 
IrriMAX by clicking Exit in the File menu. 

What are the database file access rules 
Sentek database files are opened in read-only or write mode. A database that has been opened for writing 
cannot be accessed. IrriMAX and its utilities will automatically relinquish exclusive access until the 
operation is complete. A database can be accessed for reading by many applications simultaneously. 

When a database file cannot be opened due to sharing violation the user will be alerted and advised to 
close down other applications or utilities, which may be accessing the database. Typical causes of this 
problem are 

• The database is held open in read-only by another computer. This will prevent writing operations 
(e.g. download from logger to database) from taking place. Close IrriMAX on the other 
computer. 

• Database Manager is also running, and is using one of the DB tools. Close the DB tool dialog 
and try again. 

What is involved in logger communication 
Communication with EnviroSCAN RT6 loggers from IrriMAX applications takes place in various modes 
described here. These modes are similar to the ways in which files can be opened with different 
read/write and sharing permissions under Windows. 

It is necessary to understand these issues if two or more communication utilities are running at the same 
time, as conflicts can occur if certain operations are carried out simultaneously. Some of the opening 
modes require exclusive access. This means that while a logger is open in that mode, all other open 
requests will fail. Similarly, if a logger is already open in any mode requests for exclusive access will fail. 

Anonymous and non-anonymous mode 
When IrriMAX or a utility requests opening a logger for communication, it can name a specific logger ID 
(non-anonymous) or request communication with any logger that on the specified port (anonymous). 
Opening a logger in anonymous mode will automatically open it exclusively. The condition for this to 
work is that only single logger be connected to the communication line. In the case of multiple loggers 
connected to the communication line (e.g. RS485 multidrop connection), an attempt to communicate in 
anonymous mode may fail due to communication conflicts occurring. 

Read-only, Direct and Set modes 
When communication is opened with a logger, the calling program requests a certain level of privileges 
that determine what actions it can perform. The three modes in which a logger can be opened are listed 
below. 

• Read-only mode 
This allows the program to read data and configuration information such as logger ID, number of 
sensors from the logger, number of data blocks and also the logged data. The logger clock can 
also be read in this mode. Read-only mode is non-exclusive. 

• Direct mode 
In addition to the privileges for read-only mode, direct mode allows the real-time voltages and 
sensor readings to be read from the logger. Direct mode requires exclusive access. 

• Set mode 
Set mode allows the calling program to set certain parameters in the logger such as 
communication speed, sampling interval, etc. Set mode requires exclusive access. 

• Configuration mode 
This mode allows the calling program to over-write the logger configuration (such as number of 
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sensors connected to a logger) and erase the data from the logger. Configuration mode requires 
exclusive access. 

 

Connection modes used by IrriMAX and utilities 
Logger communication takes place from Logger Manager, Data Exchange (Logger Download) and the 
logger (setup) dialog shared by IrriMAX and Database Manager.  

Data Exchange (Logger Download) always communicates in read-only mode. It usually communicates 
in non-anonymous mode. The only exception is when a logger is opened through the configuration dialog 
by specifying a COM port and baud rate. In this case, the logger will be opened anonymously in order to 
determine its ID, closed and then re-opened non-anonymously.  

Logger Manager communicates in various modes, depending on the activity being carried out. It will 
initially open in read-only mode, and stays in read-only mode until the Sensors or Voltages page is 
activated, at which point it closes the logger and reopens in direct mode. Once the logger is opened in 
direct mode it will not reopen in read-only mode if the Info or Data Blocks pages are activated. On the 
Settings page it will close and re-open in Set mode when the 'Apply' button is clicked, in order to send the 
updated time and sampling interval to the logger. 

The connection mode (read-only, direct or set) is displayed in the status bar. 

Logger Manager will use non-anonymous mode if it is supplied with a logger ID either through the 
command line or by connecting through a database. 

The logger dialog in IrriMAX and Database Manager always opens in anonymous configuration mode, 
and thus requires exclusive access. The logger is not opened until the Send to Logger button is pressed, 
and once opened it remains open until the logger dialog is closed. 

Downloading data from a logger into a database is achieved using Data Exchange with the Source 
module set to RT6. Data Exchange can use either anonymous or non-anonymous mode. 
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Glossary 
Absolute moisture value 

Absolute moisture values reflect accurate volumetric soil water content readings that have been derived 
by calibrating sensors for different depth levels for a specific site. 

Access tube 
The access tube is the cylindrical tube buried in the ground that contains the Sentek probe and its sensors. 

Active Mode FTP 
See FTP glossary entry for a description of Active Mode FTP. 

Agronomist 
An agronomist is a rural land management and productivity specialist. 

Batch file 
A batch file is a text-based file that contains one or more commands or programs to be executed when 
you run the batch file. Batch files have a .BAT file name extension (also known as Script file). 

Baud rate 
The Baud rate specifies the speed at which the data is being transmitted/received via the serial 
communication port. 

Budget line 
A budget line is the horizontal line that can be setup on an IrriMAX summed graph, to represent an 
important soil moisture value e.g. Onset of Stress and Full Point. 

Cable run 
Two cable runs can exist on an RT6 logger. Sensors send and receive information to the logger via the 
cable. The two cable runs are referred to as Run A and Run B. 

Calculated value 
The calculated value is the component of a logged reading that has been processed via the logger's 
calibration equation. The calculated value is the one used by the graphs and is a quantitative measure of 
the moisture for that sensor and that time. The other component of the reading is the original raw value, 
which was stored by the logger and then used with the equation to calculate the calculated value. 

If a calculated value is set to INVALID (-1) or ERROR (-2) then it will not appear on the graphs, and a 
single gap will appear in the graph in the place of one or more of these values. 

Calibration equation 
A calibration equation is used to convert normalized, raw sensor data into moisture units. Moisture units 
describe volumetric soil water content. Most IrriMAX users will use the default calibration equation 
supplied with the software. This equation presents data for clear identification of trends and relative 
changes. 

There can be more than one soil type within a given soil profile. Calibrations may be setup for individual 
soil types. It is important to assign the correct calibration to the correct soil type if absolute data is being 
collected. 

Cascaded 
Cascading windows enables you to see the title bars of all open windows but the windows are layered on 
the screen. Clicking on a title bar activates that window and brings it to the front of the screen. 

Chemigation 
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Chemigation. See Fertigation. 

COM port 
COM Port is the abbreviation for Communications port. A computer usually has one or two COM ports 
named COM1 and COM2, which can be used for communication to external devices, using a special 
cable e.g. modem or front panel connector on the RT6 logger housing. 

COM Port Handle 
The COM Port handle is the value provided by the operating system (Windows 98, Windows ME, 
Windows NT, Windows 2000, Windows XP) when the Remote Connection Manager is opening a 
serial COM port. This is an internal system parameter. The program that obtains this value when opening 
the COM port can pass this value to another program in order to share the COM port. 

Command line parameters 
Command line parameters allow the passing of information ('switches' and 'Arguments') to a program 
via the command line, which is not normally seen by the computer user. In a batch file, these parameters 
are specified after a space and a forward slash '/' to signify that it is a parameter (e.g. DEXC.exe /L:"MY 
LOGFILENAME.TXT"). 

Cooked value 
Cooked value is a Sentek term to describe the calibrated value resulting from passing a raw value 
through the Sentek calibration equation. 

Data Exchange 
Data Exchange is the IrriMAX utility that downloads data from Sentek devices e.g. RT6 logger, Diviner 
2000, EnviroSCAN Plus front panel or EnviroSCAN Plus Server. Data Exchange also has the capability 
to transfer data between various IrriMAX data formats. 

Database 
A database is a file that stores data. For IrriMAX, there are two types of database files: 

1. IrriMAX database (.SDB) contains the logger configuration and readings data. 

2. Irrigation & Rainfall database (.WDB), matches the soil moisture database filename (except for the 
.WDB file name extension). 

Device Parameter 
Device parameters are used by RCM. See Token. 

Dialog 
A dialog is a part of computer screen that has a title bar but does not have a menu or toolbar and 
generally cannot be resized. Dialogs often prevent accessing other windows in the application until their 
OK or Cancel button is clicked. See also: Window. 

Dimmed 
Dimmed fields (light gray) occur in edit boxes, check boxes, buttons or lists (Windows controls) when 
the control is temporarily disabled and does not accept user input. 

Dithering 
Dithering is used as a method of presenting solid graph colors on printers that cannot print solid color. 
The solid color is replaced with different dot patterns for each region. Dithered graphs may print faster 
than solid color. 

Diviner 2000 
The Sentek Diviner 2000 is a hand held portable soil moisture monitoring system. It comprises a data 
display unit and probe. The Data Exchange utility can communicate with a Diviner 2000 and download 
its collected data into an IrriMAX database. 
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Download 
Download is the process of receiving of data from another location e.g. Download from the Internet to an 
IrriMAX database. Uploading is the sending of data to another location. 

EC Units 
EC units is the abbreviation for Electrical Conductivity Units (EC). 

Electrical Conductivity Units (EC) 
Electrical Conductivity Units (EC) is the Systéme Internationale (SI) unit for electrical conductivity 
(deciSiemens per metre, dSm-1). 

Electrical Conductivity (EC) is a measure of the ability of a material to conduct electricity. The ease with 
which electrical current passes through water is proportional to the salt concentration of the water. 
Consequently, the total salt concentration of an extracted and prepared soil solution can be estimated by 
measuring the EC with an electrical conductivity meter. A higher EC means a greater salt concentration. 
A relationship between VIC and EC needs to be established. Refer to section on "Benchmarking Soil 
Salinity -TriSCAN Calibration" in the Agronomic User Manual. 

Note: The EC value of soil salinity is dependent on the technique used for sample preparation. See the 
definition of terms in the Agronomic User Manual. 

EnviroSCAN Plus 
EnviroSCAN Plus is a Sentek system that can upload its readings to the Internet. It incorporates an 
EnviroSCAN Plus probe, the Data Transmission Unit (DTU), solar panel, a modem and antenna. Data 
Exchange can download the readings from the Internet into an IrriMAX database. 

Extent 
The graph extent is the limit of graph data. Horizontal extent is the time range from earliest data point to 
latest data point. The vertical extent is the minimum and maximum value of the data currently displayed 
in the graph window. 

Fertigation 
Fertigation is the application of fertilizer via the irrigation system. This may change the salinity of the 
soil. 

Field download cable 
The Field download cable is the communications cable used to connect between a computer COM port 
and the front panel of the RT6 logger housing (see also Office download cable). 

File name extension 
A File name extension is the three (generally) characters present after the final dot in a Windows file 
name, also referred to as file name suffix. IrriMAX has some predefined file name extensions e.g. .SDB, 
.LIF. 

Firewall 
A firewall, in the context of Internet communications, is computer software (or hardware) that intercepts 
all messages transferred to a computer and prevents unauthorized messages from propagating. 

Firmware 
Firmware is a computer program stored in Read Only Memory (ROM) on an integrated circuit chip of a 
device (for example, a logger). Firmware programs are not lost when the system is turned off and are 
permanent. 

Floating window 
Floating window can be placed anywhere on the screen. They can float behind or in front of other 
window. 
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Front Panel 
The front panel is part of the EnviroSCAN Plus Data Transmission Unit (DTU). It contains the 
EnviroSCAN Plus power switch and the front panel download-connector. Behind the front panel are the 
modem, battery and solar charger circuit. 

FTP 
FTP is the acronym for File Transfer Protocol. This is a standard method for data file transfer across the 
Internet. Another common standard is HTTP. Active mode requires the remote computer to make a 
connection to your computer, which your firewall may prevent. With Passive all connections are made by 
your computer. There is little performance difference between active and passive modes 

Graph 
A graph is used to display data in a pictorial format. IrriMAX displays agronomic graphs for soil 
moisture, irrigation and rainfall data. 

HTTP 
HTTP is the acronym for Hypertext Transfer Protocol. This is a standard communication method on the 
Internet. Another standard is FTP. 

Icon 
A Windows icon is a small picture that represents the use of a data file or program. Double-clicking an 
icon opens the file or program. Minimized IrriMAX windows are also called icons. 

Interface 
The interface is the area of input and output and communication between the software, monitor 
(hardware) and the user. Sentek software uses a Windows interface environment. 

The tem "Interface board" is sometimes used to describe the circuit board at the top of a Sentek Probe 
which controls the sensors. 

Internet 
The Internet is a global network connecting millions of computers. More than 100 countries are linked 
into exchanges of data, news and opinions. 

Interpolate 
Interpolation (on a summed graph) uses the proportional reading between two sensors to establish a 
reading for a missing sensor. For example, if a graph displays readings taken from sensors positioned at 
10 and 30cm, interpolating the graph includes a non-existent sensor at the 20cm position to calculate the 
total graph. 

I&R 
I&R is an abbreviation. See Irrigation & Rainfall. 

Irrigation 
Irrigation is the application of water to a crop. The rate of water flow and the start time and duration can 
be stored in an irrigation & rainfall database, on a per site basis. 

Irrigation & Rainfall 
Irrigation & Rainfall data is stored in a (.WDB) database file, which matches a soil moisture database 
(.SDB) file in name (except for the .WDB file name extension) and in site names. The rate of water flow for 
both irrigation & rainfall, along with the start time and duration can be stored in an irrigation & rainfall 
database, on a per site basis. 

In IrriMAX, the I&R bar graph representation of this data is shown on a pane above the moisture graph. 

Logger 
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A logger is a device used to store data in the field, for later downloading to a computer. An IrriMAX 
logger is the field unit that holds readings which can be downloaded into IrriMAX.  

Logger ID 
The Logger ID is a computer readable name that uniquely identifies a Sentek logger. The Logger ID in 
the logger and in the moisture database must match. When multiple RT6 Loggers are on a single 
communication line (RS485 multiple devices), every logger must have a different Logger ID. 

Logger tree view 
A logger tree view is a pictorial representation in a tree style, of the logger, probes and sensors that make 
up a database. This view is available in the logger configuration and database manager windows. 

Matric Potential 
Matric Potential (matric suction, soil water suction) is defined as the negative gauge pressure, relative to 
the external gas pressure on soil water, to which a solution identical in composition with the soil solution 
must be subjected in order to be in equilibrium through a porous membrane wall with the water in the soil 
(ISSS Committee). 

Normalization 
For a Sentek sensor, Normalization is the process of establishing the raw count corresponding to dry air 
(near 0% moisture) and raw count corresponding to water (100% moisture). Every sensor in a probe must 
be normalized. 

Normalization container 
A normalization container is a water container containing a short length of access tube, to allow for 
normalization of the water counts of sensors on a probe. 

Office download cable 
An office download cable is a special communications cable used to connect between a computer COM 
port and an RT6 logger when it is not connected to the Logger Facility Main Board. The cable requires a 
12V DC power pack. This cable is normally used when a logger is brought back to the office for 
downloading (see also: Field download cable). 

Pane 
A Pane is a separate area of a graph window. Panes split the window into sub windows. The IrriMAX 
graph window can be split into an I&R pane, Salinity pane, custom sensors pane(s) and a primary 
moisture or matric potential pane. 

Parallel port 
A Parallel port is computer connector used for transmitting data in parallel, eight bits at a time. A 
parallel port uses a 25-pin connector. The parallel port is most commonly used for connecting printers to 
the computer. 

Parameter 
Parameter is a generic term for the value sent to a program or operation by the user or another program. 

Passive Mode FTP 
See FTP glossary entry for a description of Passive Mode FTP. 

Password 
Password is part of login identification. See User name. 

PConfig 
PConfig is the abbreviation for the Probe Configuration utility program. It is used to setup and configure 
EnviroSCAN Plus, EasyAG and EnviroSMART probes. 
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PDF 
PDF is an acronym for Portable Document Format. A type of file that electronically displays the image of 
a document exactly as it would appear if printed. PDF files are viewed using Adobe Acrobat Reader 
software, which is freely available on the Internet. 

Port 
Port number, in the context of Internet access, is the access point through which Internet data is 
transferred. HTTP protocol by default uses port 80, FTP protocol defaults to port 21. Your Hosting 
Provider will inform you if you must change from these defaults. Changing these values may require the 
updating of your computer's firewall configuration. 

Probe 
A probe takes soil moisture/salinity readings. It is a device inside an access tube which is in the soil at a 
predetermined site. The probe consists of the access tube, an interface board (5-Wire board, 
EnviroSMART interface or EasyAG interface), top cap and probe rod with sensors attached. 

Rainfall 
Rainfall is the application of rain to a crop. The rate of rainfall and the start time and duration can be 
stored in an irrigation & rainfall database, on a per site basis. 

Raw count 
A raw count is the base unit of data recorded by the RT6 logger. Raw counts are downloaded to a 
computer and converted to 'useable' data (calculated values) through the application of normalize raw 
counts and calibration equation coefficients. 

Raw data 
Raw data is a general term for data that needs further processing in order to represent the desired 
quantitative values. 

Relative value 
A relative value reflects a volumetric soil water content reading. This is derived using initial default 
calibration equation(s) supplied by Sentek Pty Ltd and may not be an absolute moisture value for a 
particular soil type. 

Retries 
Retries - The number of times software will try to repeat the communications in the event of a Time-out 
from the other device. 

Return values 
A return values is numeric code that a core program returns to Remote Connection Manager to 
indicate whether the core program was able to complete a task successfully or not. You can view return 
values and corresponding interpretation in the RCM log file. 

RS232 
RS232 is a serial communication connection standard commonly used for connecting two devices within 
a short distance. It allows full duplex communication. e.g. computer to modem, direct field connection of 
computer to RT6 logger facility (see also: RS485). 

RS485 
RS485 is a serial communication connection standard that uses only two wires and allows connection of 
multiple devices. Used for longer distances than RS232 or when multiple devices are needed on one 
communication line (see also: RS232). 

RT6 Logger 
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An RT6 logger is a Sentek proprietary logger that stores data from Sentek sensors for later download into 
IrriMAX Databases. The term RT6 logger also covers the superseded RT5, logger except where they are 
explicitly differentiated. 

RTS 
RTS is a telemetry term that means "Ready To Send". This feature is used in IrriMAX communication 
software to support remote synchronization. It is required so the computer and logger know when to send 
data to each other, or to pause while the other end is busy. 

Ruler 
A graph ruler is a vertical or horizontal line on an IrriMAX graph that can be moved from left to right, or 
up and down, using the mouse. It displays a value label at the point of interception of the ruler line with 
the graph data. The ruler is used in the graph window to move along the shape of the graph, displaying 
precise units at a specific date and time. 

Run A and Run B 
Run A is the primary cable and Run B is the secondary cable between the sites and the EnviroSCAN 
RT6 logger. 

Salinity 
The term salinity refers to the total dissolved concentration of major inorganic solutes or ions (principally 
Na+, Ca++, Mg++, K+, HCO3

-, CO3
--, SO4

-- and Cl-) in aqueous samples. As applied to soils, it refers to the 
soluble plus readily dissolvable salts in the soil, or in an aqueous extract of a soil sample. 

Salinity is quantified in terms of the total concentration of such soluble salts, or more practically, in terms 
of the EC of the solution. 

Saline soils can be defined as soils containing sufficient soluble salts to adversely affect the growth of 
plants. The soluble salts are chiefly sodium chloride and sodium sulfate, but saline soils also contain 
appreciable quantities of chlorides and sulfates of calcium and magnesium. For purposes of definition, 
saline soils are those which have an electrical conductivity of the saturation soil extract of more than 4 
dSm-1 at 25°C. 

The application of fertilizer may change the salinity of the soil. 

Sampling interval 
The sampling interval is the time between individual powering of all sensors to obtain readings. The 
Sentek RT6 logger and EnviroSCAN Plus systems schedule readings at regular sampling intervals. These 
times are set in the Sampling Interval field in the Send to Logger dialog box (RT6 Logger) or on the 
Settings tab page in IPConfig (EnviroSMART and EasyAG probes). 

Scaled frequency 
Scaled frequency is a sensor raw count reading in relation to normalized air count and water count. It is 
used in the Sentek calibration equation. 

Scaled Frequency (SF) = (AirCount - SoilCount) / (AirCount - WaterCount) 

All counts are taken within an access tube.  

Script file 
Script file - See Batch file. 

Sensor 
A sensor is the device within a Sentek probe that takes soil moisture readings, at a particular depth.  

Site 
A site is the area around the probe(s) that is having its soil profile data gathered. An IrriMAX database 
reflects the site configuration and has a logger name, one or more site names and one or more probes on 
each site. 



 IrriMAX User Guide 
 Glossary 

Sentek Pty Ltd 231 

Site Code and Site Key 
IrriMAX license registration generates a site code. You send this site code to Sentek registrations who 
generate a site key. You then use this site key to convert the IrriMAX 30 day trial into an unlimited use 
license. Each computer has a different site code and site key. 

SMTP 
Simple Mail Transfer Protocol is a standard for e-mail transmissions across the Internet. IrriMAX uses 
SMTP for e-mail transmissions. 

Splitter bar 
A splitter bar is the bar that divides two panes in a window. It usually allows the resizing of the panes 
within the window. 

SSL 
Secure Sockets Layer is a cryptographic protocol which provides secure communications on the 
Internet. IrriMAX can use SSL for e-mail transmissions. 

Telemetry 
Telemetry is the equipment involved in remote communications e.g. radio modem. 

Tiling windows 
Tiling windows enables you to see all open windows at once. Each window occupies a section of the 
screen. The size of each window is inversely proportional to the number of open windows. 

Time-out 
Time-out is the time the communications driver will wait for an answer from the device (e.g. logger) 
before it gives up and reports that it cannot communicate with the device. Factors affecting this time 
include end-to-end delay when communicating via a radio or other communications device. 

Title bar 
The title bar is the bar at the top of any window that contains the name of the program and the name of 
the open file. 

ToolTip 
A Windows tooltip is a small box containing descriptive text. It appears when you use the mouse to point 
to certain Windows objects. 

TriSCAN 
TriSCAN™ is the world's first near-continuous in-field monitoring probe that measures soil water 
content and soil salinity (VIC) throughout a soil profile. At each depth, soil water and salinity 
measurements are taken by the same sensor. The TriSCAN™ technology is protected by world patents. 

Upload 
Uploading is the process of sending of data to another location e.g. An EnviroSCAN Plus Probe uploads 
to the Internet. Download is the receiving of data from another location. 

User name 
User name is part of login identification. A user name and password may be are required for connection 
to the ES Plus server. The Hosting Provider company usually supplies the relevant user names and 
passwords. These values are entered using Edit Servers dialog in Data Exchange. These are not the same 
as your Internet user name and password, which are supplied by your ISP and are used to setup you 
Internet Network Connection. 

URL 
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URL is the acronym for Universal Resource Locator. It contains all of the information needed to access 
an object over the Internet. It is the Internet address of the host location to which you want to connect. It 
consists of a "scheme" followed by a colon then a resolvable network address (a numeric TCP/IP address 
e.g. 192.168.2.1 or a domain name e.g. www.sentek.com.au). Schemes include HTTP and FTP. 

VIC Units 
VIC is an acronym - see Volumetric Ion Content Units (VIC) 

Volumetric Ion Content Units (VIC) 
Volumetric Ion Content (VIC) is a nominal instrument value that is produced by the sensor data 
processing model. VIC does not represent the exact soil EC value. Changes of units of VIC represent 
changes in units of soil EC. The exact relationship between VIC and EC varies between soil types. A 
relationship between VIC and EC needs to be established. Refer to section on "Benchmarking Soil 
Salinity -TriSCAN Calibration" in the Agronomic User Manual. 

Measurement units of VIC can be quantitatively related (calibrated) to the soil EC through site-specific 
physical soil sampling and analysis. Similar to the soil water data, the sensor output of VIC can be 
presented as dynamic trend changes over a chosen time scale. 

Web 
Web is the abbreviation for the World Wide Web (WWW), a system of Internet servers that support 
documents formatted in a markup language called HTML (HyperText Markup Language). It supports 
links to other documents, as well as graphics, audio, and video files. This means you can jump from one 
document to another simply by clicking on hot spots. 

Web browsers make it easy to access the World Wide Web. Some of the most popular are Netscape, 
Firefox, Mozilla and Microsoft's Internet Explorer. 

Webification 
Webification is the process of converting a computer document into a form suitable for display on the 
Web. 

Webify 
To webify is to convert a computer document into a form suitable for display on the Web. 

Window 
A window is a part of the computer screen that has a title bar and generally a menu and toolbar. It may be 
resizable and you can swap between windows in one application. See also: Dialog. 

Windows (with a capital W) denotes a reference to the Microsoft Windows operating system. 

Workspace 
The Workspace is the working environment of IrriMAX. From the Workspace, you can view the current 
soil moisture or access more detailed graphs to view soil moisture trends. The Workspace contains 
references to its graphs and layouts. 

http://www.sentek.com.au)

